aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-02 15:08:31 -0400
committerHorea Christian <chr@chymera.eu>2023-05-02 15:15:14 -0400
commit754a211496a630db2841613ef2460e96963b6f38 (patch)
treedbd810d3f4f6d7194714ca1d92098c60934e1712 /dev-vcs
parentdev-python/annexremote: update SRC_URI, PYTHON_COMPAT, PEP517 bump (diff)
downloadsci-754a211496a630db2841613ef2460e96963b6f38.tar.gz
sci-754a211496a630db2841613ef2460e96963b6f38.tar.bz2
sci-754a211496a630db2841613ef2460e96963b6f38.zip
dev-vcs/datalad: brought back
This reverts commit 7405c8639adafc1064f8d4a5d023d786728422bf. Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/datalad/Manifest2
-rw-r--r--dev-vcs/datalad/datalad-0.18.0.ebuild74
-rw-r--r--dev-vcs/datalad/datalad-0.18.1.ebuild74
-rw-r--r--dev-vcs/datalad/metadata.xml30
4 files changed, 180 insertions, 0 deletions
diff --git a/dev-vcs/datalad/Manifest b/dev-vcs/datalad/Manifest
new file mode 100644
index 000000000..92f325b66
--- /dev/null
+++ b/dev-vcs/datalad/Manifest
@@ -0,0 +1,2 @@
+DIST datalad-0.18.0.tar.gz 1425155 BLAKE2B 8d7cbf7f56b1de82c74fa823b2d4512112f1b4c4be106cac433c8db696b2e7f77da758c0bb62b7cb9fe0fbb08d49431dda2818d08d5c60b5052154895c335b33 SHA512 0df8276edc3872c73fee7286ea4e578648a6fb2a630fa49a4f8945e0d6ff88353d9b11d29d942c0ce22ed17a8223e71f99d8b519a6a8afbc2ac9e6da89d95ee5
+DIST datalad-0.18.1.tar.gz 1425820 BLAKE2B 574e864feb500062f829dfea3f9c8c51f9ad2e0e68e70966c2a5ea315fafffb259de9a0f57427c0aae1ee93c24ec9a3a91ef42637d109d912cf5b6c41ac07b11 SHA512 19f011428fe66d9f21410ae33276133f26cf2b1a367c23a83c56ab48a0e038837ba18163e12ab2d74eba7d0ec9ce2e660a21494ddba0da3a2df6da2c043c4aad
diff --git a/dev-vcs/datalad/datalad-0.18.0.ebuild b/dev-vcs/datalad/datalad-0.18.0.ebuild
new file mode 100644
index 000000000..69b1a5cb5
--- /dev/null
+++ b/dev-vcs/datalad/datalad-0.18.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1
+
+DESCRIPTION="Keep code, data, containers under control with git and git-annex"
+HOMEPAGE="https://github.com/datalad/datalad"
+SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +downloaders +metadata +publish misc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ app-arch/p7zip
+ app-arch/patool[${PYTHON_USEDEP}]
+ dev-python/annexremote[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/wraps[${PYTHON_USEDEP}]
+ dev-vcs/git-annex
+ downloaders? (
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ metadata? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ )
+ misc? (
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+ publish? (
+ dev-vcs/python-gitlab[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+# Also wants test dep:
+# dev-python/types-requests
+# dev-python/types-python-dateutil
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DATALAD_TESTS_NONETWORK=1
+ # see test groups in "tox.ini"
+ epytest -k "not turtle and not slow and not usecase"
+}
diff --git a/dev-vcs/datalad/datalad-0.18.1.ebuild b/dev-vcs/datalad/datalad-0.18.1.ebuild
new file mode 100644
index 000000000..69b1a5cb5
--- /dev/null
+++ b/dev-vcs/datalad/datalad-0.18.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1
+
+DESCRIPTION="Keep code, data, containers under control with git and git-annex"
+HOMEPAGE="https://github.com/datalad/datalad"
+SRC_URI="https://github.com/datalad/datalad/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +downloaders +metadata +publish misc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ app-arch/p7zip
+ app-arch/patool[${PYTHON_USEDEP}]
+ dev-python/annexremote[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/wraps[${PYTHON_USEDEP}]
+ dev-vcs/git-annex
+ downloaders? (
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ metadata? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ )
+ misc? (
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+ publish? (
+ dev-vcs/python-gitlab[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+# Also wants test dep:
+# dev-python/types-requests
+# dev-python/types-python-dateutil
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DATALAD_TESTS_NONETWORK=1
+ # see test groups in "tox.ini"
+ epytest -k "not turtle and not slow and not usecase"
+}
diff --git a/dev-vcs/datalad/metadata.xml b/dev-vcs/datalad/metadata.xml
new file mode 100644
index 000000000..8a6c00a2d
--- /dev/null
+++ b/dev-vcs/datalad/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ DataLad makes data management and data distribution more accessible. To
+ do that, it stands on the shoulders of Git and Git-annex to deliver a
+ decentralized system for data exchange. This includes automated
+ ingestion of data from online portals and exposing it in readily usable
+ form as Git(-annex) repositories, so-called datasets. The actual data
+ storage and permission management, however, remains with the original
+ data providers.
+ </longdescription>
+ <use>
+ <flag name="downloaders">Extended support for download resources</flag>
+ <flag name="metadata">Annotated metadata support for datasets</flag>
+ <flag name="misc">Dataset publishing support</flag>
+ <flag name="publish">Dataset publishing support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">datalad/datalad</remote-id>
+ </upstream>
+</pkgmetadata>