aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-05-02 03:59:06 -0400
committerHorea Christian <chr@chymera.eu>2022-05-02 03:59:06 -0400
commit7bcf8e8fe0cc8f767d0aa5708741a67893c770d9 (patch)
tree76b2a375a99d848c696cece8bf60ad0bbc0fb295 /dev-vcs
parentdev-vcs/dandi-cli: dependency update (diff)
downloadsci-7bcf8e8fe0cc8f767d0aa5708741a67893c770d9.tar.gz
sci-7bcf8e8fe0cc8f767d0aa5708741a67893c770d9.tar.bz2
sci-7bcf8e8fe0cc8f767d0aa5708741a67893c770d9.zip
dev-vcs/dandi-cli: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/dandi-cli/Manifest1
-rw-r--r--dev-vcs/dandi-cli/dandi-cli-0.39.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-vcs/dandi-cli/Manifest b/dev-vcs/dandi-cli/Manifest
index 8fca2f322..cce81b9b2 100644
--- a/dev-vcs/dandi-cli/Manifest
+++ b/dev-vcs/dandi-cli/Manifest
@@ -1,2 +1,3 @@
DIST dandi-cli-0.37.0.tar.gz 212121 BLAKE2B a38077439edb9975b25eaffd299cba633b538d7c5a93aefeb35e8403e07896f1e93eb6b42790ca84ab20ddfe0ead850a000f857cfd3ef8c6342eb76952b95b62 SHA512 fe96b760bb8526cf2670be4523121b389ede82699a8b13a9b46e4511012ab15390d9aec35b5403fa4d52dd79738a37980bcc83755df738b4039ae56eb6ca0f14
DIST dandi-cli-0.38.0.tar.gz 322974 BLAKE2B 5451eb922019e0b06de1181161d23fac21ddbd772fb9ff5b23e296eb5ccc54c44b6c6c62d5d8f25bf075e6c93136f1db4d3ab72d372dfa7a28c84fc03008e0f3 SHA512 a77d834dadbd532ce016425fe25324582a5d2c442b52087d5751770d99c84fa9532a08525ee75f40d45ccb5c50ed11b9fbe0c29a24c7d1b24c253d218538e054
+DIST dandi-cli-0.39.4.tar.gz 329268 BLAKE2B c34674570c3474dbc12a2f96c0877a84ca3cddbf8d04cb1bc7cc47e6d03bbf4103cf8f36d4267f59bfb5da2504300e14dc007a3f23a5d807bb92cece506fb7b7 SHA512 8ac4ae25eb9b09530a017ca2812a490c578157caeb0cca2737630f9796ec4559fc2379f150764544e1cd474cf481f87bb08dd255d4bf4dcc7722c8006ae78c4b
diff --git a/dev-vcs/dandi-cli/dandi-cli-0.39.4.ebuild b/dev-vcs/dandi-cli/dandi-cli-0.39.4.ebuild
new file mode 100644
index 000000000..1f68c40bf
--- /dev/null
+++ b/dev-vcs/dandi-cli/dandi-cli-0.39.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="DANDI command line client to facilitate common operations"
+HOMEPAGE="https://github.com/dandi/dandi-cli"
+SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test etelemetry"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ ~dev-python/dandi-schema-0.6.0[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/fscacher[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/interleave[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings_alt[${PYTHON_USEDEP}]
+ dev-python/nwbinspector[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyout[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/anys[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
+ )
+"
+# Upstream might be amenable to dropping opencv:
+# https://github.com/dandi/dandi-cli/issues/944
+
+# Some tests require deep copy with git history
+# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
+EPYTEST_DESELECT=(
+ "dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
+ "dandi/tests/test_utils.py::test_get_instance_url"
+ "dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
+ "dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
+)
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.37.0-pip-versioncheck.patch"
+)
+
+src_prepare() {
+ if use etelemetry; then
+ default
+ else
+ eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
+ default
+ sed -i "/etelemetry/d" setup.cfg
+ fi
+}
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ epytest
+}