aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-03-26 09:25:44 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-03-26 09:27:02 +0800
commita01a2f74a6310651454ca3f780d030bef6a985ed (patch)
treefa8a1a3fee28f317227a248f073812321c755437 /media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild
parentsci-visualization/fsleyes: new package (diff)
downloadsci-a01a2f74a6310651454ca3f780d030bef6a985ed.tar.gz
sci-a01a2f74a6310651454ca3f780d030bef6a985ed.tar.bz2
sci-a01a2f74a6310651454ca3f780d030bef6a985ed.zip
media-libs/DualContouringSample: depend on media-libs/glm
Reported-By: Xuewei Liu Package-Manager: Portage-2.3.88, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild')
-rw-r--r--media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild b/media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild
new file mode 100644
index 000000000..28fd4d2e5
--- /dev/null
+++ b/media-libs/DualContouringSample/DualContouringSample-0_p20191111-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="A sample Dual Contouring implementation"
+HOMEPAGE="https://github.com/simoncblyth/DualContouringSample"
+
+EGIT_REPO_URI="https://github.com/simoncblyth/${PN}.git"
+EGIT_COMMIT="d5ed08c21228575f948292422cd8542cbdce255c"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/bcm
+ media-libs/glm"
+
+PATCHES=( "${FILESDIR}"/DualContouringSample-0_glm.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/${PN}
+ )
+
+ cmake-utils_src_configure
+}