aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-23 13:26:43 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-11-23 13:26:43 +0100
commitb8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637 (patch)
tree997b0823713504f7fe08073139a5199cb6cdf6ba /media-libs/glbinding
parentMerge pull request #695 from timeraider4u/giac-fix (diff)
downloadsci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.tar.gz
sci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.tar.bz2
sci-b8c8ce2ed9b9bd422a697ed1c897d8fc80c3e637.zip
media-libs/glbinding: New packages, ebuild written by me
Required by up-to-date arrayfire/forge versions Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/glbinding')
-rw-r--r--media-libs/glbinding/Manifest1
-rw-r--r--media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch29
-rw-r--r--media-libs/glbinding/glbinding-2.1.1.ebuild37
-rw-r--r--media-libs/glbinding/metadata.xml27
4 files changed, 94 insertions, 0 deletions
diff --git a/media-libs/glbinding/Manifest b/media-libs/glbinding/Manifest
new file mode 100644
index 000000000..03c0fb0c8
--- /dev/null
+++ b/media-libs/glbinding/Manifest
@@ -0,0 +1 @@
+DIST glbinding-2.1.1.tar.gz 3147406 SHA256 253671f2b730a6efa55de92a704938bb0f1761d151f3f8e87c043c51d46ea1e4 SHA512 3d4035294b1383aa71d693f34691bc5e865267e73aa21010f418126b28e4b7850a28a03d8bf3af23bb566f2ca1b53d74ce4a4ee0be962c7df6a3256eb54bb60e WHIRLPOOL 7a5f6bd10611a7c0e7a768a53a0876a3445cd0c14d833824b7b91bb9a1900ef56f5311cc009ba0821fdda5ed0166b6a7fd47bfeba0a40206ad6eaea02af92878
diff --git a/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
new file mode 100644
index 000000000..080cb7fae
--- /dev/null
+++ b/media-libs/glbinding/files/glbinding-2.1.1-CMakeLists.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,7 +103,7 @@ endif()
+ if(UNIX AND SYSTEM_DIR_INSTALL)
+ # Install into the system (/usr/bin or /usr/local/bin)
+ set(INSTALL_ROOT "share/${project}") # /usr/[local]/share/<project>
+- set(INSTALL_CMAKE "share/${project}/cmake") # /usr/[local]/share/<project>/cmake
++ set(INSTALL_CMAKE "lib/cmake") # /usr/[local]/lib/cmake
+ set(INSTALL_EXAMPLES "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_DATA "share/${project}") # /usr/[local]/share/<project>
+ set(INSTALL_BIN "bin") # /usr/[local]/bin
+@@ -159,16 +159,8 @@ add_subdirectory(deploy)
+ # Deployment (global project files)
+ #
+
+-# Install version file
+-install(FILES "${PROJECT_BINARY_DIR}/VERSION" DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-
+ # Install cmake find script for the project
+-install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_ROOT} COMPONENT dev)
+-
+-# Install the project meta files
+-install(FILES AUTHORS DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-install(FILES LICENSE DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
+-install(FILES README.md DESTINATION ${INSTALL_ROOT} COMPONENT runtime)
++install(FILES ${META_PROJECT_NAME}-config.cmake DESTINATION ${INSTALL_LIB}/cmake/${project} COMPONENT dev)
+
+ # Install runtime data
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${INSTALL_DATA} COMPONENT examples_data)
diff --git a/media-libs/glbinding/glbinding-2.1.1.ebuild b/media-libs/glbinding/glbinding-2.1.1.ebuild
new file mode 100644
index 000000000..4efac0c07
--- /dev/null
+++ b/media-libs/glbinding/glbinding-2.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cross-platform C++ binding for the OpenGL API"
+HOMEPAGE="https://github.com/cginternals/glbinding"
+SRC_URI="https://github.com/cginternals/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/glfw-3.1.1
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-3.2.2
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}"-CMakeLists.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPTION_BUILD_TESTS=OFF
+ -DOPTION_BUILD_GPU_TESTS=OFF
+ -DOPTION_BUILD_DOCS=OFF
+ -DOPTION_BUILD_EXAMPLES=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-libs/glbinding/metadata.xml b/media-libs/glbinding/metadata.xml
new file mode 100644
index 000000000..4d6a1c0ac
--- /dev/null
+++ b/media-libs/glbinding/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ glbinding leverages modern C++11 features like enum classes,
+ lambdas, and variadic templates, instead of relying on macros; all
+ OpenGL symbols are real functions and variables. It provides
+ type-safe parameters, per feature API header, lazy function
+ resolution, multi-context and multi-thread support, global and local
+ function callbacks, meta information about the generated OpenGL
+ binding and the OpenGL runtime, as well as tools and examples for
+ quick-starting your projects. Based on the OpenGL API specification
+ (gl.xml) glbinding is generated using python scripts and templates
+ that can be easily adapted to fit custom needs.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cginternals/glbinding</remote-id>
+ </upstream>
+</pkgmetadata>