aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 12:46:41 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 12:46:41 +0100
commit6a2913691ed760852e730ec4b2fbef1f174ca263 (patch)
tree91cecdce7bafcbaa629f83f46c24155c77015ce7 /media-libs/yocto-gl
parentmedia-libs/implicitmesher: update snapshot (diff)
downloadsci-6a2913691ed760852e730ec4b2fbef1f174ca263.tar.gz
sci-6a2913691ed760852e730ec4b2fbef1f174ca263.tar.bz2
sci-6a2913691ed760852e730ec4b2fbef1f174ca263.zip
media-libs/yocto-gl: version bump 3.3.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'media-libs/yocto-gl')
-rw-r--r--media-libs/yocto-gl/Manifest1
-rw-r--r--media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch27
-rw-r--r--media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild27
-rw-r--r--media-libs/yocto-gl/yocto-gl-3.3.0.ebuild39
4 files changed, 40 insertions, 54 deletions
diff --git a/media-libs/yocto-gl/Manifest b/media-libs/yocto-gl/Manifest
new file mode 100644
index 000000000..e1a26da8c
--- /dev/null
+++ b/media-libs/yocto-gl/Manifest
@@ -0,0 +1 @@
+DIST yocto-gl-3.3.0.tar.gz 196860271 BLAKE2B a2b563a16d9b07a1e92fe5f05de56d1cc21abe2dd05b2d72700feba020989c60aa676072e70ebb83cd6cba0ea8dba521d6c8ee2d894a012a070773a715315171 SHA512 f6b824fe1b546a29a093ab7932fb2c5ca4e194813dfcc45e22f0f1532bf0693ef92ebe95eeeba6f02f8a46368925cea2275189ab2c4d022620e8ac4d8d2f4648
diff --git a/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch b/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch
deleted file mode 100644
index 711438fd4..000000000
--- a/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: yocto-gl-0_p20191111/CMakeLists.txt
-===================================================================
---- yocto-gl-0_p20191111.orig/CMakeLists.txt
-+++ yocto-gl-0_p20191111/CMakeLists.txt
-@@ -3,7 +3,8 @@ set(name YoctoGL)
- project(${name} VERSION 0.1.0)
-
- include(CTest)
--include(OpticksBuildOptions)
-+find_package(BCM)
-+include(BCMDeploy)
- #[=[
- YoctoGL
- ========
-@@ -14,12 +15,6 @@ Opticks currently uses only glTF 2.0 rea
-
- #]=]
-
--include(GNUInstallDirs)
--set(CMAKE_INSTALL_INCLUDEDIR "externals/include/${name}")
--set(CMAKE_INSTALL_LIBDIR "externals/lib")
--set(CMAKE_INSTALL_BINDIR "lib")
--
--
- set(SOURCES
- yocto/yocto_img.cpp
- yocto/yocto_gltf.cpp
diff --git a/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild b/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild
deleted file mode 100644
index 9dbee5ab4..000000000
--- a/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils git-r3
-
-DESCRIPTION="Single File Libraries for Physically-Based Graphics"
-HOMEPAGE="https://github.com/simoncblyth/yocto-gl"
-
-EGIT_REPO_URI="https://github.com/simoncblyth/yocto-gl.git"
-EGIT_COMMIT="3cfcfacafece377b4542a0ffea4030bf13ae8b3c"
-KEYWORDS="~amd64"
-
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND="dev-util/bcm"
-PATCHES=( "${FILESDIR}"/yocto-gl-0_bcm-include.patch )
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_INCLUDEDIR=include/YoctoGL
- )
-
- cmake-utils_src_configure
-}
diff --git a/media-libs/yocto-gl/yocto-gl-3.3.0.ebuild b/media-libs/yocto-gl/yocto-gl-3.3.0.ebuild
new file mode 100644
index 000000000..e6102dde1
--- /dev/null
+++ b/media-libs/yocto-gl/yocto-gl-3.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit cmake python-any-r1 docs
+
+DESCRIPTION="Single File Libraries for Physically-Based Graphics"
+HOMEPAGE="https://github.com/simoncblyth/yocto-gl"
+SRC_URI="https://github.com/xelatihy/yocto-gl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-util/bcm"
+
+src_prepare() {
+ sed -i -e 's/isnan/std::isnan/g' libs/yocto/yocto_mesh.cpp || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/YoctoGL
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ docs_compile
+ cmake_src_compile
+}