aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Mitrak <lucas@lucasmitrak.com>2021-07-26 13:48:33 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-31 13:11:53 +0200
commit1a90a9bd6a062ab4f93fb3cc6a9c5b37445b4bd3 (patch)
tree3338d802eb2f8639ea307b7cc1d81cd66e4009ef /media-libs
parentsci-libs/nipype: PYTHON_COMPAT update (diff)
downloadsci-1a90a9bd6a062ab4f93fb3cc6a9c5b37445b4bd3.tar.gz
sci-1a90a9bd6a062ab4f93fb3cc6a9c5b37445b4bd3.tar.bz2
sci-1a90a9bd6a062ab4f93fb3cc6a9c5b37445b4bd3.zip
media-libs/libgfx: version bump to 1.1.1 which is hosted on github
* Version bump to 1.1.1 which is hosted on github on its own branch Currently, the science repo only has media-libs/libgfx-1.1.0. Upstream has made available version 1.1.1; however, it is not located in 1.1.0's SRC_URI [1]. Instead, he made version 1.1.1 available on github in its own branch [2]. This new version implements both patches stored in the ebuild's files directory[3]. These patches were made available upstream by me, Lucas Mitrak, via email. This commit was tested in a docker image with dev-util/ebuildtester. This commit was written, tested, and submitted by Lucas Mitrak. [1] http://mgarland.org/files/dist/ [2] https://github.com/mjgarland/libgfx/tree/branch-1.1.1 [3] https://github.com/gentoo/sci/tree/master/media-libs/libgfx/files Closes: https://github.com/gentoo/sci/pull/1100 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Lucas Mitrak <lucas@lucasmitrak.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libgfx/Manifest1
-rw-r--r--media-libs/libgfx/libgfx-1.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libgfx/Manifest b/media-libs/libgfx/Manifest
index c18a5b7eb..68c9b5f8d 100644
--- a/media-libs/libgfx/Manifest
+++ b/media-libs/libgfx/Manifest
@@ -1 +1,2 @@
DIST libgfx-1.1.0.tar.gz 145470 BLAKE2B bbf80adc726f9b4030c22365526af284a3843cf487fb5f606318d651af39d3866cb02d846969735e65aba0c857b715d4c10fcf443f22bb2cb3f65ac642999e29 SHA512 b23744225a63a77f17a78eb49b39e89a5d8c695cac62e1a399516c0e1728074ca80275fccb91cb3a128f20c2a8c66a6756005ba2d2ef9c251be36e3b3ba95d9b
+DIST libgfx-1.1.1.tar.gz 145075 BLAKE2B dab3bf0c4ddde672a3588fa88dc931db5deeef2e5e51ee6adb80ab500796677d200d4cec157828011cde5146c883cad80aae2cd69603e8f68dc67996ef84fc95 SHA512 264288a91ee9a1062bd36fa6ef381f27813e7c87949e8a1e7723f936fc1827d0a63252f2897b393f90ad0c6d47d0d413b5779194b05141efd618fc841b6bb6ff
diff --git a/media-libs/libgfx/libgfx-1.1.1.ebuild b/media-libs/libgfx/libgfx-1.1.1.ebuild
new file mode 100644
index 000000000..6cbedc968
--- /dev/null
+++ b/media-libs/libgfx/libgfx-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simplify the creation of computer graphics software"
+HOMEPAGE="http://mgarland.org/software/libgfx.html"
+
+COMMIT="f28ca5f0df3044f6399d6214faf66daa36712b91"
+SRC_URI="https://github.com/mjgarland/libgfx/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ virtual/opengl
+ x11-libs/fltk
+"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd src || die
+ default
+}
+
+src_install() {
+ use static-libs && dolib.a src/*.a
+ doheader include/gfx/gfx.h
+
+ dodoc doc/*
+}
+
+src_test() {
+ cd tests || die
+ sed -i -e 's/t-vec.cxx t-img.cxx t-gui.cxx t-glimg.cxx t-script.cxx t-glext.cxx/t-vec.cxx t-img.cxx t-script.cxx/' Makefile
+ emake
+}