aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-05-11 16:33:08 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-05-11 16:33:08 +0200
commita02ec57710056dc66553c28d195110b87e7abd6d (patch)
treea5f3d6149c75f6093d8f768fd842ea21e41d51a0 /media-libs
parentdev-python/numba: drop old (diff)
downloadsci-a02ec57710056dc66553c28d195110b87e7abd6d.tar.gz
sci-a02ec57710056dc66553c28d195110b87e7abd6d.tar.bz2
sci-a02ec57710056dc66553c28d195110b87e7abd6d.zip
media-libs/libredwg: add package
use this with >=media-gfx/freecad-0.19 to import autocad dwg files (2D only) Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libredwg/Manifest1
-rw-r--r--media-libs/libredwg/libredwg-0.12.4.ebuild75
-rw-r--r--media-libs/libredwg/metadata.xml8
3 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/libredwg/Manifest b/media-libs/libredwg/Manifest
new file mode 100644
index 000000000..1899b90fb
--- /dev/null
+++ b/media-libs/libredwg/Manifest
@@ -0,0 +1 @@
+DIST libredwg-0.12.4.tar.gz 18318912 BLAKE2B 21ff443881c19782c747ddf880eba23090295432edf4367161472aeef970e1b93983967e667ca2c3e140bf0b97e7b238bbe4a342815df365cee10bde83a04178 SHA512 df9424f475be512a6e9e02a1156a7d6a966f684f5753f420843593ee9dc236bd33bd10dbd627bab1b9adab9b8e7cb3a6b464c15e643ae755bc7e11974c05cd7a
diff --git a/media-libs/libredwg/libredwg-0.12.4.ebuild b/media-libs/libredwg/libredwg-0.12.4.ebuild
new file mode 100644
index 000000000..459e83e54
--- /dev/null
+++ b/media-libs/libredwg/libredwg-0.12.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DOCS_BUILDER="doxygen"
+# File is hardcoded to be run from ../ so we use this instead of DOCS_DIR
+DOCS_CONFIG_NAME="doc/Doxyfile"
+
+inherit docs python-single-r1 perl-functions
+
+DESCRIPTION="C library to handle DWG files"
+HOMEPAGE="https://www.gnu.org/software/libredwg/"
+SRC_URI="https://github.com/LibreDWG/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug python perl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ perl? ( dev-lang/perl )
+ dev-libs/libpcre2
+ dev-libs/pslib
+"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ perl? ( dev-lang/swig )
+"
+
+src_configure() {
+ perl_set_version
+ local myconf=(
+ --enable-write
+ --enable-dxf
+ --enable-json
+ --disable-gcov
+ $(usex debug "--disable-release" "--enable-release")
+ $(use_enable debug trace)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable python python "${EPYTHON}")
+ $(usex perl "--with-perl-install=vendor" "--with-perl-install=no")
+ )
+
+ if use python || use perl; then
+ myconf+=( --enable-bindings )
+ else
+ myconf+=( --disable-bindings )
+ fi
+
+ econf ${myconf[@]}
+
+ # Fix variable references itself error, fails in src_install otherwise.
+ # Can't put this in src_prepare and use eautoreconf because eautoreconf
+ # only works inside a git repository for this package.
+ sed -i -e 's/TEXINPUTS = "$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS = "$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile || die
+}
+
+src_compile() {
+ perl_set_version
+ emake
+ docs_compile
+}
+
+src_install() {
+ perl_set_version
+ default
+ use python && python_optimize
+ use perl && perl_domodule bindings/perl/LibreDWG.pm
+}
diff --git a/media-libs/libredwg/metadata.xml b/media-libs/libredwg/metadata.xml
new file mode 100644
index 000000000..ae9640ffb
--- /dev/null
+++ b/media-libs/libredwg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>