aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-12-03 23:51:05 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-12-03 23:51:05 +0800
commitc87d96ad5f7e3db23b7f0041fee391c5fe0fccc6 (patch)
tree1956a5f69d64210513f96a2d7b7cb4ff5539be0c /media-libs
parentsci-physics/opticks: depend on sci-physics/opticks-okconf. (diff)
downloadsci-c87d96ad5f7e3db23b7f0041fee391c5fe0fccc6.tar.gz
sci-c87d96ad5f7e3db23b7f0041fee391c5fe0fccc6.tar.bz2
sci-c87d96ad5f7e3db23b7f0041fee391c5fe0fccc6.zip
media-libs/yocto-gl: initial commit of 0_p20191111.
This is included as a dependency of sci-physics/opticks. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch27
-rw-r--r--media-libs/yocto-gl/metadata.xml7
-rw-r--r--media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild27
3 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch b/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch
new file mode 100644
index 000000000..711438fd4
--- /dev/null
+++ b/media-libs/yocto-gl/files/yocto-gl-0_bcm-include.patch
@@ -0,0 +1,27 @@
+Index: yocto-gl-0_p20191111/CMakeLists.txt
+===================================================================
+--- yocto-gl-0_p20191111.orig/CMakeLists.txt
++++ yocto-gl-0_p20191111/CMakeLists.txt
+@@ -3,7 +3,8 @@ set(name YoctoGL)
+ project(${name} VERSION 0.1.0)
+
+ include(CTest)
+-include(OpticksBuildOptions)
++find_package(BCM)
++include(BCMDeploy)
+ #[=[
+ YoctoGL
+ ========
+@@ -14,12 +15,6 @@ Opticks currently uses only glTF 2.0 rea
+
+ #]=]
+
+-include(GNUInstallDirs)
+-set(CMAKE_INSTALL_INCLUDEDIR "externals/include/${name}")
+-set(CMAKE_INSTALL_LIBDIR "externals/lib")
+-set(CMAKE_INSTALL_BINDIR "lib")
+-
+-
+ set(SOURCES
+ yocto/yocto_img.cpp
+ yocto/yocto_gltf.cpp
diff --git a/media-libs/yocto-gl/metadata.xml b/media-libs/yocto-gl/metadata.xml
new file mode 100644
index 000000000..7203fb853
--- /dev/null
+++ b/media-libs/yocto-gl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild b/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild
new file mode 100644
index 000000000..9dbee5ab4
--- /dev/null
+++ b/media-libs/yocto-gl/yocto-gl-0_p20191111.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Single File Libraries for Physically-Based Graphics"
+HOMEPAGE="https://github.com/simoncblyth/yocto-gl"
+
+EGIT_REPO_URI="https://github.com/simoncblyth/yocto-gl.git"
+EGIT_COMMIT="3cfcfacafece377b4542a0ffea4030bf13ae8b3c"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-util/bcm"
+PATCHES=( "${FILESDIR}"/yocto-gl-0_bcm-include.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/YoctoGL
+ )
+
+ cmake-utils_src_configure
+}