aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-10-12 20:27:12 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-10-12 20:27:12 +0000
commit88941983f871d364e4e5f5aa91f004cc32dd2897 (patch)
treeb585826c112189f0bcee74841e1529663dc48e00 /sci-astronomy/ds9/ds9-4.0_beta7.ebuild
parentgit-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@360 32389bae-... (diff)
downloadsci-88941983f871d364e4e5f5aa91f004cc32dd2897.tar.gz
sci-88941983f871d364e4e5f5aa91f004cc32dd2897.tar.bz2
sci-88941983f871d364e4e5f5aa91f004cc32dd2897.zip
ds9-4.0_beta10: updated version and patches.
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@361 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy/ds9/ds9-4.0_beta7.ebuild')
-rw-r--r--sci-astronomy/ds9/ds9-4.0_beta7.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
deleted file mode 100644
index f79939387..000000000
--- a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit flag-o-matic eutils
-
-MY_PV="4.0b7"
-DESCRIPTION="Astronomical imaging and data visualization application for FITS images"
-HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
-SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${MY_PV}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc xpa"
-DEPEND=">=sys-devel/gcc-3.4
- virtual/x11"
-RDEPEND="virtual/x11"
-
-S=${WORKDIR}/sao${PN}
-
-# This is a long and fragile compilation
-# which recompiles tcl/tk, blt, funtools, and who knows what else
-# The make install in src_compile only install and strip the ds9 exec
-# One day scientists will use tools like autotools, cmake, scons
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # The patch is to speed up the compilation
- # (avoid generating tcl man files for ex.)
- # and avoid local install bugs with symbolic linking.
- epatch ${FILESDIR}/${PN}-Makefile.patch
-}
-
-src_compile() {
- ! is-flag -fPIC && append-flags -fPIC
- sed -i -e '1i #!/bin/sh' funtools-*/filter/inc.sed
- use x86 && ln -s make.linux make.include
- use amd64 && ln -s make.linux64 make.include
- emake -j1 || die "emake failed"
- # only install locally
- make install || die "make install (local) failed"
-}
-
-src_install () {
- dobin bin/ds9
- if use xpa; then
- dobin bin/xpa*
- doman man/man?/xpa*
- fi
- dodoc README acknowledgement copyright
- use doc && dohtml ds9/doc/*
-}