aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-02 09:22:17 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-02 09:22:17 +0000
commitef49ba597c3d366d5b4ce4d25ae55faa3bf4bb5b (patch)
treef207711ae1b2e602fbc75bb60aa5887dec03e061 /sci-astronomy/scamp/files
parentopenmotif, not motif (diff)
downloadsci-ef49ba597c3d366d5b4ce4d25ae55faa3bf4bb5b.tar.gz
sci-ef49ba597c3d366d5b4ce4d25ae55faa3bf4bb5b.tar.bz2
sci-ef49ba597c3d366d5b4ce4d25ae55faa3bf4bb5b.zip
scamp:version bump and fixes
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1172 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy/scamp/files')
-rw-r--r--sci-astronomy/scamp/files/scamp-1.4.6-plplot.patch57
-rw-r--r--sci-astronomy/scamp/files/scamp-atlas.patch25
2 files changed, 57 insertions, 25 deletions
diff --git a/sci-astronomy/scamp/files/scamp-1.4.6-plplot.patch b/sci-astronomy/scamp/files/scamp-1.4.6-plplot.patch
new file mode 100644
index 000000000..2f3a71321
--- /dev/null
+++ b/sci-astronomy/scamp/files/scamp-1.4.6-plplot.patch
@@ -0,0 +1,57 @@
+--- configure.ac.orig 2008-05-31 17:35:29.000000000 +0100
++++ configure.ac 2008-07-01 23:42:06.624440703 +0100
+@@ -23,7 +23,7 @@
+ sinclude(acx_atlas.m4)
+ sinclude(acx_cdsclient.m4)
+ sinclude(acx_fftw.m4)
+-sinclude(acx_plplot.m4)
++#sinclude(acx_plplot.m4)
+ sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_pthread.m4)
+ sinclude(acx_urbi_resolve_dir.m4)
+@@ -93,17 +93,9 @@
+
+ # Provide a special option for PlPLOT
+ AC_ARG_WITH(plplot,
+- [AC_HELP_STRING([--with-plplot@<:@=<PLPlot dir>@:>@],
+- [Provide an alternative path to the PLPlot library])],
+- use_plplot="yes"
+- if "$withval" == "no"; then
+- use_plplot="no"
+- fi
+- if test "$withval" != "yes"; then
+- plplot_dir=$withval
+- fi,
+- use_plplot="yes"
+- )
++ [AC_HELP_STRING([--with-plplot],
++ [Build with the PLPlot library])])
++
+
+ # Provide special option for debugging
+ AC_MSG_CHECKING([for debugger mode])
+@@ -239,19 +231,14 @@
+ fi
+
+ ################# handle the PLPlot library (graphic plots) ##################
+-if test "$use_plplot" = "yes"; then
+- ACX_PLPLOT(,,[use_plplot=no])
+- if test "$use_plplot" = "no"; then
+- AC_MSG_WARN(PLPlot library not found! Plotting deactivated.)
+- fi
+-fi
+-
+-if test "$use_plplot" = "yes"; then
++if test x"$with_plplot" = x"yes"; then
++ PKG_PROG_PKG_CONFIG
++ PKG_CHECK_MODULES(PLPLOT, plplot)
+ AC_SUBST(PLPLOT_CFLAGS)
+ [CFLAGS="$CFLAGS $PLPLOT_CFLAGS"]
+ [LIBS="$PLPLOT_LIBS $PTHREAD_LIBS $LIBS"]
+- fi
+-AM_CONDITIONAL(USE_PLPLOT, test $use_plplot = "yes")
++fi
++AM_CONDITIONAL(USE_PLPLOT, test x"$with_plplot" = x"yes")
+
+ # Special optimization options for the INTEL C compiler
+ if test $use_icc = "yes" && test $CC = "icc"; then
diff --git a/sci-astronomy/scamp/files/scamp-atlas.patch b/sci-astronomy/scamp/files/scamp-atlas.patch
deleted file mode 100644
index 3df2b5bc3..000000000
--- a/sci-astronomy/scamp/files/scamp-atlas.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- configure.ac.orig 2007-11-08 15:38:10.146227506 +0000
-+++ configure.ac 2007-11-08 15:38:35.895694885 +0000
-@@ -217,11 +217,7 @@
-
- ################## handle the ATLAS library(linear algebra) ##################
- if test "$use_atlas" = "yes"; then
-- if test "$use_pthreads" = "yes"; then
-- LIBS="-llapack -lptcblas -lcblas -latlas $LIBS"
-- else
-- LIBS="-llapack -lcblas -latlas $LIBS"
-- fi
-+ LIBS="ATLAS_LIBDIR -llapack -lcblas -latlas $LIBS"
- else
- AC_MSG_ERROR([CBLAS/LAPack library not found! Exiting.])
- fi
---- src/Makefile.am.orig 2007-11-08 15:38:45.072217825 +0000
-+++ src/Makefile.am 2007-11-08 15:39:24.090441347 +0000
-@@ -4,6 +4,7 @@
-
- if USE_PLPLOT
- CPLOTSOURCE = cplot.c
-+AM_CFLAGS = @PLPLOT_CFLAGS@ $(CFLAGS)
- endif
-
- bin_PROGRAMS = scamp