aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 14:30:45 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 14:30:45 -0700
commitf3ee6dc28a12b5f8bbb4997d949930f8a74b7783 (patch)
tree3021fca250e43f08f22e0a5721a2a91548fbd0f3 /sci-astronomy/scamp
parentsci-astronomy/sextractor: Live version, introduced prefix love (diff)
downloadsci-f3ee6dc28a12b5f8bbb4997d949930f8a74b7783.tar.gz
sci-f3ee6dc28a12b5f8bbb4997d949930f8a74b7783.tar.bz2
sci-f3ee6dc28a12b5f8bbb4997d949930f8a74b7783.zip
sci-astronomy/scamp: live version
Diffstat (limited to 'sci-astronomy/scamp')
-rw-r--r--sci-astronomy/scamp/ChangeLog6
-rw-r--r--sci-astronomy/scamp/scamp-1.7.0-r2.ebuild15
-rw-r--r--sci-astronomy/scamp/scamp-9999.ebuild60
3 files changed, 74 insertions, 7 deletions
diff --git a/sci-astronomy/scamp/ChangeLog b/sci-astronomy/scamp/ChangeLog
index 0ce6588e7..a50a19150 100644
--- a/sci-astronomy/scamp/ChangeLog
+++ b/sci-astronomy/scamp/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/scamp/ChangeLog,v 1.7 2011/08/04 18:32:22 bicatali Exp $
+*scamp-9999 (04 Jul 2012)
+
+ 04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> scamp-1.7.0-r2.ebuild,
+ +scamp-9999.ebuild:
+ Live version, introduced prefix love
+
15 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> scamp-1.7.0-r2.ebuild:
Fixed patch name
diff --git a/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild b/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild
index 69c4b2c36..d99ab48bc 100644
--- a/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild
+++ b/sci-astronomy/scamp/scamp-1.7.0-r2.ebuild
@@ -11,22 +11,23 @@ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
LICENSE="CeCILL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc threads plplot"
RDEPEND=">=sci-astronomy/cdsclient-3.4
virtual/cblas
- sci-libs/atlas
+ sci-libs/atlas[lapack]
sci-libs/fftw:3.0
plplot? ( sci-libs/plplot )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+DEPEND="${RDEPEND}"
src_prepare() {
local mycblas=atlcblas myclapack=atlclapack
if use threads; then
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
+ myclapack=ptclapack
fi
# fix the configure and not the acx_atlas.m4. the eautoreconf will
# produce a configure giving a wrong install Makefile target (to fix)
@@ -35,7 +36,7 @@ src_prepare() {
-e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
-e "s/-llapack/-l${myclapack}/g" \
-e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
- configure || die "sed acx_atlas.m4 failed"
+ configure || die
epatch "${FILESDIR}"/${P}-plplot599.patch
}
diff --git a/sci-astronomy/scamp/scamp-9999.ebuild b/sci-astronomy/scamp/scamp-9999.ebuild
new file mode 100644
index 000000000..8208cc152
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+if [[ ${PV} == "9999" ]] ; then
+ _SVN=subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit ${_SVN} autotools
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc plplot threads"
+
+RDEPEND=">=sci-astronomy/cdsclient-3.4
+ virtual/cblas
+ sci-libs/atlas[lapack]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
+ myclapack=ptclapack
+ fi
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*
+}