aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-02 17:54:05 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2007-08-02 17:54:05 +0000
commita3cb36a92f5d82e550ef48ded02a3bc7d88e746d (patch)
tree856788fd5579a18e2ff07f90372e89340cfdfb8b /sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild
parentremoved ds9, now in main tree (diff)
downloadsci-a3cb36a92f5d82e550ef48ded02a3bc7d88e746d.tar.gz
sci-a3cb36a92f5d82e550ef48ded02a3bc7d88e746d.tar.bz2
sci-a3cb36a92f5d82e550ef48ded02a3bc7d88e746d.zip
sci-astronomy/sextractor: filter optim flags
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@680 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild')
-rw-r--r--sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild b/sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild
index f5c1a2cdc..5c4200427 100644
--- a/sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild
+++ b/sci-astronomy/sextractor/sextractor-2.5.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="Extract catalogs of sources from astronomical FITS images."
HOMEPAGE="http://terapix.iap.fr/soft/sextractor"
@@ -19,6 +19,8 @@ src_compile() {
CONFDIR=/usr/share/${PN}/config
# change default configuration files location from current dir
sed -i -e "s:default\.:${CONFDIR}/default\.:" src/preflist.h
+ # buggy with >= O2
+ replace-flags -O[2-9] -O1
local myconf
[[ "$(tc-getCC)" == "icc" ]] \
&& myconf="${myconf} --enable-icc"