aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2011-05-17 15:15:32 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2011-05-17 15:15:32 +0100
commit3f4c408e59767ed047a637d280cef70aa5dcec14 (patch)
tree32d1d12557d459bb00de3b364fa0850c27a0a97b /sci-astronomy
parentsci-mathematics/giac: QA fixes (diff)
downloadsci-3f4c408e59767ed047a637d280cef70aa5dcec14.tar.gz
sci-3f4c408e59767ed047a637d280cef70aa5dcec14.tar.bz2
sci-3f4c408e59767ed047a637d280cef70aa5dcec14.zip
added casacore
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/casacore/Manifest6
-rw-r--r--sci-astronomy/casacore/casacore-1.2.20110516.ebuild50
-rw-r--r--sci-astronomy/casacore/files/1.2.20110516-headers.patch22
-rw-r--r--sci-astronomy/casacore/files/1.2.20110516-implicits.patch166
-rw-r--r--sci-astronomy/casacore/files/1.2.20110516-libdir.patch196
-rw-r--r--sci-astronomy/casacore/metadata.xml10
6 files changed, 450 insertions, 0 deletions
diff --git a/sci-astronomy/casacore/Manifest b/sci-astronomy/casacore/Manifest
new file mode 100644
index 000000000..6e081f258
--- /dev/null
+++ b/sci-astronomy/casacore/Manifest
@@ -0,0 +1,6 @@
+AUX 1.2.20110516-headers.patch 936 RMD160 0775642a72727df99130b41c484d69f034410992 SHA1 7ede5cb0f92cc5cf6ed9ce1d1beda191ad7d5c4e SHA256 34769b047fabff24e6da4069d040c6f5f44e393170831925c14d5391394d9444
+AUX 1.2.20110516-implicits.patch 6423 RMD160 01569cd7ec3b5f4cb6498722945fb1a9eccf87a2 SHA1 512e292f7a9ea90ec87950a9a5c70e94cf91a020 SHA256 7f537b6a7404d185580b3ad12676f87a718f9e92ffab24229888959f323879f4
+AUX 1.2.20110516-libdir.patch 8284 RMD160 dcecff84020fff3f7fb91386a3c338b5fda26c44 SHA1 1fdc9e7f8087918d6511d1ccdf717c1e078f1be7 SHA256 112112db01eca5657a08a492b923f96c183d6e77aa9d6ca1d2402fd7aedb72a2
+DIST casacore-1.2.20110516.tar.bz2 4649168 RMD160 3d0f7df94b88b93a3cd36b5f76e01538f37b0877 SHA1 57e9b1b19a61c846d7ceeeeb575ff92998b011fc SHA256 d47a113038bf26a4431bbbeb4821b0e245a452fc1d63ffe4d9df2af0d3155ca7
+EBUILD casacore-1.2.20110516.ebuild 1099 RMD160 76ece8f9079b711e047819a6c89f9a8f3216dd12 SHA1 1f8b3e97e52db514f1724ce69a563e28b8622bca SHA256 686eb5146c308be21d3bb886565ed227bd2334545e3e85ef9e42848407a419f7
+MISC metadata.xml 391 RMD160 2b9d91edfd432ddf16694c417d25e89eaa13da42 SHA1 c6300dc3bf52bdd055804ad2f2c2480cc2304dcb SHA256 58c9dd33f794ccc2a1243b05da6f787660e1d844ba29c62f264b780793ab01b8
diff --git a/sci-astronomy/casacore/casacore-1.2.20110516.ebuild b/sci-astronomy/casacore/casacore-1.2.20110516.ebuild
new file mode 100644
index 000000000..deec38284
--- /dev/null
+++ b/sci-astronomy/casacore/casacore-1.2.20110516.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
+HOMEPAGE="http://code.google.com/p/casacore/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc fftw hdf5 test"
+
+RDEPEND="sci-libs/cfitsio
+ sci-astronomy/wcslib
+ virtual/blas
+ virtual/lapack
+ sys-libs/readline
+ hdf5? ( sci-libs/hdf5 )
+ fftw? ( >=sci-libs/fftw-3 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PV}-{headers,implicits,libdir}.patch )
+
+src_configure() {
+ has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
+ mycmakeargs+=(
+ -DENABLE_SHARED=YES
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use_use hdf5 HDF5)
+ $(cmake-utils_use_use fftw FFTW3)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && doxygen doxygen.cfg
+}
+
+src_install(){
+ cmake-utils_src_compile
+ use doc && dohtml -r doc/html
+}
diff --git a/sci-astronomy/casacore/files/1.2.20110516-headers.patch b/sci-astronomy/casacore/files/1.2.20110516-headers.patch
new file mode 100644
index 000000000..21cc86fc9
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.2.20110516-headers.patch
@@ -0,0 +1,22 @@
+diff -Nur casacore-1.2.20110516.orig/casa/Arrays/IPosition.h casacore-1.2.20110516/casa/Arrays/IPosition.h
+--- casacore-1.2.20110516.orig/casa/Arrays/IPosition.h 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/casa/Arrays/IPosition.h 2011-05-17 06:04:15.000000000 +0100
+@@ -33,6 +33,7 @@
+ #include <casa/iosfwd.h>
+ #include <casa/BasicSL/String.h>
+ #include <vector>
++#include <cstddef>
+ #include <unistd.h>
+
+ namespace casa { //# NAMESPACE CASA - BEGIN
+diff -Nur casacore-1.2.20110516.orig/casa/Containers/Block.h casacore-1.2.20110516/casa/Containers/Block.h
+--- casacore-1.2.20110516.orig/casa/Containers/Block.h 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.2.20110516/casa/Containers/Block.h 2011-05-17 06:05:55.000000000 +0100
+@@ -28,6 +28,7 @@
+ #ifndef CASA_BLOCK_H
+ #define CASA_BLOCK_H
+
++#include <cstddef>
+ #include <casa/aips.h>
+ ///#include <casa/Containers/BlockIO.h>
+ #include <casa/Utilities/Copy.h>
diff --git a/sci-astronomy/casacore/files/1.2.20110516-implicits.patch b/sci-astronomy/casacore/files/1.2.20110516-implicits.patch
new file mode 100644
index 000000000..697b1ce6d
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.2.20110516-implicits.patch
@@ -0,0 +1,166 @@
+diff -Nur casacore-1.2.20110516.orig/casa/HDF5/HDF5DataSet.cc casacore-1.2.20110516/casa/HDF5/HDF5DataSet.cc
+--- casacore-1.2.20110516.orig/casa/HDF5/HDF5DataSet.cc 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/casa/HDF5/HDF5DataSet.cc 2011-05-16 17:29:12.000000000 +0100
+@@ -174,7 +174,7 @@
+ H5Pset_chunk(itsPLid, rank, cs.storage());
+ // Create the data set.
+ setHid (H5Dcreate(parentHid, name.chars(), itsDataType.getHidFile(),
+- itsDSid, NULL, itsPLid, NULL));
++ itsDSid, 0, itsPLid, 0));
+ if (! isValid()) {
+ throw HDF5Error("Data set array " + name + " could not be created");
+ }
+@@ -185,7 +185,7 @@
+ itsParent = &parentHid;
+ setName (name);
+ // Open the dataset.
+- setHid (H5Dopen(parentHid, name.chars(), NULL));
++ setHid (H5Dopen(parentHid, name.chars(), 0));
+ if (! isValid()) {
+ throw HDF5Error("Data set array " + name + " does not exist");
+ }
+@@ -271,7 +271,7 @@
+
+ DataType HDF5DataSet::getDataType (hid_t parentHid, const String& name)
+ {
+- hid_t id = H5Dopen(parentHid, name.chars(), NULL);
++ hid_t id = H5Dopen(parentHid, name.chars(), 0);
+ if (id < 0) {
+ throw HDF5Error("Data set array " + name + " does not exist");
+ }
+diff -Nur casacore-1.2.20110516.orig/casa/HDF5/test/tHDF5.cc casacore-1.2.20110516/casa/HDF5/test/tHDF5.cc
+--- casacore-1.2.20110516.orig/casa/HDF5/test/tHDF5.cc 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/casa/HDF5/test/tHDF5.cc 2011-05-16 17:29:12.000000000 +0100
+@@ -126,7 +126,7 @@
+ H5Pset_chunk (plId, rank, chunkShp);
+ // Create the data set.
+ setId = H5Dcreate (fileId, "dataset", typeIdFile,
+- dsId, NULL, plId, NULL);
++ dsId, 0, plId, 0);
+ check (setId, "Failed to create dataset");
+ }
+
+@@ -136,7 +136,7 @@
+ typeIdFile = H5Tcopy (H5T_NATIVE_FLOAT);
+ typeIdMem = H5Tcopy (typeIdFile);
+ // Open the dataset.
+- setId = H5Dopen (fileId, "dataset", NULL);
++ setId = H5Dopen (fileId, "dataset", 0);
+ check (setId, "Failed to open dataset");
+ // Get the data space (for the shape).
+ dsId = H5Dget_space(setId);
+diff -Nur casacore-1.2.20110516.orig/mirlib/bug.c casacore-1.2.20110516/mirlib/bug.c
+--- casacore-1.2.20110516.orig/mirlib/bug.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/bug.c 2011-05-16 17:29:12.000000000 +0100
+@@ -12,6 +12,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++void habort_c();
+
+ static char *errmsg_c();
+ void bug_c();
+diff -Nur casacore-1.2.20110516.orig/mirlib/dio.c casacore-1.2.20110516/mirlib/dio.c
+--- casacore-1.2.20110516.orig/mirlib/dio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/dio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -45,6 +45,7 @@
+ extern int errno;
+ #endif
+ #include <errno.h>
++void bug_c();
+
+ #define MAXPATH 128
+
+diff -Nur casacore-1.2.20110516.orig/mirlib/hio.c casacore-1.2.20110516/mirlib/hio.c
+--- casacore-1.2.20110516.orig/mirlib/hio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/hio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -36,7 +36,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-
++#include "sysdep.h"
+ #include "hio.h"
+
+ #define private static
+diff -Nur casacore-1.2.20110516.orig/mirlib/maskio.c casacore-1.2.20110516/mirlib/maskio.c
+--- casacore-1.2.20110516.orig/mirlib/maskio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/maskio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-
++void bug_c();
++void bugno_c();
+
+ private void mkfill();
+ void mkflush_c();
+diff -Nur casacore-1.2.20110516.orig/mirlib/scrio.c casacore-1.2.20110516/mirlib/scrio.c
+--- casacore-1.2.20110516.orig/mirlib/scrio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/scrio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -9,6 +9,8 @@
+ /************************************************************************/
+
+ #include "io.h"
++void bug_c();
++void bugno_c();
+
+ /* char *sprintf(); */
+ #include <stdio.h>
+@@ -100,7 +102,7 @@
+ /************************************************************************/
+ void scrwrite_c(handle,buffer,offset,length)
+ int handle,offset,length;
+-float *buffer;
++Const float *buffer;
+ /**scrwrite -- Write real data to the scratch file. */
+ /*:scratch-i/o */
+ /*+ FORTRAN call sequence:
+diff -Nur casacore-1.2.20110516.orig/mirlib/sysdep.h casacore-1.2.20110516/mirlib/sysdep.h
+--- casacore-1.2.20110516.orig/mirlib/sysdep.h 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/sysdep.h 2011-05-16 17:41:07.000000000 +0100
+@@ -131,5 +131,13 @@
+ # define unpackd_c(a,b,c) memcpy((char *)(b),(a),sizeof(double)*(c))
+ # define pack32_c(a,b,c) memcpy((b),(char *)(a),sizeof(int)*(c))
+ # define unpack32_c(a,b,c) memcpy((char *)(b),(a),sizeof(int)*(c))
++#else
++void pack32_c(int* in, char* out, int n);
++void unpack32_c(char* in, int* out,int n);
++void packr_c(float* in, char* out, int n);
++void unpackr_c(char* in, float* out, int n);
++void packd_c(double* in, char* out, int n);
++void unpackd_c(char* in, double* out, int n);
+ #endif
++
+ #endif
+diff -Nur casacore-1.2.20110516.orig/mirlib/xyio.c casacore-1.2.20110516/mirlib/xyio.c
+--- casacore-1.2.20110516.orig/mirlib/xyio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/xyio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -37,7 +37,7 @@
+ #define Strcpy (void)strcpy
+ void bug_c(),bugno_c();
+ void rdhdi_c(),wrhdi_c();
+-void mkclose_c(),mkwrite_c();
++void mkclose_c(),mkwrite_c(),mkflush_c();
+ char *mkopen_c();
+ int mkread_c();
+ static void xymkopen_c();
+diff -Nur casacore-1.2.20110516.orig/mirlib/xyzio.c casacore-1.2.20110516/mirlib/xyzio.c
+--- casacore-1.2.20110516.orig/mirlib/xyzio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/xyzio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -55,6 +55,14 @@
+ #include <string.h>
+ #include <stdlib.h>
+ void bug_c();
++void bugno_c();
++char *mkopen_c(int tno, char* name, char* status);
++void mkclose_c(char *handle);
++int mkread_c(char* handle, int mode, int* flags, int offset, int n, int nsize);
++void mkwrite_c(char* handle, int mode, int* flags, int offset, int n, int nsize);
++void mkflush_c(char* handle);
++int limprint(char *string, int lower[], int upper[]);
++int ferr(char* string, char arg );
+ #define check(x) if(x)bugno_c('f',x)
+
+
diff --git a/sci-astronomy/casacore/files/1.2.20110516-libdir.patch b/sci-astronomy/casacore/files/1.2.20110516-libdir.patch
new file mode 100644
index 000000000..1410aae68
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.2.20110516-libdir.patch
@@ -0,0 +1,196 @@
+diff -Nur casacore-1.2.20110516.orig/casa/CMakeLists.txt casacore-1.2.20110516/casa/CMakeLists.txt
+--- casacore-1.2.20110516.orig/casa/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/casa/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -209,8 +209,8 @@
+
+ install (
+ TARGETS casa_casa
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/components/CMakeLists.txt casacore-1.2.20110516/components/CMakeLists.txt
+--- casacore-1.2.20110516.orig/components/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/components/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -30,8 +30,8 @@
+ install (
+ TARGETS casa_components
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/coordinates/CMakeLists.txt casacore-1.2.20110516/coordinates/CMakeLists.txt
+--- casacore-1.2.20110516.orig/coordinates/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.2.20110516/coordinates/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -25,8 +25,8 @@
+
+ install (TARGETS casa_coordinates
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/derivedmscal/CMakeLists.txt casacore-1.2.20110516/derivedmscal/CMakeLists.txt
+--- casacore-1.2.20110516.orig/derivedmscal/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.2.20110516/derivedmscal/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -14,8 +14,8 @@
+
+ install (TARGETS casa_derivedmscal
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/fits/CMakeLists.txt casacore-1.2.20110516/fits/CMakeLists.txt
+--- casacore-1.2.20110516.orig/fits/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.2.20110516/fits/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -34,8 +34,8 @@
+
+ install (TARGETS casa_fits
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/images/CMakeLists.txt casacore-1.2.20110516/images/CMakeLists.txt
+--- casacore-1.2.20110516.orig/images/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/images/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -71,8 +71,8 @@
+ install (
+ TARGETS casa_images
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/lattices/CMakeLists.txt casacore-1.2.20110516/lattices/CMakeLists.txt
+--- casacore-1.2.20110516.orig/lattices/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/lattices/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -67,8 +67,8 @@
+
+ install (TARGETS casa_lattices
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/measures/CMakeLists.txt casacore-1.2.20110516/measures/CMakeLists.txt
+--- casacore-1.2.20110516.orig/measures/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/measures/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -69,8 +69,8 @@
+ install (
+ TARGETS casa_measures
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/mirlib/CMakeLists.txt casacore-1.2.20110516/mirlib/CMakeLists.txt
+--- casacore-1.2.20110516.orig/mirlib/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/mirlib/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -22,8 +22,8 @@
+ install (
+ TARGETS casa_mirlib
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/ms/CMakeLists.txt casacore-1.2.20110516/ms/CMakeLists.txt
+--- casacore-1.2.20110516.orig/ms/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/ms/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -148,8 +148,8 @@
+
+ install (TARGETS casa_ms
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/msfits/CMakeLists.txt casacore-1.2.20110516/msfits/CMakeLists.txt
+--- casacore-1.2.20110516.orig/msfits/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/msfits/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -29,8 +29,8 @@
+
+ install (
+ TARGETS casa_msfits
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/scimath/CMakeLists.txt casacore-1.2.20110516/scimath/CMakeLists.txt
+--- casacore-1.2.20110516.orig/scimath/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/scimath/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -38,8 +38,8 @@
+
+ install (TARGETS casa_scimath
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_WRITE GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/scimath_f/CMakeLists.txt casacore-1.2.20110516/scimath_f/CMakeLists.txt
+--- casacore-1.2.20110516.orig/scimath_f/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/scimath_f/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -34,8 +34,8 @@
+
+ install (
+ TARGETS casa_scimath_f
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.2.20110516.orig/tables/CMakeLists.txt casacore-1.2.20110516/tables/CMakeLists.txt
+--- casacore-1.2.20110516.orig/tables/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.2.20110516/tables/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -181,8 +181,8 @@
+
+ install (TARGETS casa_tables
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
diff --git a/sci-astronomy/casacore/metadata.xml b/sci-astronomy/casacore/metadata.xml
new file mode 100644
index 000000000..e83314833
--- /dev/null
+++ b/sci-astronomy/casacore/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ A set of libraries for the the Common Astronomy Software
+ Applications for radioastronomy. This project contains C++ libraries
+ which were the code of the discontinued AIPS++ package.
+</longdescription>
+</pkgmetadata>