aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 15:39:21 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-04 15:39:21 -0700
commit5cfadcc1c711a996165b9cb943c6823bc828a603 (patch)
treead29fc88db43c25e5ea6f11756b50bda90caafb5 /sci-astronomy
parentno blas (diff)
downloadsci-5cfadcc1c711a996165b9cb943c6823bc828a603.tar.gz
sci-5cfadcc1c711a996165b9cb943c6823bc828a603.tar.bz2
sci-5cfadcc1c711a996165b9cb943c6823bc828a603.zip
sci-astronomy/stuff: Live version. Prefix love
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/skymaker/skymaker-9999.ebuild2
-rw-r--r--sci-astronomy/stuff/Manifest2
-rw-r--r--sci-astronomy/stuff/stuff-1.19.ebuild13
-rw-r--r--sci-astronomy/stuff/stuff-9999.ebuild36
4 files changed, 42 insertions, 11 deletions
diff --git a/sci-astronomy/skymaker/skymaker-9999.ebuild b/sci-astronomy/skymaker/skymaker-9999.ebuild
index d4a14b093..a42326395 100644
--- a/sci-astronomy/skymaker/skymaker-9999.ebuild
+++ b/sci-astronomy/skymaker/skymaker-9999.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.astromatic.net/software/skymaker"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc threads plplot"
+IUSE="threads"
RDEPEND="sci-libs/fftw:3.0"
DEPEND="${RDEPEND}"
diff --git a/sci-astronomy/stuff/Manifest b/sci-astronomy/stuff/Manifest
index 3efe14757..bfa758acc 100644
--- a/sci-astronomy/stuff/Manifest
+++ b/sci-astronomy/stuff/Manifest
@@ -1 +1 @@
-DIST stuff-1.19.tar.gz 4017086 RMD160 c8ac8d3bbe7cd4a7e48b81b98de60b6c777e6e74 SHA1 acf5b26e5cc10eac757b55b8cca59d5ca3d3ab94 SHA256 592e6bfff704d1391b150a0820b52258ef69a99b698ac07eb0a8f04daf5b0210
+DIST stuff-1.19.tar.gz 4017086 RMD160 c8ac8d3bbe7cd4a7e48b81b98de60b6c777e6e74 SHA1 acf5b26e5cc10eac757b55b8cca59d5ca3d3ab94 SHA256 592e6bfff704d1391b150a0820b52258ef69a99b698ac07eb0a8f04daf5b0210 SHA512 d4dd26a024a4c1372ede2d0ae642ac3ce9e35715e22705996d6344e9e3054e645f1e662ef975d7fb00aea611720ef8c37153b533e0a1b1d9ffb13f16cafba423 WHIRLPOOL a1949b63e6dd6ac34c3ea1c4190c0f236e4a1f0c8363bf876f9329c1c5252272becf72d1327362c0d0b200629a14fcd012fcf07d6538635f614c8d510d54a189
diff --git a/sci-astronomy/stuff/stuff-1.19.ebuild b/sci-astronomy/stuff/stuff-1.19.ebuild
index 39abdb39e..5561ae8b5 100644
--- a/sci-astronomy/stuff/stuff-1.19.ebuild
+++ b/sci-astronomy/stuff/stuff-1.19.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="Tool for automatic generation of astronomical catalogs"
-HOMEPAGE="http://astromatic.iap.fr/software/stuff/"
+HOMEPAGE="http://www.astromatic.net/software/stuff/"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
DEPEND=""
@@ -25,8 +25,3 @@ src_prepare() {
src_configure() {
econf $(use_enable threads)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
-}
diff --git a/sci-astronomy/stuff/stuff-9999.ebuild b/sci-astronomy/stuff/stuff-9999.ebuild
new file mode 100644
index 000000000..78c3b6252
--- /dev/null
+++ b/sci-astronomy/stuff/stuff-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+if [[ ${PV} == "9999" ]] ; then
+ _SVN=subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit ${_SVN} autotools
+
+DESCRIPTION="Tool for automatic generation of astronomical catalogs"
+HOMEPAGE="http://www.astromatic.net/software/stuff/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="threads"
+
+RDEPEND="sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}