aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2005-11-27 22:36:02 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2005-11-27 22:36:02 +0000
commit6187b9b0f8734f581ec5e168dd1ed08545897d86 (patch)
tree24a9d9a8003891a10737e0ba8211835878554d2b /sci-astronomy
parentAdding linsmith-0.9.2.ebuild (diff)
downloadsci-6187b9b0f8734f581ec5e168dd1ed08545897d86.tar.gz
sci-6187b9b0f8734f581ec5e168dd1ed08545897d86.tar.bz2
sci-6187b9b0f8734f581ec5e168dd1ed08545897d86.zip
Added new ebuild for sextractor-2.4.4
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@20 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/sextractor/ChangeLog9
-rw-r--r--sci-astronomy/sextractor/Manifest4
-rw-r--r--sci-astronomy/sextractor/files/digest-sextractor-2.4.41
-rw-r--r--sci-astronomy/sextractor/metadata.xml12
-rw-r--r--sci-astronomy/sextractor/sextractor-2.4.4.ebuild50
5 files changed, 76 insertions, 0 deletions
diff --git a/sci-astronomy/sextractor/ChangeLog b/sci-astronomy/sextractor/ChangeLog
new file mode 100644
index 000000000..463dae322
--- /dev/null
+++ b/sci-astronomy/sextractor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-astronomy/sextractor
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+* sextractor-2.4.4 (27 Nov 2005)
+
+ 26 Nov 2005; Sebastien Fabbro <seb@ist.utl.pt> +sextractor-2.4.4.ebuild:
+ Initial import. Close bug #65684
+
diff --git a/sci-astronomy/sextractor/Manifest b/sci-astronomy/sextractor/Manifest
new file mode 100644
index 000000000..03b4ce9f0
--- /dev/null
+++ b/sci-astronomy/sextractor/Manifest
@@ -0,0 +1,4 @@
+MD5 18e5a7a1a132a9e4905b53f13aec8413 sextractor-2.4.4.ebuild 1245
+MD5 7d0b376a442a326bab90b2faa639bdde ChangeLog 272
+MD5 87811b8b5342ee5676e9185164f15434 metadata.xml 427
+MD5 1837fe343ad054c084ca09560d8414ba files/digest-sextractor-2.4.4 69
diff --git a/sci-astronomy/sextractor/files/digest-sextractor-2.4.4 b/sci-astronomy/sextractor/files/digest-sextractor-2.4.4
new file mode 100644
index 000000000..70bafaa6b
--- /dev/null
+++ b/sci-astronomy/sextractor/files/digest-sextractor-2.4.4
@@ -0,0 +1 @@
+MD5 9f1389ae9229c65f0a6a0b264deb314f sextractor-2.4.4.tar.gz 1318197
diff --git a/sci-astronomy/sextractor/metadata.xml b/sci-astronomy/sextractor/metadata.xml
new file mode 100644
index 000000000..bc8fa1129
--- /dev/null
+++ b/sci-astronomy/sextractor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>seb@ist.utl.pt</email>
+ <name>Sebastien Fabbro</name>
+ </maintainer>
+ <longdescription lang="en">
+ SExtractor stands for Source Extractor, a program that build a catalog of objects from astronomical FITS images.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/sextractor/sextractor-2.4.4.ebuild b/sci-astronomy/sextractor/sextractor-2.4.4.ebuild
new file mode 100644
index 000000000..d89b470f7
--- /dev/null
+++ b/sci-astronomy/sextractor/sextractor-2.4.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic
+
+DESCRIPTION="Extract catalogs of sources from astronomical FITS images."
+HOMEPAGE="http://terapix.iap.fr/soft/${PN}"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="static doc icc"
+DEPEND="icc? ( dev-lang/icc >= 9 )"
+
+CONFDIR=/usr/share/${PN}/config
+
+src_compile() {
+ # trust sextractor cflags to be optimized.
+ filter-flags ${CFLAGS}
+ # change default configuration files location from current dir
+ sed -i -e "s:default\.:${CONFDIR}/default\.:" src/preflist.h
+ econf \
+ $(use_enable static) \
+ $(use_enable icc) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog COPYING HISTORY README THANKS
+ dodir /usr/share/${PN}
+ dodir ${CONFDIR}
+ insinto ${CONFDIR}
+ doins config/*
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can find sextractor configuration files"
+ einfo "in /usr/share/${PN}/config and are enabled by default."
+ einfo
+}
+