aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-27 19:46:02 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-27 23:10:03 +0200
commitddde0dc5acdb84ae91636f3bf61d401cea531b0a (patch)
tree493aa1ac7dea3ecfcb5a6274d09aca32eaf9d045 /sci-astronomy
parentPython ABI fixes (diff)
downloadsci-ddde0dc5acdb84ae91636f3bf61d401cea531b0a.tar.gz
sci-ddde0dc5acdb84ae91636f3bf61d401cea531b0a.tar.bz2
sci-ddde0dc5acdb84ae91636f3bf61d401cea531b0a.zip
Python ABI fixes
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/kapteyn/ChangeLog3
-rw-r--r--sci-astronomy/kapteyn/Manifest14
-rw-r--r--sci-astronomy/kapteyn/kapteyn-1.9.1.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/sci-astronomy/kapteyn/ChangeLog b/sci-astronomy/kapteyn/ChangeLog
index 1d810c6d0..6ffd67892 100644
--- a/sci-astronomy/kapteyn/ChangeLog
+++ b/sci-astronomy/kapteyn/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 27 Jun 2010; Justin Lecher <jlec@gentoo.org> kapteyn-1.9.1.ebuild:
+ Python ABI fixes
+
*kapteyn-1.9.1 (27 Apr 2010)
27 Apr 2010; Kacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>
diff --git a/sci-astronomy/kapteyn/Manifest b/sci-astronomy/kapteyn/Manifest
index ce812e663..eb5c36b81 100644
--- a/sci-astronomy/kapteyn/Manifest
+++ b/sci-astronomy/kapteyn/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST kapteyn-1.9.1.tar.gz 6525267 RMD160 8b073c9221e5cb768d57572125b0d73f3e4b54a2 SHA1 0e32b21c24200f4990c0fb75a9001ce5f10280a5 SHA256 218b3a065ff20235e7ba5a67ce9a212171dded0bb79a8dc4669d8ec5a77e9c94
-EBUILD kapteyn-1.9.1.ebuild 529 RMD160 9190221c548c3e4e59825d25eeeb9f28203a2b7b SHA1 9a1e1e6cef371245adb74601725d976da06aec37 SHA256 7c3770d3589edebb11d1951126bfd1e8bc28993d035523c46f6b7e309017a0d4
-MISC ChangeLog 479 RMD160 46e02d39ca32c583571d5c730e67052f6af3c099 SHA1 403f0ec4dc8e7d04cf7573857c9cb2444cb1fc4e SHA256 37d6fd2071e23a2d181925675ed95e1878b00dc5abe7f7b168009cee36c8ca77
+EBUILD kapteyn-1.9.1.ebuild 612 RMD160 f371acedc915bac8ebae9a40f90154659c5ce435 SHA1 15dc10e2a79f431ab8b1e6d1c3fbed4530db98ed SHA256 247ac5709fbc0c9314b6d20e7ed0c49653ea8a6b6b29e08710fe1d9117ae5378
+MISC ChangeLog 568 RMD160 1b232732ace3d18c6c360e403da573bb44a7a429 SHA1 b062631bb700be941d8be309f70b8aec73ae3ee8 SHA256 7fb38164c7ce6b26e1f0c63691157ca043a834e8c0873ac8ec42f3dadb7becf3
MISC metadata.xml 501 RMD160 21ff30e9908a8872f7cf8facbcf86f089b874ebe SHA1 a43bcde0827ad797de7fc10583ae244e2a10e82e SHA256 9c4965e57b84b29a22d6137872629c44618000cb50f8c9a95fb73b46fc348b6a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwnjloACgkQgAnW8HDreRZb6gCg0qS3rFOuWe4/p8rOYVH+sra5
+EX8An0XI7ax/4FPrN0riaFUKrp2Vbda+
+=UwJH
+-----END PGP SIGNATURE-----
diff --git a/sci-astronomy/kapteyn/kapteyn-1.9.1.ebuild b/sci-astronomy/kapteyn/kapteyn-1.9.1.ebuild
index 7aaf1663b..a0d78d043 100644
--- a/sci-astronomy/kapteyn/kapteyn-1.9.1.ebuild
+++ b/sci-astronomy/kapteyn/kapteyn-1.9.1.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
inherit distutils
DESCRIPTION="Collection of python tools for astronomy"
@@ -14,10 +19,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="sci-astronomy/wcslib
+DEPEND="
+ sci-astronomy/wcslib
dev-python/numpy"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
src_install() {
distutils_src_install
if use doc; then