aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-09 16:44:04 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-09 16:44:04 -0700
commitf50fab3bd09c80c446ef032738445e00348ad654 (patch)
tree23062777224dcec7465feca9419f2b62576fca75 /sci-astronomy
parentsci-astronomy/missfits: live version, prefix keywording (diff)
downloadsci-f50fab3bd09c80c446ef032738445e00348ad654.tar.gz
sci-f50fab3bd09c80c446ef032738445e00348ad654.tar.bz2
sci-f50fab3bd09c80c446ef032738445e00348ad654.zip
sci-astronomy/stiff: live version, prefix keywording
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stiff/ChangeLog53
-rw-r--r--sci-astronomy/stiff/files/stiff-configure.patch63
-rw-r--r--sci-astronomy/stiff/metadata.xml10
-rw-r--r--sci-astronomy/stiff/stiff-9999.ebuild43
4 files changed, 169 insertions, 0 deletions
diff --git a/sci-astronomy/stiff/ChangeLog b/sci-astronomy/stiff/ChangeLog
new file mode 100644
index 000000000..5d562b9e3
--- /dev/null
+++ b/sci-astronomy/stiff/ChangeLog
@@ -0,0 +1,53 @@
+# ChangeLog for sci-astronomy/stiff
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stiff/ChangeLog,v 1.7 2011/08/04 18:33:30 bicatali Exp $
+
+*stiff-9999 (09 Jul 2012)
+
+ 09 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +stiff-9999.ebuild,
+ +files/stiff-configure.patch, +metadata.xml:
+ Added live version, fixed for respecting flags, keyword amd64-linux,
+ x86-linux
+
+ 04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
+ Switched herd to sci-astronomy
+
+*stiff-2.1.3 (10 Apr 2011)
+
+ 10 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org> -stiff-1.12.ebuild,
+ +stiff-2.1.3.ebuild:
+ Version bump
+
+ 08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org> stiff-2.1.2.ebuild:
+ media-libs/jpeg -> virtual/jpeg
+
+*stiff-2.1.2 (26 Feb 2010)
+
+ 26 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> -stiff-1.10.ebuild,
+ +stiff-2.1.2.ebuild:
+ Version bump
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> stiff-1.12.ebuild:
+ Updated license to CeCILL-2
+
+*stiff-1.12 (28 Jul 2009)
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +stiff-1.12.ebuild,
+ +files/stiff-configure.patch:
+ Version bump
+
+*stiff-1.10 (17 Feb 2009)
+
+ 17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +stiff-1.10.ebuild:
+ Initial import to the main tree from the sci overlay
+
+ 26 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org> stiff-1.10.ebuild:
+ cleaning
+
+ 29 Dec 2006; Sebastien Fabbro <seb@ist.utl.pt>;
+ Removed icc flag, too buggy.
+
+ 19 Sep 2006; Sebastien Fabbro <seb@ist.utl.pt> +stiff-1.10.ebuild:
+ Initial import.
+
diff --git a/sci-astronomy/stiff/files/stiff-configure.patch b/sci-astronomy/stiff/files/stiff-configure.patch
new file mode 100644
index 000000000..15b8d9aa3
--- /dev/null
+++ b/sci-astronomy/stiff/files/stiff-configure.patch
@@ -0,0 +1,63 @@
+--- configure.ac.orig 2009-03-10 12:34:36.000000000 +0000
++++ configure.ac 2009-07-28 17:26:22.000000000 +0100
+@@ -21,40 +21,14 @@
+
+ # Include macros
+ #sinclude(acx_pthread.m4)
+-sinclude(acx_prog_cc_optim.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+-# Checks for programs.
+-# GCC is chosen last because it is likely to yield less optimized code
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C
+ AM_PROG_CC_STDC
+ # C Compiler: Check that it is POSIX-compliant
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+@@ -107,19 +81,9 @@
+
+ # Link with gprof option
+ if test "$use_gprof" = "yes"; then
+- if test "$use_icc" = "yes"; then
+- CFLAGS="$CFLAGS -pq"
+- else
+- CFLAGS="$CFLAGS -pg"
+- fi
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+ # Override automatic CFLAGS and LDFLAGS with those of user
+ #if test -n "$mycflags"; then
+ #CFLAGS="$mycflags"
diff --git a/sci-astronomy/stiff/metadata.xml b/sci-astronomy/stiff/metadata.xml
new file mode 100644
index 000000000..320c9fec8
--- /dev/null
+++ b/sci-astronomy/stiff/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ STIFF is a program that convert scientific FITS images to the
+ more popular TIFF, in 8 (grayscale) or 24 (true colour: 3 times 8) bits per
+ pixel.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/stiff/stiff-9999.ebuild b/sci-astronomy/stiff/stiff-9999.ebuild
new file mode 100644
index 000000000..961d68bf5
--- /dev/null
+++ b/sci-astronomy/stiff/stiff-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stiff/stiff-2.1.3.ebuild,v 1.1 2011/04/10 14:45:35 bicatali Exp $
+
+EAPI=4
+
+
+if [[ ${PV} == "9999" ]] ; then
+ _SVN=subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit ${_SVN} autotools
+
+DESCRIPTION="Converts astronomical FITS images to the TIFF format"
+HOMEPAGE="http://astromatic.iap.fr/software/stiff"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc threads"
+
+RDEPEND="media-libs/tiff
+ virtual/jpeg
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*
+}