aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2011-11-28 21:35:17 +0000
committerSébastien Fabbro <sebfabbro@gmail.com>2011-11-28 21:35:17 +0000
commitf5d0d9fcf03e7f67c4815305cd00b2cd738f082f (patch)
tree129163d48dd19cafeee10ef91a4e80dd1caa66b0 /sci-astronomy
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.tar.gz
sci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.tar.bz2
sci-f5d0d9fcf03e7f67c4815305cd00b2cd738f082f.zip
fixed astromatic packages for recent ATLAS
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/psfex/ChangeLog6
-rw-r--r--sci-astronomy/psfex/Manifest4
-rw-r--r--sci-astronomy/psfex/psfex-3.9.1-r1.ebuild50
-rw-r--r--sci-astronomy/psfex/psfex-3.9.1.ebuild45
-rw-r--r--sci-astronomy/scamp/ChangeLog75
-rw-r--r--sci-astronomy/scamp/Manifest4
-rw-r--r--sci-astronomy/scamp/metadata.xml13
-rw-r--r--sci-astronomy/scamp/scamp-1.7.0-r1.ebuild51
-rw-r--r--sci-astronomy/sextractor/ChangeLog48
-rw-r--r--sci-astronomy/sextractor/Manifest5
-rw-r--r--sci-astronomy/sextractor/files/sextractor-configure.patch84
-rw-r--r--sci-astronomy/sextractor/metadata.xml13
-rw-r--r--sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild55
13 files changed, 406 insertions, 47 deletions
diff --git a/sci-astronomy/psfex/ChangeLog b/sci-astronomy/psfex/ChangeLog
index 194a9b99f..24df27043 100644
--- a/sci-astronomy/psfex/ChangeLog
+++ b/sci-astronomy/psfex/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*psfex-3.9.1-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> -psfex-3.9.1.ebuild,
+ +psfex-3.9.1-r1.ebuild:
+ Fixed for recent ATLAS. Switch to EAPI4
+
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/psfex/Manifest b/sci-astronomy/psfex/Manifest
index 9620f0611..026983a33 100644
--- a/sci-astronomy/psfex/Manifest
+++ b/sci-astronomy/psfex/Manifest
@@ -1,4 +1,4 @@
DIST psfex-3.9.1.tar.gz 2364495 RMD160 54c1a32c7f9305a91b973a974c4ae527a4dc3143 SHA1 af164b4e3d1bf61cdd738e8c52730f8564460ae0 SHA256 1758a1a40166ef59475d8fab6abda33ca0ed0a837531ff7ad577d8bce4e511f7
-EBUILD psfex-3.9.1.ebuild 1183 RMD160 26f4f8c2c4e6e6bee033972d051f5ca949a58877 SHA1 88f82e87f8258be728318d1930dfcf93cec51022 SHA256 afe364cee799aabbe1a474fbd62f88db3288f7078292be05965f437e81083d55
-MISC ChangeLog 223 RMD160 d0b003facb024aa6fdd256e22e4bc195fb869fad SHA1 88423e194987deee94f09e7bf83a2108fb5cdaf2 SHA256 e54455e8fe6b6c783abcba8ee9911786d19e3434881f11652617a007dd6d0036
+EBUILD psfex-3.9.1-r1.ebuild 1350 RMD160 823380233c4decbefbb8c2dace96dfc218aa7bb5 SHA1 aa65bacadc4b1db078e3d8ffbb680cfc8047728e SHA256 7c6a36089c831ecac4ad54a227ab69fc5b054e7d73c82b4ea77caf39fed69065
+MISC ChangeLog 399 RMD160 6d6be363a1d1492134ac80cb1bd21117e6b53bad SHA1 b2f0e87c7e0243ff95f200569e9b9ddf85cc7044 SHA256 e34cfb8188b6509de73cfe000e375c79cf1737fcc8698699d59dc51d1087930a
MISC metadata.xml 618 RMD160 4457a863e2920a162d35f06cb54131569b7a1570 SHA1 39b4dbb51a1b04df0638bbb35404970544d91531 SHA256 5d67566a70b08931f4df71183ef8c69d237af0c54d8544547fc8bd0712160e5f
diff --git a/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild b/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild
new file mode 100644
index 000000000..d94b5c3f8
--- /dev/null
+++ b/sci-astronomy/psfex/psfex-3.9.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
+HOMEPAGE="http://www.astromatic.net/software/psfex"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc plplot threads"
+
+RDEPEND="virtual/cblas
+ sci-libs/atlas
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ configure || die "sed acx_atlas.m4 failed"
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EROOT}/usr/include/atlas" \
+ $(use_with plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*.pdf
+}
diff --git a/sci-astronomy/psfex/psfex-3.9.1.ebuild b/sci-astronomy/psfex/psfex-3.9.1.ebuild
deleted file mode 100644
index 3530ea969..000000000
--- a/sci-astronomy/psfex/psfex-3.9.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/scamp/scamp-1.7.0.ebuild,v 1.1 2010/05/03 21:44:04 bicatali Exp $
-
-EAPI=3
-inherit eutils
-
-DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
-HOMEPAGE="http://www.astromatic.net/software/psfex"
-SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc plplot threads"
-
-RDEPEND="virtual/cblas
- sci-libs/lapack-atlas
- sci-libs/fftw:3.0
- plplot? ( sci-libs/plplot )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- # gentoo uses cblas instead of ptcblas (linked to threaded with eselect)
- sed -i \
- -e 's/ptcblas/cblas/g' \
- configure || die "sed failed"
-}
-
-src_configure() {
- econf \
- --with-atlas="${EPREFIX}/usr/$(get_libdir)/lapack/atlas" \
- $(use_with plplot) \
- $(use_enable threads)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins doc/*.pdf || die "pdf doc install failed"
- fi
-}
diff --git a/sci-astronomy/scamp/ChangeLog b/sci-astronomy/scamp/ChangeLog
new file mode 100644
index 000000000..2de8c44c9
--- /dev/null
+++ b/sci-astronomy/scamp/ChangeLog
@@ -0,0 +1,75 @@
+# ChangeLog for sci-astronomy/scamp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/scamp/ChangeLog,v 1.7 2011/08/04 18:32:22 bicatali Exp $
+
+*scamp-1.7.0-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> +scamp-1.7.0-r1.ebuild,
+ +metadata.xml:
+ Fixed for recent ATLAS. Switch to EAPI4
+
+ 04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
+ Switched herd to sci-astronomy
+
+*scamp-1.7.0 (03 May 2010)
+
+ 03 May 2010; Sébastien Fabbro <bicatali@gentoo.org> -scamp-1.5.5.ebuild,
+ +scamp-1.7.0.ebuild:
+ Version bump
+
+*scamp-1.6.2 (04 Nov 2009)
+
+ 04 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> -scamp-1.4.6.ebuild,
+ +scamp-1.6.2.ebuild:
+ Version bump
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> scamp-1.5.5.ebuild:
+ Updated license to CeCILL-2
+
+*scamp-1.5.5 (28 Jul 2009)
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +scamp-1.5.5.ebuild,
+ +files/scamp-1.5.5-autotools.patch:
+ Version bumpp
+
+ 05 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/scamp-1.4.6-autotools.patch:
+ More plplot patching
+
+*scamp-1.4.6 (26 Feb 2009)
+
+ 26 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scamp-1.4.6-autotools.patch, +metadata.xml, +scamp-1.4.6.ebuild:
+ Initial import to the main tree from the sci overlay. Also included
+ autotools from scamp svn public repository for better dependencies
+
+ 02 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scamp-1.4.6-plplot.patch, -files/scamp-atlas.patch,
+ -scamp-1.4.0.ebuild, +scamp-1.4.6.ebuild:
+ Version bump.
+
+ 08 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scamp-atlas.patch, -scamp-1.3.11.ebuild, +scamp-1.4.0.ebuild:
+ Version bump
+
+ 02 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org> -scamp-1.3.8.ebuild,
+ +scamp-1.3.11.ebuild:
+ Version bump
+
+ 18 May 2007; Sébastien Fabbro <bicatali@gentoo.org> -scamp-1.3.5.ebuild,
+ +scamp-1.3.8.ebuild:
+ Version bump
+
+ 26 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -scamp-1.2.11-r1.ebuild, +scamp-1.3.5.ebuild:
+ Version bump.
+
+ 29 Dec 2006; Sebastien Fabbro <seb@ist.utl.pt>;
+ Removed icc flag, too buggy.
+
+ 15 Oct 2006; Sebastien Fabbro <seb@ist.utl.pt> +scamp-1.2.11-r1.ebuild:
+ Removed flag filtering, some cleaning.
+
+ 19 Sep 2006; Sebastien Fabbro <seb@ist.utl.pt> +scamp-1.2.11.ebuild:
+ Initial import.
+
diff --git a/sci-astronomy/scamp/Manifest b/sci-astronomy/scamp/Manifest
new file mode 100644
index 000000000..8f37fec97
--- /dev/null
+++ b/sci-astronomy/scamp/Manifest
@@ -0,0 +1,4 @@
+DIST scamp-1.7.0.tar.gz 9214695 RMD160 d73325df23a189e62d0eabdcc35c83bf06638511 SHA1 f54476b0ce8f5f7c5294640a9bb85a877f5ad1c4 SHA256 b8451bd34946fa33c26ea60a12b40ec3c2fa22987564aaaa05205df0728b4d54
+EBUILD scamp-1.7.0-r1.ebuild 1384 RMD160 778baec0e698deb2734325bdf6dd3075cda726dc SHA1 07f3fc58fc95011a4ae673e8536e75dabc0887e0 SHA256 a558cda742b4ea145dcb52c7a61d0d1894751223ff5113be898e3799e2c09f08
+MISC ChangeLog 2409 RMD160 261ba4641937eeb3dd4d79a8590162870d48cd44 SHA1 7f7d117e18f5dd9b618b07ea618e1eecfcb8d014 SHA256 a0c14f63d57b08cff5ea78759e7987c0d79127e06699c26dd9b58d40cbf109c4
+MISC metadata.xml 512 RMD160 322015f33ab93788e6e3030a238ad7afed35648e SHA1 bb955b6042700fe32b9cd9f3927831de1f3f5051 SHA256 425864802d38f542f8fd22374b73973c0ffecf149ac2bae270237ad547b6dcec
diff --git a/sci-astronomy/scamp/metadata.xml b/sci-astronomy/scamp/metadata.xml
new file mode 100644
index 000000000..edd8754ca
--- /dev/null
+++ b/sci-astronomy/scamp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ SCAMP computes astrometric and photometric solutions from SExtractor catalogs
+ and stores them in header files. These headers files can be read by SWarp to
+ coadd images.
+</longdescription>
+<use>
+ <flag name="plplot">Build with <pkg>sci-libs/plplot</pkg> to allow diagnostic plots during processing</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild b/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild
new file mode 100644
index 000000000..7c1b3856f
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads plplot"
+
+RDEPEND=">=sci-astronomy/cdsclient-3.4
+ virtual/cblas
+ sci-libs/atlas
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ configure || die "sed acx_atlas.m4 failed"
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EROOT}/usr/include/atlas" \
+ $(use_with plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*,pdf
+}
diff --git a/sci-astronomy/sextractor/ChangeLog b/sci-astronomy/sextractor/ChangeLog
new file mode 100644
index 000000000..67fe448f2
--- /dev/null
+++ b/sci-astronomy/sextractor/ChangeLog
@@ -0,0 +1,48 @@
+# ChangeLog for sci-astronomy/sextractor
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/sextractor/ChangeLog,v 1.3 2011/08/04 18:32:38 bicatali Exp $
+
+*sextractor-2.8.6-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +sextractor-2.8.6-r1.ebuild, +files/sextractor-configure.patch,
+ +metadata.xml:
+ Fixed for recent ATLAS. Switch to EAPI4
+
+ 04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
+ Switched herd to sci-astronomy
+
+*sextractor-2.8.6 (28 Jul 2009)
+
+ 28 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +sextractor-2.8.6.ebuild, +files/sextractor-configure.patch:
+ Version bump
+
+*sextractor-2.5.0 (17 Feb 2009)
+
+ 17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +sextractor-2.5.0.ebuild:
+ Initial import to the main tree from the sci overlay, closing bug #65684
+
+ 02 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ sextractor-2.5.0-r1.ebuild:
+ filter optim flags
+
+ 26 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ sextractor-2.5.0-r1.ebuild:
+ Cleaning, adapting for new portage.
+
+ 29 Dec 2006; Sebastien Fabbro <seb@ist.utl.pt>;
+ Removed icc flag, too buggy.
+
+ 15 Oct 2006; Sebastien Fabbro <seb@ist.utl.pt>
+ +sextractor-2.5.0-r1.ebuild -sextractor-2.5.0.ebuild
+ -sextractor-2.4.4.ebuild: removed flag filtering, cleaning,
+ removed old versions.
+
+ 06 Sep 2006; Sebastien Fabbro <seb@ist.utl.pt> +sextractor-2.5.0.ebuild:
+ Version bump.
+
+ 26 Nov 2005; Sebastien Fabbro <seb@ist.utl.pt> +sextractor-2.4.4.ebuild:
+ Initial import. Close bug #65684
+
diff --git a/sci-astronomy/sextractor/Manifest b/sci-astronomy/sextractor/Manifest
new file mode 100644
index 000000000..1abea046d
--- /dev/null
+++ b/sci-astronomy/sextractor/Manifest
@@ -0,0 +1,5 @@
+AUX sextractor-configure.patch 2252 RMD160 4ba075e8add3c29c2b9bd033b7e644c8a1a3e034 SHA1 aa2e4eaa02fd79fe7fd24731909d937b88dc3e50 SHA256 95a611a2a2857d784190958f9ebd9efbcc846cce55ee4cd2c6a1149f3837071e
+DIST sextractor-2.8.6.tar.gz 3994622 RMD160 98319c54ab3af0d4a91c3ffa70e7d5148b06d67a SHA1 103ac2d51d9bae9fcbc5dda3031d82cd127f8250 SHA256 dde34594c2a1324f0951272e404e55d0d4cb0607f8ea18a61f2563bb67f494ac
+EBUILD sextractor-2.8.6-r1.ebuild 1428 RMD160 9598dabc1fedb9b7d0b944f64aed3960e3d2ab03 SHA1 84b24e9bd1967e53a869ec9e6566cbf4e056b212 SHA256 3d5d75e3e4a7234411f89fb6fd3e047ddc2414e7db381bdf2a2485a5b0ae5989
+MISC ChangeLog 1627 RMD160 508e6ba6eecb3d53c9e2a255a744bbf46ca04301 SHA1 527d68350029dc401aed861925e4b7bd96bab516 SHA256 2a1a2726e81972b0dbc9b7362ffb5e2b434307da32f375804ddd015739303990
+MISC metadata.xml 565 RMD160 6ecadc21d64b23d9a38056647e5c8404818a344c SHA1 460aae80eb863d4c70190da9de4e08753b643c07 SHA256 43d21ac4ebaedaa0c98f80fc25857135752e5d9a1f9b25f29215a0960195107e
diff --git a/sci-astronomy/sextractor/files/sextractor-configure.patch b/sci-astronomy/sextractor/files/sextractor-configure.patch
new file mode 100644
index 000000000..dc8957ba0
--- /dev/null
+++ b/sci-astronomy/sextractor/files/sextractor-configure.patch
@@ -0,0 +1,84 @@
+--- configure.ac.orig 2009-04-09 14:28:38.000000000 +0100
++++ configure.ac 2009-07-28 18:25:38.000000000 +0100
+@@ -22,42 +22,19 @@
+ # Include macros
+ sinclude(acx_atlas.m4)
+ sinclude(acx_fftw.m4)
+-sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_pthread.m4)
+ sinclude(acx_urbi_resolve_dir.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+ # Checks for programs.
+ # GCC is chosen last because it is likely to yield less optimized code
+ AC_LANG(C)
+-AC_PROG_CC([$cclist])
++AC_PROG_CC
+ # C Compiler: Check that it is ANSI C and POSIX-compliant
+ AM_PROG_CC_STDC
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_DISABLE_STATIC
+ #AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+@@ -160,17 +137,6 @@
+ use_gprof="no"
+ AC_MSG_RESULT([no]))
+
+-# Enable static linking
+-AC_MSG_CHECKING([static linking])
+-AC_ARG_ENABLE(static,
+- [AC_HELP_STRING([--enable-static],
+- [Enable static linking \
+-(off by default)])],
+- use_static="yes"
+- AC_MSG_RESULT([yes]),
+- use_static="no"
+- AC_MSG_RESULT([no]))
+-
+ ################# Actions to complete in case of multhreading ################
+ AC_DEFINE_UNQUOTED(THREADS_NMAX, $n_pthreads,[Maximum number of POSIX threads])
+ if test "$use_pthreads" = "yes"; then
+@@ -205,19 +171,9 @@
+
+ # Link with gprof option
+ if test "$use_gprof" = "yes"; then
+- if test "$use_icc" = "yes"; then
+- CFLAGS="$CFLAGS -pq"
+- else
+- CFLAGS="$CFLAGS -pg"
+- fi
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+ # Override automatic CFLAGS and LDFLAGS with those of user
+ #if test -n "$mycflags"; then
+ #CFLAGS="$mycflags"
diff --git a/sci-astronomy/sextractor/metadata.xml b/sci-astronomy/sextractor/metadata.xml
new file mode 100644
index 000000000..8b8931e59
--- /dev/null
+++ b/sci-astronomy/sextractor/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ SExtractor (Source Extractor) is a program that builds a catalogue of
+ objects from an astronomical image. Although it is particularly
+ oriented towards reduction of large scale galaxy-survey data, it
+ performs rather well on moderately crowded star fields. It has the
+ ability to automatically separate stars and galaxy using neural
+ networks.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild b/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild
new file mode 100644
index 000000000..1db0e066f
--- /dev/null
+++ b/sci-astronomy/sextractor/sextractor-2.8.6-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Extract catalogs of sources from astronomical FITS images"
+HOMEPAGE="http://www.astromatic.net/software/sextractor"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads"
+
+RDEPEND="virtual/cblas
+ sci-libs/atlas[lapack]
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] && myclapack=ptclapack
+ fi
+ sed -i \
+ -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ acx_atlas.m4 || die "sed acx_atlas.m4 failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ CONFDIR=/usr/share/sextractor
+ insinto ${CONFDIR}
+ doins config/*
+ use doc && dodoc doc/*
+}
+
+pkg_postinst() {
+ elog "SExtractor examples configuration files are located"
+ elog "in ${EROOT}/${CONFDIR} and are not loaded anymore by default."
+}