aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 10:55:06 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 10:55:06 +0100
commit19eb71e9e2cc023a547e9ca34c246d0266dcbcf2 (patch)
tree7553ba9e4a6a6bddf0d178cbdd8252d7ff350dab /sci-biology/GAL
parentsci-biology/vcflib: bump to 1.0.3 (diff)
downloadsci-19eb71e9e2cc023a547e9ca34c246d0266dcbcf2.tar.gz
sci-19eb71e9e2cc023a547e9ca34c246d0266dcbcf2.tar.bz2
sci-19eb71e9e2cc023a547e9ca34c246d0266dcbcf2.zip
sci-biology/GAL: fix install
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-biology/GAL')
-rw-r--r--sci-biology/GAL/GAL-0.2.2_p20200508.ebuild19
-rw-r--r--sci-biology/GAL/files/Build.PL.patch24
2 files changed, 21 insertions, 22 deletions
diff --git a/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild b/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
index 1aa7e99be..f02907368 100644
--- a/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
+++ b/sci-biology/GAL/GAL-0.2.2_p20200508.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit perl-module
@@ -10,16 +10,15 @@ COMMIT="94af39622aab5ba48eb693f2327f6e90f1d202ed"
DESCRIPTION="Genome Annotation Library (incl. fasta_tool)"
HOMEPAGE="https://github.com/The-Sequence-Ontology/GAL"
SRC_URI="https://github.com/The-Sequence-Ontology/GAL/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="( GPL-1+ Artistic )"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
RESTRICT="test"
DEPEND="
- >=dev-lang/perl-5.6.1
- dev-perl/Module-Build
dev-perl/Config-Std
virtual/perl-Data-Dumper
dev-perl/Data-Types
@@ -29,6 +28,7 @@ DEPEND="
dev-perl/Number-Format
virtual/perl-Scalar-List-Utils
dev-perl/Set-IntSpan-Fast
+ dev-perl/Statistics-Descriptive
dev-perl/Statistics-Descriptive-Discrete
dev-perl/Template-Toolkit
dev-perl/Text-Graph
@@ -36,7 +36,12 @@ DEPEND="
dev-perl/Text-Table
dev-perl/Exception-Class
dev-perl/Test-Warn
- dev-perl/URI"
+ dev-perl/URI
+ sci-biology/fasta
+"
RDEPEND="${DEPEND}"
+BDEPEND="dev-perl/Module-Build"
-S="${WORKDIR}/${PN}-${COMMIT}"
+PATCHES=(
+ "${FILESDIR}/Build.PL.patch"
+)
diff --git a/sci-biology/GAL/files/Build.PL.patch b/sci-biology/GAL/files/Build.PL.patch
index 6d881f249..eee4fb60d 100644
--- a/sci-biology/GAL/files/Build.PL.patch
+++ b/sci-biology/GAL/files/Build.PL.patch
@@ -1,16 +1,11 @@
-diff -ruN GAL_0.2.2.orig/Build.PL GAL_0.2.2/Build.PL
---- GAL_0.2.2.orig/Build.PL 2014-01-30 01:35:11.000000000 +0100
-+++ GAL_0.2.2/Build.PL 2016-01-02 12:09:16.212623256 +0100
-@@ -6,26 +6,6 @@
- my $class = Module::Build->subclass
- (
- class => 'Module::Build::Custom',
-- code => q{
-- sub ACTION_build {
-- my $self = shift;
-- $self->SUPER::ACTION_build;
-- $self->dispatch('installdeps');
-- }
+diff --git a/Build.PL b/Build.PL
+index 5915ca8..61eceb3 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -12,19 +12,6 @@ my $class = Module::Build->subclass
+ $self->SUPER::ACTION_build;
+ $self->dispatch('installdeps');
+ }
- sub ACTION_install {
- my $self = shift;
- print "\n\nGAL does not do a system wide install\n\n";
@@ -24,7 +19,6 @@ diff -ruN GAL_0.2.2.orig/Build.PL GAL_0.2.2/Build.PL
- print "remove the entire subroutine (ACTION_install) where this message\n";
- print "is printed run Build realclean and re-install.\n\n";
- }
-- },
+ },
);
- my $builder = $class->new(