aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 14:11:48 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 14:12:02 +0100
commit50d690e643d45a8b54d2bdf24afa1839a0781a53 (patch)
tree862dfb930660d90857c9cd61ba097e11a25e225f /sci-biology/IMAGE
parentsci-biology/jannover: drop pack, unsupported build system (diff)
downloadsci-50d690e643d45a8b54d2bdf24afa1839a0781a53.tar.gz
sci-50d690e643d45a8b54d2bdf24afa1839a0781a53.tar.bz2
sci-50d690e643d45a8b54d2bdf24afa1839a0781a53.zip
sci-biology/IMAGE: fix install, EAPI bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/IMAGE')
-rw-r--r--sci-biology/IMAGE/IMAGE-2.4.1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sci-biology/IMAGE/IMAGE-2.4.1.ebuild b/sci-biology/IMAGE/IMAGE-2.4.1.ebuild
index d0969c344..6bd80436e 100644
--- a/sci-biology/IMAGE/IMAGE-2.4.1.ebuild
+++ b/sci-biology/IMAGE/IMAGE-2.4.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+inherit perl-functions
DESCRIPTION="Iterative Mapping and Assembly for Gap Elimination using paired-end Illumina"
HOMEPAGE="https://sourceforge.net/apps/mediawiki/image2"
@@ -10,10 +12,16 @@ SRC_URI="https://sourceforge.net/projects/image2/files/IMAGE_version${PV}_64bit.
#http://genomebiology.com/2010/11/4/R41
LICENSE="CC-BY-2.0"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+KEYWORDS="~amd64"
# contains bundled binaries:
# nucmer smalt_x86_64 ssaha2 ssaha2Build velvetg velveth
DEPEND=""
RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}_version2.4"
+
+src_install() {
+ perl_doexamples example/
+ perl_domodule *.pl
+}