aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-29 13:44:25 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-29 13:44:25 +0000
commitc38274779a20385ad70d5c2aa2dac34d8525868d (patch)
tree3c1dfaacb3e677a5e15eb0ba58c6492776a47c00 /sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
parentsci-biology/Atlas2: Add missing slot operator (diff)
downloadsci-c38274779a20385ad70d5c2aa2dac34d8525868d.tar.gz
sci-c38274779a20385ad70d5c2aa2dac34d8525868d.tar.bz2
sci-c38274779a20385ad70d5c2aa2dac34d8525868d.zip
sci-biology/SEECER: QA fixes
Bump to6 EAPI drop non active code add missing slot operator Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/SEECER/SEECER-0.1.3-r2.ebuild')
-rw-r--r--sci-biology/SEECER/SEECER-0.1.3-r2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
index 8d8e91972..f2b5a67a4 100644
--- a/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
+++ b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
@@ -1,41 +1,40 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils
DESCRIPTION="SEquencing Error Corrector for RNA-Seq reads"
HOMEPAGE="http://sb.cs.cmu.edu/seecer/"
-if [ "$PV" == "9999" ]; then
- EGIT_REPO_URI="https://github.com/haisonle/SEECER.git"
- KEYWORDS=""
-else
- SRC_URI="
+SRC_URI="
http://sb.cs.cmu.edu/seecer/downloads/"${P}".tar.gz
http://sb.cs.cmu.edu/seecer/downloads/manual.pdf -> "${PN}"-manual.pdf"
- KEYWORDS="~amd64"
-fi
LICENSE="GPL-3"
SLOT="0"
IUSE=""
+KEYWORDS="~amd64"
# although has bundled jellyfish-1.1.11 copy it just calls the executable during runtime
# seems jellyfish-2 does not accept same commandline arguments
DEPEND="
- sci-libs/gsl
- sci-biology/seqan"
+ sci-libs/gsl:0=
+ sci-biology/seqan:0="
RDEPEND="${DEPEND}
=sci-biology/jellyfish-1.1.11"
S="${S}"/SEECER
+PATCHES=(
+ "${FILESDIR}"/remove-hardcoded-paths.patch
+)
+
src_prepare(){
# http://seecer-rna-read-error-correction-mailing-list.21961.x6.nabble.com/Segmentation-fault-in-step-4-td41.html
cp -p "${FILESDIR}"/replace_ids.cc "${S}"/src/ || die
- epatch "${FILESDIR}"/remove-hardcoded-paths.patch
+ default
}
src_install(){