aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-13 18:26:00 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-13 18:26:00 +0100
commitc10c56b06fbaf0b0127db70aa6ad7b7910694d2e (patch)
treeaf086269e6f2d4822dd136f45511627287c1b918 /sci-biology/SEECER
parentsci-biology/BBmap-34.56: restoring previous working version (diff)
downloadsci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.tar.gz
sci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.tar.bz2
sci-c10c56b06fbaf0b0127db70aa6ad7b7910694d2e.zip
sci-biology/SEECER: remove hardcoded paths
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/SEECER')
-rw-r--r--sci-biology/SEECER/ChangeLog7
-rw-r--r--sci-biology/SEECER/SEECER-0.1.3-r2.ebuild (renamed from sci-biology/SEECER/SEECER-0.1.3-r1.ebuild)3
-rw-r--r--sci-biology/SEECER/files/remove-hardcoded-paths.patch49
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/SEECER/ChangeLog b/sci-biology/SEECER/ChangeLog
index eae131d7c..2872b27ef 100644
--- a/sci-biology/SEECER/ChangeLog
+++ b/sci-biology/SEECER/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*SEECER-0.1.3-r2 (13 Nov 2015)
+
+ 13 Nov 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +SEECER-0.1.3-r2.ebuild, +files/remove-hardcoded-paths.patch,
+ -SEECER-0.1.3-r1.ebuild:
+ sci-biology/SEECER: remove hardcoded paths
+
12 Nov 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
SEECER-0.1.3-r1.ebuild:
sci-biology/SEECER: install also the main program wrapper
diff --git a/sci-biology/SEECER/SEECER-0.1.3-r1.ebuild b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
index 1110b97e0..730c4291e 100644
--- a/sci-biology/SEECER/SEECER-0.1.3-r1.ebuild
+++ b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit eutils
+
DESCRIPTION="SEquencing Error Corrector for RNA-Seq reads"
HOMEPAGE="http://sb.cs.cmu.edu/seecer/"
SRC_URI="
@@ -27,6 +29,7 @@ S="${S}"/SEECER
src_prepare(){
# http://seecer-rna-read-error-correction-mailing-list.21961.x6.nabble.com/Segmentation-fault-in-step-4-td41.html
cp -p "${FILESDIR}"/replace_ids.cc "${S}"/src/ || die
+ epatch "${FILESDIR}"/remove-hardcoded-paths.patch
}
src_install(){
diff --git a/sci-biology/SEECER/files/remove-hardcoded-paths.patch b/sci-biology/SEECER/files/remove-hardcoded-paths.patch
new file mode 100644
index 000000000..9258e5005
--- /dev/null
+++ b/sci-biology/SEECER/files/remove-hardcoded-paths.patch
@@ -0,0 +1,49 @@
+--- SEECER-0.1.3/SEECER/bin/run_seecer.sh.old 2015-11-13 18:17:53.985784977 +0100
++++ SEECER-0.1.3/SEECER/bin/run_seecer.sh 2015-11-13 18:20:19.995787411 +0100
+@@ -25,8 +25,8 @@
+ #
+
+
+-BINDIR='bin/' #this can be hardcoded to /absolute/path/to/SEECER/bin/
+-JF="../jellyfish-1.1.11/bin/jellyfish" #this may be hardcoded to /absolute/path/to/jellyfish/bin/
++BINDIR='' #this can be hardcoded to /absolute/path/to/SEECER/bin/
++JF="jellyfish" #this may be hardcoded to /absolute/path/to/jellyfish/bin/
+
+ K=17
+ SEECER_PARAMS=""
+@@ -149,7 +149,7 @@
+ then
+ echo "++ Step 1: Replacing Ns ... and stripping off read IDs"
+ echo
+- ${BINDIR}/random_sub_N $RS_ARGS
++ "${BINDIR}"random_sub_N $RS_ARGS
+ fi;
+
+ if [ ! -r $Read1_N ];
+@@ -166,7 +166,7 @@
+ then
+ echo "++ Step 2: Running JELLYFISH to count kmers ..."
+ echo
+- bash ${BINDIR}/run_jellyfish.sh $JF $TMPDIR/counts_${K}_${LCOUNT} $K $LCOUNT $TMPDIR $Read1_N $Read2_N
++ bash "${BINDIR}"run_jellyfish.sh $JF $TMPDIR/counts_${K}_${LCOUNT} $K $LCOUNT $TMPDIR $Read1_N $Read2_N
+ fi;
+
+ if [ ! -r $TMPDIR/counts_${K}_${LCOUNT} ];
+@@ -185,7 +185,7 @@
+ echo "-----------------------------------------------------------------------"
+ echo " *** Start time: " `date`;
+
+- ${BINDIR}/seecer $Read1_N $Read2_N $SEECER_PARAMS --kmer $K -k $TMPDIR/counts_${K}_${LCOUNT} -o $TMPDIR/corrected.fasta
++ "${BINDIR}"seecer $Read1_N $Read2_N $SEECER_PARAMS --kmer $K -k $TMPDIR/counts_${K}_${LCOUNT} -o $TMPDIR/corrected.fasta
+ echo " *** End time: " `date`;
+ echo "-----------------------------------------------------------------------"
+ echo
+@@ -204,7 +204,7 @@
+ if [ $SeecerStep -le 4 ];
+ then
+ echo "++ Step 4: Cleaning and putting back original read IDs ... We finish soon!"
+- ${BINDIR}/replace_ids $TMPDIR/corrected.fasta $Reads $Reads_N $Reads_O
++ "${BINDIR}"replace_ids $TMPDIR/corrected.fasta $Reads $Reads_N $Reads_O
+ # rm $TMPDIR/corrected.fasta
+ fi;
+