aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-15 19:42:06 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-15 19:42:06 +0100
commite1d13a2f0d3827367a8e5b10813a1dafbcbd46ae (patch)
tree2cee2c8dbdc89b0b198eb79040809c6b23e06937 /sci-biology/SEECER
parentsci-biology/Rcorrector: respect CXXFLAGS (diff)
downloadsci-e1d13a2f0d3827367a8e5b10813a1dafbcbd46ae.tar.gz
sci-e1d13a2f0d3827367a8e5b10813a1dafbcbd46ae.tar.bz2
sci-e1d13a2f0d3827367a8e5b10813a1dafbcbd46ae.zip
sci-biology/SEECER: add einfo() message that default kmer size 17 is suboptimal
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/SEECER')
-rw-r--r--sci-biology/SEECER/ChangeLog5
-rw-r--r--sci-biology/SEECER/SEECER-0.1.3-r2.ebuild13
2 files changed, 16 insertions, 2 deletions
diff --git a/sci-biology/SEECER/ChangeLog b/sci-biology/SEECER/ChangeLog
index b72cc461e..1302cab1e 100644
--- a/sci-biology/SEECER/ChangeLog
+++ b/sci-biology/SEECER/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 15 Nov 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ SEECER-0.1.3-r2.ebuild:
+ sci-biology/SEECER: add einfo() message that default kmer size 17 is
+ suboptimal
+
13 Nov 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
SEECER-0.1.3-r2.ebuild, files/remove-hardcoded-paths.patch:
sci-biology/SEECER: patch crappy shellscripts to at leats die on error;
diff --git a/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
index 3a9138c04..8d8e91972 100644
--- a/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
+++ b/sci-biology/SEECER/SEECER-0.1.3-r2.ebuild
@@ -8,13 +8,18 @@ inherit eutils
DESCRIPTION="SEquencing Error Corrector for RNA-Seq reads"
HOMEPAGE="http://sb.cs.cmu.edu/seecer/"
-SRC_URI="
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/haisonle/SEECER.git"
+ KEYWORDS=""
+else
+ SRC_URI="
http://sb.cs.cmu.edu/seecer/downloads/"${P}".tar.gz
http://sb.cs.cmu.edu/seecer/downloads/manual.pdf -> "${PN}"-manual.pdf"
+ KEYWORDS="~amd64"
+fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
IUSE=""
# although has bundled jellyfish-1.1.11 copy it just calls the executable during runtime
@@ -37,3 +42,7 @@ src_install(){
dobin bin/seecer bin/random_sub_N bin/replace_ids bin/run_jellyfish.sh bin/run_seecer.sh
dodoc README "${DISTDIR}"/"${PN}"-manual.pdf
}
+
+pkg_postinst(){
+ einfo "Note that the default kmer size 17 is terribly suboptimal, use k=31 instead"
+}