aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-11-15 20:13:13 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-11-15 20:13:13 +0100
commitbee1add2f405f7e728e35c473d6cc85acd05e0e6 (patch)
treef7fcf93acfd12dfa2cab3ef04e637b60dca8fdd7 /sci-biology/VarScan/VarScan-2.4.2.ebuild
parentRevert "sci-biology/VarScan: remove a package skeleton, no sources available" (diff)
downloadsci-bee1add2f405f7e728e35c473d6cc85acd05e0e6.tar.gz
sci-bee1add2f405f7e728e35c473d6cc85acd05e0e6.tar.bz2
sci-bee1add2f405f7e728e35c473d6cc85acd05e0e6.zip
sci-biology/VarScan: install upstream jar with *.java and *.class files
Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/VarScan/VarScan-2.4.2.ebuild')
-rw-r--r--sci-biology/VarScan/VarScan-2.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/VarScan/VarScan-2.4.2.ebuild b/sci-biology/VarScan/VarScan-2.4.2.ebuild
new file mode 100644
index 000000000..63eb84a09
--- /dev/null
+++ b/sci-biology/VarScan/VarScan-2.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Variant detection (germline, multi-sample, somatic mutations, CNA, SNP calls)"
+HOMEPAGE="http://varscan.sourceforge.net/"
+
+# binary
+#http://downloads.sourceforge.net/project/varscan/VarScan.v2.3.7.jar
+#SRC_URI="http://downloads.sourceforge.net/project/varscan/${PN}.v${PV}.jar"
+SRC_URI="http://downloads.sourceforge.net/project/varscan/${PN}.v${PV}.source.jar"
+
+LICENSE="Non-profit-OSL-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=virtual/jdk-1.5:*
+ !sci-biology/VarScan-bin"
+RDEPEND=">=virtual/jre-1.5:*"
+
+S="${WORKDIR}"/net/sf/varscan
+
+src_compile(){
+ javac *.java
+}
+
+src_install(){
+ java-pkg_newjar "${DISTDIR}"/${PN}.v${PV}.source.jar ${PN}.source.jar
+ java-pkg_dolauncher VarScan
+}