aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-06-09 12:24:16 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-06-09 12:24:16 +0200
commitd33eacc4b6316885d2d31c3ef5774bb731242cd7 (patch)
treeb09741ae9f5af242530ddab92d20ffff1c3c5706 /sci-biology/artemis
parentsci-biology/artemis-bin: ebuild cleanup (diff)
downloadsci-d33eacc4b6316885d2d31c3ef5774bb731242cd7.tar.gz
sci-d33eacc4b6316885d2d31c3ef5774bb731242cd7.tar.bz2
sci-d33eacc4b6316885d2d31c3ef5774bb731242cd7.zip
sci-biology/artemis: ebuild cleanup; officially there is not install and one needs to keep the structure of the source tree and execute directly from there; therefore the ebuild does not work yet
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/artemis')
-rw-r--r--sci-biology/artemis/ChangeLog5
-rw-r--r--sci-biology/artemis/Manifest1
-rw-r--r--sci-biology/artemis/artemis-9999.ebuild38
3 files changed, 39 insertions, 5 deletions
diff --git a/sci-biology/artemis/ChangeLog b/sci-biology/artemis/ChangeLog
index 4bebaffc8..818f34c42 100644
--- a/sci-biology/artemis/ChangeLog
+++ b/sci-biology/artemis/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Jun 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> artemis-9999.ebuild:
+ sci-biology/artemis: ebuild cleanup; officially there is not install and one
+ needs to keep the structure of the source tree and execute directly from
+ there; therefore the ebuild does not work yet
+
18 Feb 2015; Justin Lecher <jlec@gentoo.org> artemis-9999.ebuild:
sci-biology/artemis: fix SLOT operators
diff --git a/sci-biology/artemis/Manifest b/sci-biology/artemis/Manifest
new file mode 100644
index 000000000..1c027d782
--- /dev/null
+++ b/sci-biology/artemis/Manifest
@@ -0,0 +1 @@
+DIST artemis.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
diff --git a/sci-biology/artemis/artemis-9999.ebuild b/sci-biology/artemis/artemis-9999.ebuild
index 630e392f3..8db550951 100644
--- a/sci-biology/artemis/artemis-9999.ebuild
+++ b/sci-biology/artemis/artemis-9999.ebuild
@@ -6,9 +6,9 @@ EAPI=5
inherit java-pkg-2 java-ant-2 git-r3
-DESCRIPTION="DNA sequence viewer, annotation (Artemis) and comparison (ACT) tool"
+DESCRIPTION="DNA sequence viewer/annotation (Artemis) and comparison (ACT) tool"
HOMEPAGE="http://www.sanger.ac.uk/resources/software/artemis"
-SRC_URI=""
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf"
EGIT_REPO_URI="https://github.com/sanger-pathogens/Artemis"
LICENSE="GPL-2"
@@ -21,13 +21,41 @@ RDEPEND="
sci-biology/samtools
>=virtual/jre-1.6:*"
DEPEND="${RDEPEND}
+ !sci-biology/artemis-bin
dev-java/ant-core
- >=virtual/jdk-1.6:*"
+ >=virtual/jdk-1.6:*
+ dev-java/log4j
+ dev-java/jdbc-postgresql
+ dev-java/jakarta-regexp
+ dev-java/batik
+ dev-java/j2ssh
+ sci-biology/picard
+ dev-java/biojava"
+# some more dependencies extracted from /usr/bin/act
+# JacORB.jar, jemAlign.jar, macos.jar, chado-14-interface.jar, iBatis, biojava.jar,
+#
# http://www.mail-archive.com/artemis-users@sanger.ac.uk/msg00551.html
# http://www.mail-archive.com/artemis-users@sanger.ac.uk/msg00561.html
# http://gmod.org/wiki/Artemis-Chado_Integration_Tutorial
-# ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf
-
# BamView is at http://bamview.sourceforge.net/
+
+src_compile(){
+ ant || die
+}
+
+src_install(){
+ dobin act act.command art dnaplotter gff2embl
+ java-pkg_dojar ant-build/artemis.jar
+ dodoc "${DISTDIR}"/artemis.pdf README
+}
+
+# artemis_compiled_v16.0.11.tar.gz contains compiled binaries but also java *.class files
+# artemis_v16.0.11.jar and sartemis_v16.0.11.jar
+# ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v16/v16.0.11/
+
+pkg_postinst(){
+ einfo "For BAM file support please install sci-biology/BamView"
+ einfo " from http://bamview.sourceforge.net"
+}