aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinlin Yan <yanlinlin82@gmail.com>2014-12-20 16:14:04 +0800
committerLinlin Yan <yanlinlin82@gmail.com>2014-12-20 16:14:04 +0800
commit1ecaad76c11f5dce7a466addc22a17fe325a06b4 (patch)
treeba51834830ef62840061d5e64c677887cad9f0d8 /sci-biology/bismark/bismark-0.13.0.ebuild
parentsci-chemistry/freeon-9999: Move files. (diff)
downloadsci-1ecaad76c11f5dce7a466addc22a17fe325a06b4.tar.gz
sci-1ecaad76c11f5dce7a466addc22a17fe325a06b4.tar.bz2
sci-1ecaad76c11f5dce7a466addc22a17fe325a06b4.zip
sci-biology/bismark: Add new package.
Diffstat (limited to 'sci-biology/bismark/bismark-0.13.0.ebuild')
-rw-r--r--sci-biology/bismark/bismark-0.13.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/bismark/bismark-0.13.0.ebuild b/sci-biology/bismark/bismark-0.13.0.ebuild
new file mode 100644
index 000000000..b62a44aa2
--- /dev/null
+++ b/sci-biology/bismark/bismark-0.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to map bisulfite converted sequence reads and determine cytosine methylation states"
+HOMEPAGE="http://www.bioinformatics.babraham.ac.uk/projects/bismark/"
+SRC_URI="http://www.bioinformatics.babraham.ac.uk/projects/${PN}/${PN}_v${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+doc"
+
+DEPEND=""
+RDEPEND="sci-biology/bowtie"
+
+S="${WORKDIR}/${PN}_v${PV}"
+
+src_install() {
+ dobin bismark{,2bedGraph,2report,_genome_preparation,_methylation_extractor} coverage2cytosine deduplicate_bismark
+ dodir /usr/share/${P}
+ insinto /usr/share/${P}
+ doins bismark_sitrep.tpl
+ dosym /usr/share/${P}/bismark_sitrep.tpl /usr/bin/bismark_sitrep.tpl
+ if use doc; then
+ dodoc Bismark_User_Guide.pdf RRBS_Guide.pdf license.txt RELEASE_NOTES.txt
+ fi
+}