aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-10 19:21:59 +0200
committerTed Tanberry <ted.tanberry@gmail.com>2015-10-10 19:21:59 +0200
commit72ec06023243088ee31dacc6a9189c986c011561 (patch)
tree8ee948f2058960eee0421690af88e78759a0b249 /sci-biology/bowtie
parentMerge pull request #510 from SoapZaNet/pysam-0.8.3 (diff)
downloadsci-72ec06023243088ee31dacc6a9189c986c011561.tar.gz
sci-72ec06023243088ee31dacc6a9189c986c011561.tar.bz2
sci-72ec06023243088ee31dacc6a9189c986c011561.zip
sci-biology/bowtie: Version bump to 1.1.2
dev-cpp/tbb is now supported with 'tbb' USE flag.
Diffstat (limited to 'sci-biology/bowtie')
-rw-r--r--sci-biology/bowtie/ChangeLog7
-rw-r--r--sci-biology/bowtie/Manifest1
-rw-r--r--sci-biology/bowtie/bowtie-1.1.2.ebuild64
-rw-r--r--sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch14
-rw-r--r--sci-biology/bowtie/metadata.xml5
5 files changed, 91 insertions, 0 deletions
diff --git a/sci-biology/bowtie/ChangeLog b/sci-biology/bowtie/ChangeLog
index e05b4dc54..42bdbdfd4 100644
--- a/sci-biology/bowtie/ChangeLog
+++ b/sci-biology/bowtie/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*bowtie-1.1.2 (10 Oct 2015)
+
+ 10 Oct 2015; Ted Tanberry <ted.tanberry@gmail.com> +bowtie-1.1.2.ebuild,
+ +files/bowtie-1.1.2-tbb-tinythread-missing.patch, metadata.xml:
+ sci-biology/bowtie: Version bump to 1.1.2, support dev-cpp/tbb with
+ USE flag.
+
08 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
sci-biology/bowtie: Updating remote-id in metadata.xml
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index df99ece11..984902e72 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1,3 +1,4 @@
DIST bowtie-1.1.1-src.zip 7711451 SHA256 92aacb2d32065ebee433ce76eff673c24ed12591eb6c20e22ad7e4a790c48f72 SHA512 b7e2604902d846e5e1ce79ae79eceed5401070e7db76f6875d1617e277f8244a32930b334b20869c712bab58d7d88ae26f2569350c8324df4dddae0400c013f9 WHIRLPOOL 65d1248280b32ca1f6cf7c270895abdfbec27f32128915b13a01e43a7697a743f1872440f528b29413140c260e9b7f61b6a4d435f3f83be486972b6b1533d6a5
+DIST bowtie-1.1.2-src.zip 7713258 SHA256 b1e9ccc825207efd1893d9e33244c681bcb89b9b2b811eb95a9f5a92eab637ae SHA512 3d3d69bc3a865bb577b5a91440215d0d5b606c7a8751d565e606e36adbfbdef695b1718ae81cd3e2682a39ca7784c4d00976441e7618264ad99b04c7f53c36e8 WHIRLPOOL 08cb824bf7a1ddfbe6692de67191aacf44776d7d4e0ab66bd2a13ecfffd087bc28cdde4c7285c781fa4759de0a239e68f87b702bcc2e24c9b81fda5804360ce7
DIST bowtie2-2.2.3-source.zip 5724584 SHA256 c4f5ce9f0f53a6b8c7f573a26e96f6909f25bd4e0e8bd77191eaa10671baf0bf SHA512 3baf0e764a79e34b6767a62d52777fc528a82481f417ea5f1b24f38e01fac68c2870daff3060c8da11681d3270e15a10ede034356522336a94f0936d70874684 WHIRLPOOL e19ea1cee85c5ccbc198a981587e8832ebfb4bd9a02332d8171d218e89e6c84df5760db6cd1f8195b712097c6ff3ae7790415d1e63afd2632979392709de26ab
DIST bowtie2-2.2.5-source.zip 5725798 SHA256 e22766dd9421c10e82a3e207ee1f0eb924c025b909ad5fffa36633cd7978d3b0 SHA512 8b97860fea73ef36a60dee3dbccdfc956ac7f619ec47a7b820d1df09cff8f77362ddc8071b59ea8021444bda59757d68bdf486fb453d5c4e4b896198bc465d60 WHIRLPOOL 7a8eb7e6d723ccb807a1db3b724326764f8f339017c0b4eb6b234e034458e736ba521106bcc8347c3c428008d8f138f463f3c3e6033b781e1c41898735c2a878
diff --git a/sci-biology/bowtie/bowtie-1.1.2.ebuild b/sci-biology/bowtie/bowtie-1.1.2.ebuild
new file mode 100644
index 000000000..e4436860c
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-1.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Short read (below 50nt) aligner requiring end-to-end match, no gaps"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="1"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+IUSE="examples tbb"
+
+DEPEND="app-arch/unzip
+ tbb? ( dev-cpp/tbb )"
+RDEPEND=""
+
+DOCS=( AUTHORS NEWS TUTORIAL doc/README )
+HTML_DOCS=( doc/{manual.html,style.css} )
+
+src_prepare() {
+ # Suppress useless -Wall pollution
+ sed -i 's/\-Wall/\-Wno-enum-compare/g' Makefile || die
+
+ # always include tinythread.cpp
+ epatch "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
+}
+
+src_compile() {
+ if use tbb ; then
+ TBB="1"
+ else
+ TBB="0"
+ fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CFLAGS="" \
+ CXXFLAGS="" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}" \
+ WITH_TBB="${TBB}"
+}
+
+src_install() {
+ dobin ${PN} ${PN}-*
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ newman MANUAL ${PN}.1
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+ fi
+}
diff --git a/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
new file mode 100644
index 000000000..2a081ff29
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-1.1.2-tbb-tinythread-missing.patch
@@ -0,0 +1,14 @@
+--- bowtie-1.1.2/Makefile
++++ bowtie-1.1.2/Makefile
+@@ -106,10 +106,7 @@
+ endif
+
+ OTHER_CPPS = ccnt_lut.cpp ref_read.cpp alphabet.cpp shmem.cpp \
+- edit.cpp ebwt.cpp
+-ifneq (1,$(WITH_TBB))
+- OTHER_CPPS += tinythread.cpp
+-endif
++ edit.cpp ebwt.cpp tinythread.cpp
+
+ SEARCH_CPPS = qual.cpp pat.cpp ebwt_search_util.cpp ref_aligner.cpp \
+ log.cpp hit_set.cpp refmap.cpp annot.cpp sam.cpp \
diff --git a/sci-biology/bowtie/metadata.xml b/sci-biology/bowtie/metadata.xml
index e49341707..1aef69014 100644
--- a/sci-biology/bowtie/metadata.xml
+++ b/sci-biology/bowtie/metadata.xml
@@ -5,4 +5,9 @@
<upstream>
<remote-id type="sourceforge">bowtie-bio</remote-id>
</upstream>
+ <use>
+ <flag name='tbb'>Enables building bowtie with the Intel
+ Threading Building Blocks from <pkg>dev-cpp/tbb</pkg>. This
+ flag is recommended.</flag>
+ </use>
</pkgmetadata>