aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-06 10:37:28 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-09 08:48:34 +0100
commit6ee8d483c8788e331f785fe304231a7d93945f94 (patch)
treefe66a864734cdd154aa1c0841c6d4fa2ce3390c5 /sci-biology/brat/brat-1.2.4.ebuild
parentsci-libs/xraylib: Make python stuff optional under USE=python (diff)
downloadsci-6ee8d483c8788e331f785fe304231a7d93945f94.tar.gz
sci-6ee8d483c8788e331f785fe304231a7d93945f94.tar.bz2
sci-6ee8d483c8788e331f785fe304231a7d93945f94.zip
sci-biology/brat: Version Bump
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-biology/brat/brat-1.2.4.ebuild')
-rw-r--r--sci-biology/brat/brat-1.2.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/brat/brat-1.2.4.ebuild b/sci-biology/brat/brat-1.2.4.ebuild
new file mode 100644
index 000000000..6e971a0db
--- /dev/null
+++ b/sci-biology/brat/brat-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bfast/bfast-0.6.4c.ebuild,v 1.1 2010/05/07 19:21:57 weaver Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Bisulfite-treated Reads Analysis Tool"
+HOMEPAGE="http://compbio.cs.ucr.edu/brat/"
+SRC_URI="http://compbio.cs.ucr.edu/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e "s:g++:$(tc-getCXX):g" \
+ -e "s:-O3:${CFLAGS} ${LDFLAGS}:g" \
+ -e "s:-w:-Wall:g" \
+ -i Makefile || die
+}
+
+src_test() {
+ cd test_quick_start || die
+ ebegin "unpacking test files"
+ tar xzf test_data.tgz || die
+ eend $?
+
+ ../brat -r references.txt -1 test_reads1.txt -2 test_reads2.txt -o output.txt -bs -pe -i 200 -a 300 || die
+ ../brat -r references.txt -s test_reads1.txt -o output_singles1.txt -bs || die
+ ../brat -r references.txt -s test_reads2.txt -o output_singles2.txt -bs -A || die
+}
+
+src_install() {
+ dobin ${PN} ${PN}-large trim acgt-count ${PN}-large-build rev-compl check-strands remove-dupl convert-to-sam
+ dodoc BRAT_USER_MANUAL_*.pdf
+}