aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-04-02 00:10:47 -0400
committerHorea Christian <chr@chymera.eu>2020-04-02 00:10:47 -0400
commitca73ecf31bb85b7a3a976df75fbdbec29627ff12 (patch)
treee8498f65109752ef759725822bb0b07cfd4298bc /sci-biology/bruker2nifti
parentsci-visualization/mricron: removed package (diff)
downloadsci-ca73ecf31bb85b7a3a976df75fbdbec29627ff12.tar.gz
sci-ca73ecf31bb85b7a3a976df75fbdbec29627ff12.tar.bz2
sci-ca73ecf31bb85b7a3a976df75fbdbec29627ff12.zip
sci-biology/bruker2nifti: new package
Python Bruker ParaVision to NIfTI converter Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology/bruker2nifti')
-rw-r--r--sci-biology/bruker2nifti/Manifest1
-rw-r--r--sci-biology/bruker2nifti/bruker2nifti-1.0.4.ebuild31
-rw-r--r--sci-biology/bruker2nifti/metadata.xml16
3 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/bruker2nifti/Manifest b/sci-biology/bruker2nifti/Manifest
new file mode 100644
index 000000000..689ee2686
--- /dev/null
+++ b/sci-biology/bruker2nifti/Manifest
@@ -0,0 +1 @@
+DIST bruker2nifti-1.0.4.tar.gz 1224995 BLAKE2B 034568e5184233a82ea5c027b76413c849d07e763ff56ca2c3a9fed7bb03975cd4fec5f0625850ca0d6bb4d0f866c0a15e5151b0a9263c319a7c5d236fe29ae1 SHA512 59c1996727f2bfe7f3f76dd47410e93f6fa9d0c6c4d93919861c841db41f717db5ed7e628fe930cccabc09caea467ea32de47f4889c61fbd4f6b7640d890e02d
diff --git a/sci-biology/bruker2nifti/bruker2nifti-1.0.4.ebuild b/sci-biology/bruker2nifti/bruker2nifti-1.0.4.ebuild
new file mode 100644
index 000000000..2297139a2
--- /dev/null
+++ b/sci-biology/bruker2nifti/bruker2nifti-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Medical image converter, from raw Bruker ParaVision to NIfTI"
+HOMEPAGE="https://github.com/SebastianoF/bruker2nifti"
+SRC_URI="https://github.com/SebastianoF/bruker2nifti/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+#S="${WORKDIR}/Bru2Nii-${PV}"
+
+python_prepare_all() {
+ sed -i -e "s/packages=find_packages()/packages=find_packages(exclude=('test',))/g"\
+ setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest
diff --git a/sci-biology/bruker2nifti/metadata.xml b/sci-biology/bruker2nifti/metadata.xml
new file mode 100644
index 000000000..d67826b4d
--- /dev/null
+++ b/sci-biology/bruker2nifti/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Bruker2nifti is an open source medical image format converter from
+ raw Bruker ParaVision to NifTi, without any intermediate step through
+ the DICOM standard format.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SebastianoF/bruker2nifti</remote-id>
+ </upstream>
+</pkgmetadata>