aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 18:47:02 +0100
committerHorea Christian <chr@chymera.eu>2021-01-04 00:36:39 -0500
commit3916dc47dbb884e2a8b8f5b541f992d2e93ff98f (patch)
tree4eb733ee72c5c809be299cc36a80343cf16953bc /sci-biology/bx-python
parentdev-python/pyzotero: python client for zotero (diff)
downloadsci-3916dc47dbb884e2a8b8f5b541f992d2e93ff98f.tar.gz
sci-3916dc47dbb884e2a8b8f5b541f992d2e93ff98f.tar.bz2
sci-3916dc47dbb884e2a8b8f5b541f992d2e93ff98f.zip
sci-biology/bx-python: drop py3.6, add dep on cython and six
add blocker with RSeQC Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu> Closes https://github.com/gentoo/sci/pull/1007
Diffstat (limited to 'sci-biology/bx-python')
-rw-r--r--sci-biology/bx-python/bx-python-0.8.9.ebuild18
-rw-r--r--sci-biology/bx-python/bx-python-9999.ebuild16
2 files changed, 23 insertions, 11 deletions
diff --git a/sci-biology/bx-python/bx-python-0.8.9.ebuild b/sci-biology/bx-python/bx-python-0.8.9.ebuild
index c4d4b6060..15647034a 100644
--- a/sci-biology/bx-python/bx-python-0.8.9.ebuild
+++ b/sci-biology/bx-python/bx-python-0.8.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -13,11 +13,17 @@ SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sci-biology/RSeQC
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
# has file collision with sci-biology/RSeQC
+
+# ToDo: fix doc building:
+# Reason: TemplateNotFound('i')
+#distutils_enable_sphinx doc/source
diff --git a/sci-biology/bx-python/bx-python-9999.ebuild b/sci-biology/bx-python/bx-python-9999.ebuild
index 778cdd06e..8d92b0a18 100644
--- a/sci-biology/bx-python/bx-python-9999.ebuild
+++ b/sci-biology/bx-python/bx-python-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 git-r3
@@ -15,10 +15,16 @@ EGIT_REPO_URI="https://github.com/bxlab/bx-python"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sci-biology/RSeQC
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
# has file collision with sci-biology/RSeQC
+
+# ToDo: fix doc building:
+# Reason: TemplateNotFound('i')
+#distutils_enable_sphinx doc/source