aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-21 21:44:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-21 21:44:11 +0200
commit93d686395d6a556c97581052653842280e0b6165 (patch)
treeee77eca2c30e799bf49763708900c9c8e03f5037 /sci-biology/cdbfasta/cdbfasta-0.1.ebuild
parentsci-biology/autoeditor: Bump to EAPI 5 (diff)
downloadsci-93d686395d6a556c97581052653842280e0b6165.tar.gz
sci-93d686395d6a556c97581052653842280e0b6165.tar.bz2
sci-93d686395d6a556c97581052653842280e0b6165.zip
sci-biology/cdbfasta: Bump EAPI to 5
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/cdbfasta/cdbfasta-0.1.ebuild')
-rw-r--r--sci-biology/cdbfasta/cdbfasta-0.1.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/sci-biology/cdbfasta/cdbfasta-0.1.ebuild b/sci-biology/cdbfasta/cdbfasta-0.1.ebuild
index 05313b2a0..06cc24366 100644
--- a/sci-biology/cdbfasta/cdbfasta-0.1.ebuild
+++ b/sci-biology/cdbfasta/cdbfasta-0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=5
-DESCRIPTION="A FASTA record indexing/retrievieng utility, a part of TIGR Gene Indices project tools"
+DESCRIPTION="FASTA record indexing/retrievieng utility, a part of TIGR Gene Indices project tools"
HOMEPAGE="http://compbio.dfci.harvard.edu/tgi/software"
SRC_URI="ftp://occams.dfci.harvard.edu/pub/bio/tgi/software/cdbfasta/cdbfasta.tar.gz"
@@ -13,23 +13,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack cdbfasta.tar.gz
-}
-
-src_compile() {
- sed -i 's/CFLAGS[ ]*=/CFLAGS :=/; s/-D_REENTRANT/-D_REENTRANT \${CFLAGS}/; s/CFLAGS[ ]*:=[ ]*-O2$//' "${S}"/Makefile || die "Failed to patch Makefile"
+src_prepare() {
+ sed \
+ -e 's/CFLAGS[ ]*=/CFLAGS :=/; s/-D_REENTRANT/-D_REENTRANT \${CFLAGS}/; s/CFLAGS[ ]*:=[ ]*-O2$//' \
+ -i "${S}"/Makefile || die "Failed to patch Makefile"
sed -i 's/-march=i686//' "${S}"/Makefile || die
sed -i 's/-O2 //' "${S}"/Makefile || die
- emake || die "emake failed"
}
src_install() {
- dobin {cdbfasta,cdbyank} || die "Failed to install binaries"
- newdoc README README.${PN} || die
+ dobin {cdbfasta,cdbyank}
+ newdoc README README.${PN}
}