aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 16:53:08 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 19:05:31 +0100
commit5c00b7d3b2bf6c5febb225a4abf08960ca83f42d (patch)
tree2ffcb53f00a0d376068837ea060317712c2bddad /sci-biology/chiron
parentsci-chemistry/pymol-plugins-psico: bump py targets, add keywords (diff)
downloadsci-5c00b7d3b2bf6c5febb225a4abf08960ca83f42d.tar.gz
sci-5c00b7d3b2bf6c5febb225a4abf08960ca83f42d.tar.bz2
sci-5c00b7d3b2bf6c5febb225a4abf08960ca83f42d.zip
sci-biology/chiron: bump py targets, add keywords
Closes: https://github.com/gentoo/sci/pull/1037 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/chiron')
-rw-r--r--sci-biology/chiron/Manifest1
-rw-r--r--sci-biology/chiron/chiron-0.6.1.1.ebuild29
-rw-r--r--sci-biology/chiron/chiron-9999.ebuild22
3 files changed, 30 insertions, 22 deletions
diff --git a/sci-biology/chiron/Manifest b/sci-biology/chiron/Manifest
new file mode 100644
index 000000000..2cde5a081
--- /dev/null
+++ b/sci-biology/chiron/Manifest
@@ -0,0 +1 @@
+DIST chiron-0.6.1.1.tar.gz 53281188 BLAKE2B 56c623ec0d2f8970cd03d892d321362145b44890a0384d5209a2bd8c19b22509ec0557e539f021240a447e836ca6cd3531f3c9ac827b6ece715b086fca73d9f3 SHA512 b74e7f3cea9d206bc0c456189ec643de684a866bdb2dd6fd9d05ac11efd2b980d1aa09f7fc2a2aa3d5df56ca60e7a57c23d63e20df3df10f3ab82c5289d8a52f
diff --git a/sci-biology/chiron/chiron-0.6.1.1.ebuild b/sci-biology/chiron/chiron-0.6.1.1.ebuild
new file mode 100644
index 000000000..645e4ed30
--- /dev/null
+++ b/sci-biology/chiron/chiron-0.6.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A deep neural network basecaller for nanopore sequencing"
+HOMEPAGE="https://github.com/haotianteng/chiron
+ https://www.biorxiv.org/content/early/2017/09/12/179531"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ sci-biology/mappy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ sci-libs/tensorflow[${PYTHON_USEDEP}]
+"
diff --git a/sci-biology/chiron/chiron-9999.ebuild b/sci-biology/chiron/chiron-9999.ebuild
deleted file mode 100644
index 4294326ee..000000000
--- a/sci-biology/chiron/chiron-9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1 eutils git-r3
-
-DESCRIPTION="Basecaller for OxfordNanopore data using deep learning"
-HOMEPAGE="https://github.com/haotianteng/chiron
- https://www.biorxiv.org/content/early/2017/09/12/179531"
-EGIT_REPO_URI="https://github.com/haotianteng/chiron"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="~sci-libs/tensorflow-1.0.1"
-RDEPEND="${DEPEND}
- dev-python/h5py"