aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-07 17:20:49 +0200
committerJustin Lecher <jlec@gentoo.org>2012-06-07 17:20:49 +0200
commit8927b259cb574e45ed114fc99fdbd4d3726bbb4d (patch)
treef6a6de36f9e03fa7bea5ee866d2c28dd044d161a /sci-biology/cluster/cluster-1.50-r1.ebuild
parentMerge branch 'master' of github.com:gentoo-science/sci (diff)
downloadsci-8927b259cb574e45ed114fc99fdbd4d3726bbb4d.tar.gz
sci-8927b259cb574e45ed114fc99fdbd4d3726bbb4d.tar.bz2
sci-8927b259cb574e45ed114fc99fdbd4d3726bbb4d.zip
sci-biology/cluster: Rename cluster to cluster3, #419999
(Portage version: 2.2.0_alpha110/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-biology/cluster/cluster-1.50-r1.ebuild')
-rw-r--r--sci-biology/cluster/cluster-1.50-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/cluster/cluster-1.50-r1.ebuild b/sci-biology/cluster/cluster-1.50-r1.ebuild
new file mode 100644
index 000000000..85fb43bec
--- /dev/null
+++ b/sci-biology/cluster/cluster-1.50-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Clustering software for microarray analysis"
+HOMEPAGE="http://bonsai.ims.u-tokyo.ac.jp/~mdehoon/software/cluster/software.htm#ctv"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="Eisen"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/openmotif )"
+RDEPEND="
+ !>=media-gfx/graphviz-2.28.0
+ X? ( x11-misc/xdg-utils app-text/mupdf )"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Please obtain ${P}.tar.gz from ${HOMEPAGE} and place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:^docdir = .*$:docdir = @docdir@:' \
+ -e 's:^htmldir = .*$:htmldir = @htmldir@:' \
+ -e 's:^imagedir = .*$:imagedir = @htmldir@/images:' \
+ -e 's:^fileformatdir = .*$:fileformatdir = @docdir@:' \
+ X11/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${P}" \
+ --htmldir="/usr/share/doc/${P}/html"
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/bin/cluster{,3}
+
+ insinto /usr/share/doc/${P}/examples
+ doins example/example.c example/README
+ insinto /usr/share/doc/${PR}
+ doins doc/cluster.pdf
+}
+
+pkg_postinst() {
+ elog "We renamed the cluster binary to cluster3"
+}