aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 16:19:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 16:19:37 +0100
commit7b22a0bd06cb74e6860711e3ecb74c414a99cf23 (patch)
tree210a0dc0340bfe08cb3a2854010ebc65221d8efe /sci-biology/conform-gt
parentsci-biology/bambino: remove pack, upstream gone (diff)
downloadsci-7b22a0bd06cb74e6860711e3ecb74c414a99cf23.tar.gz
sci-7b22a0bd06cb74e6860711e3ecb74c414a99cf23.tar.bz2
sci-7b22a0bd06cb74e6860711e3ecb74c414a99cf23.zip
sci-biology/conform-gt: fix fetch, add keywords
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/conform-gt')
-rw-r--r--sci-biology/conform-gt/Manifest2
-rw-r--r--sci-biology/conform-gt/conform-gt-1174.ebuild24
2 files changed, 14 insertions, 12 deletions
diff --git a/sci-biology/conform-gt/Manifest b/sci-biology/conform-gt/Manifest
index 11bb1ffa0..efb9b49e9 100644
--- a/sci-biology/conform-gt/Manifest
+++ b/sci-biology/conform-gt/Manifest
@@ -1 +1 @@
-DIST conform-gt.r1174.zip 128608 BLAKE2B 54af005bdb32f76d6d255965bfda186c0b1fca9907d55a54d280eeaf7a26988efa7d7877400d62bb42f91dd73bea3f3ec913e29f7e2fcbaf877cff6eaf82241b SHA512 8547f122c4298e19d5284969ca7410d7a1581028e8155b554acedff16fed5d07ddb4f6f8e986279b8fec5012d7d95d278abd9af4049fa9d0ea08e5dfc775fffc
+DIST conform-gt.24May16.cee.jar 118655 BLAKE2B 9349ae8084724be365eba0dc248ff878436ef27d0d221f9a8df462ce42916417f29f3127b63aa380053039d96452792a82ac55928a36997362e51013fdf66e2a SHA512 c2588099190a15979d409bb6614aab9ccdd72f70fdd6faa9346cb288a0a1e9a34941925a4d1460b713d34baaf5fd484388e74c46f44b5befc2358eec42e361fa
diff --git a/sci-biology/conform-gt/conform-gt-1174.ebuild b/sci-biology/conform-gt/conform-gt-1174.ebuild
index 507c94c37..edd699ae1 100644
--- a/sci-biology/conform-gt/conform-gt-1174.ebuild
+++ b/sci-biology/conform-gt/conform-gt-1174.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+inherit java-pkg-2
DESCRIPTION="Modify your Variant Call Format file to be consistent with reference VCF"
-HOMEPAGE="http://faculty.washington.edu/browning/conform-gt.html"
-SRC_URI="http://faculty.washington.edu/browning/conform-gt/conform-gt.r1174.zip"
+HOMEPAGE="https://faculty.washington.edu/browning/conform-gt.html"
+SRC_URI="https://faculty.washington.edu/browning/conform-gt/conform-gt.24May16.cee.jar"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-DEPEND=""
+DEPEND=">=virtual/jre-1.7:*"
RDEPEND="${DEPEND}"
-# Some source files in the net.sf.samtools package are licensed under the MIT License.
-# http://bochet.gcc.biostat.washington.edu/beagle/1000_Genomes_phase1_vcf/
+S="${WORKDIR}"
-S="${WORKDIR}"/src
+src_install() {
+ java-pkg_newjar "${DISTDIR}/conform-gt.24May16.cee.jar" "${PN}.jar"
+}