aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <kislyuk@onyx.(none)>2009-11-23 17:43:01 -0500
committerAndrey Kislyuk <kislyuk@onyx.(none)>2009-11-23 17:43:01 -0500
commitcbf706378b8cc7a26213fd49ef61262a7a13ac33 (patch)
tree4ff9621c820c2e995f5eef5587fbf2dfc875941d /sci-biology/erpin/erpin-5.5b.ebuild
parentMerge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/sci (diff)
downloadsci-cbf706378b8cc7a26213fd49ef61262a7a13ac33.tar.gz
sci-cbf706378b8cc7a26213fd49ef61262a7a13ac33.tar.bz2
sci-cbf706378b8cc7a26213fd49ef61262a7a13ac33.zip
New package, ebuild written by me
Diffstat (limited to 'sci-biology/erpin/erpin-5.5b.ebuild')
-rw-r--r--sci-biology/erpin/erpin-5.5b.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/erpin/erpin-5.5b.ebuild b/sci-biology/erpin/erpin-5.5b.ebuild
new file mode 100644
index 000000000..8aafe2078
--- /dev/null
+++ b/sci-biology/erpin/erpin-5.5b.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/bowtie-0.10.1.ebuild,v 1.3 2009/09/22 11:43:28 maekke Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+ERPIN_BATCH_V=1.4
+
+DESCRIPTION="Easy RNA Profile IdentificatioN, an RNA motif search program"
+HOMEPAGE="http://tagc.univ-mrs.fr/erpin/"
+SRC_URI="http://rna.igmors.u-psud.fr/download/Erpin/erpin${PV}.serv.tar.gz
+ http://rna.igmors.u-psud.fr/download/Erpin/ErpinBatch.${ERPIN_BATCH_V}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="!sys-cluster/maui" # file collision
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ rm -f erpin${PV}.serv/{bin,lib}/* || die
+ rm -f ErpinBatch.${ERPIN_BATCH_V}/erpin* || die
+ find -name '*.mk' | xargs sed -i \
+ -e 's/strip $@/echo skipping strip $@/' \
+ -e '/CFLAGS =/ d' \
+ -e "s/CC = .*/CC = $(tc-getCC)/" || die
+ sed -i 's/cc -O2/$(tc-getCC) ${CFLAGS}/' erpin${PV}.serv/sum/sum.mk || die
+}
+
+src_compile() {
+ emake -C erpin${PV}.serv -f erpin.mk || die
+}
+
+src_install() {
+ dobin erpin${PV}.serv/bin/* || die
+ insinto /usr/share/${PN}
+ doins -r erpin${PV}.serv/scripts ErpinBatch.${ERPIN_BATCH_V} || die
+ exeinto /usr/share/${PN}
+ newexe "${FILESDIR}/erpincommand-${PV}.pl" erpincommand.pl || die
+ dodoc erpin${PV}.serv/doc/doc*.pdf || die
+}