aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 15:29:33 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-24 15:29:33 +0100
commite4d160b889b5217e7eff07576ce4df910ff2200a (patch)
tree619be9897eaceee0c2241f882703a00d107a5eec /sci-biology/flexbar
parentsci-biology/exonerate-gff3: remove keyword from live ebuild (diff)
downloadsci-e4d160b889b5217e7eff07576ce4df910ff2200a.tar.gz
sci-e4d160b889b5217e7eff07576ce4df910ff2200a.tar.bz2
sci-e4d160b889b5217e7eff07576ce4df910ff2200a.zip
sci-biology/flexbar: version bump, cmake-utils --> cmake
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/flexbar')
-rw-r--r--sci-biology/flexbar/Manifest3
-rw-r--r--sci-biology/flexbar/flexbar-2.7.0.ebuild33
-rw-r--r--sci-biology/flexbar/flexbar-3.5.0.ebuild (renamed from sci-biology/flexbar/flexbar-3.0.0.ebuild)10
3 files changed, 5 insertions, 41 deletions
diff --git a/sci-biology/flexbar/Manifest b/sci-biology/flexbar/Manifest
index 92c682f14..a5f19fa17 100644
--- a/sci-biology/flexbar/Manifest
+++ b/sci-biology/flexbar/Manifest
@@ -1,2 +1 @@
-DIST flexbar-2.7.0.tar.gz 30033 BLAKE2B e8c8f8e9f2e44870c844b59d40cd7c6d4da599e1d59d5b5201e3b6e3dbc2d088680253e43c5c72b57a7a33401b0a2b4770c34700e415af6be4b250c6dda0806f SHA512 38dc40476dadd769977dd2428941928e839e107e719e9b595c2ba57e1d8764fb394c5960b809da99dc939a66cae9350ea607e393b9467e98d464d0e49bcdac47
-DIST flexbar-3.0.0.tar.gz 31292 BLAKE2B 43abf3cc9d58423f1a26d52d673fd08450b149de85af49aa35036abd2906e2648d844a83b5578be57a83b5636ae70d934c48891d64596260828ea638338e8bc0 SHA512 ccefb4d1342ce5353a64510f79f8b15c409eb68853eb98ed7c9b23cb53d926e5b6965b1a9d3d8a5b3699da2f18cf8a627d5ca3ed172e25693a80d878547d6d38
+DIST flexbar-3.5.0.tar.gz 44021 BLAKE2B 2d21b366f3da5ad5a4b3c73530af11c49a131453dc1588e7836fd2060f2a1aa5c21f109bfcdc362dab6d7aeecb0bed683e58b9d50e9ba808c98bef45b2510c57 SHA512 5df1e8cb2c713256945f9fe3ed5d5faca0f3776f5be24e01ba659973e373c45b87141331fd37ceb8f38483e1ee41762671157c55798da133cbca68608e25f409
diff --git a/sci-biology/flexbar/flexbar-2.7.0.ebuild b/sci-biology/flexbar/flexbar-2.7.0.ebuild
deleted file mode 100644
index 9fc465c10..000000000
--- a/sci-biology/flexbar/flexbar-2.7.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Barcode, MID tag and adapter sequence removal"
-HOMEPAGE="https://github.com/seqan/flexbar"
-SRC_URI="https://github.com/seqan/flexbar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-CDEPEND="
- dev-cpp/tbb
- >=sci-biology/seqan-2.1.1:0"
-DEPEND="${CDEPEND}"
-RDEPEND="${CDEPEND}"
-
-# TODO: need to call 'pkg-config --cflags seqan-2.2' and pass it down
-src_configure() {
- local CPPFLAGS=${CPPFLAGS}
- append-cppflags `pkg-config --cflags seqan-2.2`
- local CXXFLAGS="${CXXFLAGS}"
- append-cxxflags "-std=c++14"
- cmake-utils_src_configure
-}
-
-# SeqAn requires C++14! You must compile your application with -std=c++14, -std=gnu++14 or -std=c++1y
-# https://github.com/seqan/flexbar/issues/8
diff --git a/sci-biology/flexbar/flexbar-3.0.0.ebuild b/sci-biology/flexbar/flexbar-3.5.0.ebuild
index 65f5dd077..b390f5056 100644
--- a/sci-biology/flexbar/flexbar-3.0.0.ebuild
+++ b/sci-biology/flexbar/flexbar-3.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Barcode, MID tag and adapter sequence removal"
HOMEPAGE="https://github.com/seqan/flexbar"
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/seqan/flexbar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
CDEPEND="
dev-cpp/tbb
@@ -28,14 +27,13 @@ src_configure() {
append-cppflags `pkg-config --cflags seqan-2.2`
local CXXFLAGS="${CXXFLAGS}"
append-cxxflags "-std=c++14"
- cmake-utils_src_configure
+ cmake_src_configure
}
# SeqAn requires C++14! You must compile your application with -std=c++14, -std=gnu++14 or -std=c++1y
# https://github.com/seqan/flexbar/issues/8
src_install(){
- elog `pwd`
dobin ../"${P}"_build/flexbar
dodoc ../"${P}"/README.md
}