aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-17 19:46:46 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-19 15:34:13 +0200
commitbd5afd76e35a6cad321d23cffb3964cd6f996c07 (patch)
tree762022a123552c518c798ee5aa51ccfdcea5a790 /sci-biology/generecon/generecon-1.2.1-r1.ebuild
parentRename 1.4.1 as 1.4.1-r1 so users can easily get stable version from main tree. (diff)
downloadsci-bd5afd76e35a6cad321d23cffb3964cd6f996c07.tar.gz
sci-bd5afd76e35a6cad321d23cffb3964cd6f996c07.tar.bz2
sci-bd5afd76e35a6cad321d23cffb3964cd6f996c07.zip
Fixing compilation with gcc4, repecting CXXFLAGS/LDFLAGS, reMANIFEST
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-biology/generecon/generecon-1.2.1-r1.ebuild')
-rw-r--r--sci-biology/generecon/generecon-1.2.1-r1.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/sci-biology/generecon/generecon-1.2.1-r1.ebuild b/sci-biology/generecon/generecon-1.2.1-r1.ebuild
index 7adfb5cf5..41e2607e5 100644
--- a/sci-biology/generecon/generecon-1.2.1-r1.ebuild
+++ b/sci-biology/generecon/generecon-1.2.1-r1.ebuild
@@ -1,37 +1,34 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+EAPI="3"
-DESCRIPTION="Generecon performs linkage disequilibrium gene mapping based on coalescent theory using Bayesian Markov Chain Monte Carlo methods."
+inherit autotools eutils
+
+DESCRIPTION="Disequilibrium gene mapping based on coalescent theory using Bayesian Markov Chain MC methods"
HOMEPAGE="http://www.daimi.au.dk/~mailund/GeneRecon/"
SRC_URI="http://www.daimi.au.dk/~mailund/GeneRecon/download/${P}.tar.gz"
-SLOT="0"
-# License of the package. This must match the name of file(s) in
-# /usr/portage/licenses/. For complex license combination see the developer
-# docs on gentoo.org for details.
+SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
-KEYWORDS="x86"
+RDEPEND="
+ dev-scheme/guile
+ sci-libs/gsl"
+DEPEND="${DEPEND}"
-DEPEND="dev-scheme/guile
- sci-libs/gsl"
-
-src_unpack() {
- unpack ${A}
- sed 's|#PF#|'${PF}'|g' ${FILESDIR}/${PN}-docfiles.patch > ${PN}-docfiles.patch
+src_prepare() {
+ sed 's|#PF#|'${PF}'|g' "${FILESDIR}"/${PN}-docfiles.patch > ${PN}-docfiles.patch
epatch ${PN}-docfiles.patch
-
- cd ${S}
- pwd
- einfo "Regenerating autotools files..."
- aclocal || die "aclocal failed"
- automake || die "automake failed"
+ epatch "${FILESDIR}"/${PV}-gcc4.patch
+ epatch "${FILESDIR}"/${PV}-flags.patch
+ eautoreconf
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
}