aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-26 09:41:48 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-26 09:41:48 +0200
commitb71c9dc45d0a26f46930158e146103fd8287260c (patch)
tree7ec939d6fcca732ceb0527970752f8ae743a09aa /sci-biology/gffcompare/files
parentsci-biology/afni: Added unstable x86 keyword (diff)
downloadsci-b71c9dc45d0a26f46930158e146103fd8287260c.tar.gz
sci-b71c9dc45d0a26f46930158e146103fd8287260c.tar.bz2
sci-b71c9dc45d0a26f46930158e146103fd8287260c.zip
sci-biology/gffcompare: new package
Is a mixture of gclib object and gffcompare objects, hence the download of two tar.gz files. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-biology/gffcompare/files')
-rw-r--r--sci-biology/gffcompare/files/Makefile.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/sci-biology/gffcompare/files/Makefile.patch b/sci-biology/gffcompare/files/Makefile.patch
new file mode 100644
index 000000000..afb52b2e1
--- /dev/null
+++ b/sci-biology/gffcompare/files/Makefile.patch
@@ -0,0 +1,79 @@
+--- gffcompare-0.10.5/Makefile 2018-06-26 09:24:06.058542487 +0200
++++ gffcompare-0.10.5/Makefile 2018-06-26 09:28:08.045119603 +0200
+@@ -16,7 +16,7 @@
+ endif
+
+ # CVS checked in
+-CC := g++
++CXX ?= g++
+ BASEFLAGS = -Wall -Wextra ${INCDIRS} $(MARCH) \
+ -fno-exceptions -fno-rtti -D_REENTRANT
+
+@@ -24,7 +24,8 @@
+
+ ifneq (,$(filter %release %static, $(MAKECMDGOALS)))
+ # -- release build
+- CFLAGS = -O3 -DNDEBUG $(BASEFLAGS)
++ CXXFLAGS ?= -O3 -g
++ CXXFLAGS += -DNDEBUG $(BASEFLAGS)
+ LDFLAGS =
+ LIBS =
+ ifneq (,$(findstring static,$(MAKECMDGOALS)))
+@@ -37,16 +38,16 @@
+ ifeq "$(GCCVER49)" "0"
+ $(error gcc version 4.9 or greater is required for this build target)
+ endif
+- CFLAGS := -fno-omit-frame-pointer -fsanitize=undefined -fsanitize=address
++ CXXFLAGS += -fno-omit-frame-pointer -fsanitize=undefined -fsanitize=address
+ GCCVER5 := $(shell expr `g++ -dumpversion | cut -f1 -d.` \>= 5)
+ ifeq "$(GCCVER5)" "1"
+- CFLAGS += -fsanitize=bounds -fsanitize=float-divide-by-zero -fsanitize=vptr
+- CFLAGS += -fsanitize=float-cast-overflow -fsanitize=object-size
+- #CFLAGS += -fcheck-pointer-bounds -mmpx
++ CXXFLAGS += -fsanitize=bounds -fsanitize=float-divide-by-zero -fsanitize=vptr
++ CXXFLAGS += -fsanitize=float-cast-overflow -fsanitize=object-size
++ #CXXFLAGS += -fcheck-pointer-bounds -mmpx
+ endif
+- CFLAGS += $(BASEFLAGS)
+- CFLAGS := -g -DDEBUG -D_DEBUG -DGDEBUG -fno-common -fstack-protector $(CFLAGS)
+- LDFLAGS := -g
++ CXXFLAGS += $(BASEFLAGS)
++ CXXFLAGS += -DDEBUG -D_DEBUG -DGDEBUG -fno-common -fstack-protector
++ LDFLAGS ?= -g
+ #LIBS := -Wl,-Bstatic -lasan -lubsan -Wl,-Bdynamic -ldl $(LIBS)
+ LIBS := -lasan -lubsan -ldl $(LIBS)
+ else
+@@ -55,26 +56,26 @@
+ # GMEMTRACE=1
+ #endif
+ #--- just plain debug build ---
+- CFLAGS = -g -DDEBUG -D_DEBUG -DGDEBUG $(BASEFLAGS)
+- LDFLAGS = -g
++ CXXFLAGS += -DDEBUG -D_DEBUG -DGDEBUG $(BASEFLAGS)
++ LDFLAGS += -g
+ LIBS =
+ endif
+ endif
+
+ %.o : %.c
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CXXFLAGS} -c $< -o $@
+
+ %.o : %.cc
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CXXFLAGS} -c $< -o $@
+
+ %.o : %.C
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CXXFLAGS} -c $< -o $@
+
+ %.o : %.cpp
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CXXFLAGS} -c $< -o $@
+
+ %.o : %.cxx
+- ${CC} ${CFLAGS} -c $< -o $@
++ ${CXX} ${CXXFLAGS} -c $< -o $@
+
+ # C/C++ linker
+