aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-26 09:41:48 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-26 09:41:48 +0200
commitb71c9dc45d0a26f46930158e146103fd8287260c (patch)
tree7ec939d6fcca732ceb0527970752f8ae743a09aa /sci-biology/gffcompare/gffcompare-0.10.5.ebuild
parentsci-biology/afni: Added unstable x86 keyword (diff)
downloadsci-b71c9dc45d0a26f46930158e146103fd8287260c.tar.gz
sci-b71c9dc45d0a26f46930158e146103fd8287260c.tar.bz2
sci-b71c9dc45d0a26f46930158e146103fd8287260c.zip
sci-biology/gffcompare: new package
Is a mixture of gclib object and gffcompare objects, hence the download of two tar.gz files. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-biology/gffcompare/gffcompare-0.10.5.ebuild')
-rw-r--r--sci-biology/gffcompare/gffcompare-0.10.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/gffcompare/gffcompare-0.10.5.ebuild b/sci-biology/gffcompare/gffcompare-0.10.5.ebuild
new file mode 100644
index 000000000..0b842d240
--- /dev/null
+++ b/sci-biology/gffcompare/gffcompare-0.10.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compare, classify, merge, track, annotate GFF files"
+HOMEPAGE="http://ccb.jhu.edu/software/stringtie/gff.shtml
+ https://github.com/gpertea/gffcompare"
+SRC_URI="https://github.com/gpertea/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/gpertea/gclib/archive/v0.10.2.tar.gz -> gclib-0.10.2.tar.gz"
+
+LICENSE="MIT Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# this cannot just depend on sci-biology/gclib (headers), the code inside
+# gclib needs to be compiled and objects get included inside gffcompare
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/Makefile.patch )
+
+src_compile(){
+ GCLIB=../gclib-0.10.2 emake
+}
+
+src_install(){
+ dobin gffcompare
+ dodoc README.md
+}