aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-18 21:22:12 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-18 21:22:12 +0100
commit1326710c5da26210005f4ec496b0c0a1af917077 (patch)
treecc47a76c8ce182043b6ba873f0f34d0e979f036a /sci-biology/jtreeview/jtreeview-9999.ebuild
parentsci-biology/jtreeview: add deemed dependency on nanoxml (diff)
downloadsci-1326710c5da26210005f4ec496b0c0a1af917077.tar.gz
sci-1326710c5da26210005f4ec496b0c0a1af917077.tar.bz2
sci-1326710c5da26210005f4ec496b0c0a1af917077.zip
sci-biology/jtreeview: add 3.0_alpha version which executes fine
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/jtreeview/jtreeview-9999.ebuild')
-rw-r--r--sci-biology/jtreeview/jtreeview-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/jtreeview/jtreeview-9999.ebuild b/sci-biology/jtreeview/jtreeview-9999.ebuild
new file mode 100644
index 000000000..24c5427ae
--- /dev/null
+++ b/sci-biology/jtreeview/jtreeview-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit java-pkg-2 git-r3
+
+DESCRIPTION="Viewer for Microarray Data in PCL or CDT formats"
+HOMEPAGE="http://jtreeview.sourceforge.net
+ https://bitbucket.org/TreeView3Dev/treeview3"
+EGIT_REPO_URI="https://bitbucket.org/TreeView3Dev/treeview3.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="" # builds and executes fines
+IUSE=""
+
+DEPEND=">virtual/jdk-1.7:*"
+RDEPEND="${DEPEND}
+ >=virtual/jre-1.7:*"
+
+src_prepare(){
+ chmod u+x ./gradle* || die
+ eapply_user
+}
+
+src_compile(){
+ # work around gradle writing $HOME/.gradle, requiring $HOME/.git and $HOME/.m2/
+ # https://github.com/samtools/htsjdk/issues/660#issuecomment-232155965
+ # make jure SDK-1.8 is available, JRE-1.8 is not enough
+ GRADLE_USER_HOME="${WORKDIR}" ./gradlew || die
+}
+
+src_install(){
+ cd build/libs || die
+ java-pkg_dojar *.jar
+ java-pkg_dolauncher ${PN}
+}