aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 13:54:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-19 13:55:06 +0100
commit26212fea17cb62e4fc20bb50e26d47e63c511b0d (patch)
tree6ff5cd55c8a8b4a0f0195c03da0915109f5863ac /sci-biology/jtreeview/jtreeview-9999.ebuild
parentsci-biology/jtreeview-bin: version bump, unmask (diff)
downloadsci-26212fea17cb62e4fc20bb50e26d47e63c511b0d.tar.gz
sci-26212fea17cb62e4fc20bb50e26d47e63c511b0d.tar.bz2
sci-26212fea17cb62e4fc20bb50e26d47e63c511b0d.zip
sci-biology/jtreeview: fix fetch, fix build, EAPI bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/jtreeview/jtreeview-9999.ebuild')
-rw-r--r--sci-biology/jtreeview/jtreeview-9999.ebuild37
1 files changed, 15 insertions, 22 deletions
diff --git a/sci-biology/jtreeview/jtreeview-9999.ebuild b/sci-biology/jtreeview/jtreeview-9999.ebuild
index 159448ab7..0b95e7cb3 100644
--- a/sci-biology/jtreeview/jtreeview-9999.ebuild
+++ b/sci-biology/jtreeview/jtreeview-9999.ebuild
@@ -1,38 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit java-pkg-2 git-r3
+inherit perl-module java-pkg-2 java-ant-2 git-r3
DESCRIPTION="Viewer for Microarray Data in PCL or CDT formats"
-HOMEPAGE="http://jtreeview.sourceforge.net
- https://bitbucket.org/TreeView3Dev/treeview3" # no https
+HOMEPAGE="http://jtreeview.sourceforge.net/" # no https
EGIT_REPO_URI="https://bitbucket.org/TreeView3Dev/treeview3.git"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="" # builds and executes fines
-IUSE=""
+KEYWORDS=""
DEPEND=">virtual/jdk-1.7:*"
RDEPEND="${DEPEND}
>=virtual/jre-1.7:*"
-src_prepare(){
- chmod u+x ./gradle* || die
- eapply_user
-}
-
-src_compile(){
- # work around gradle writing $HOME/.gradle, requiring $HOME/.git and $HOME/.m2/
- # https://github.com/samtools/htsjdk/issues/660#issuecomment-232155965
- # make jure SDK-1.8 is available, JRE-1.8 is not enough
- GRADLE_USER_HOME="${WORKDIR}" ./gradlew || die
-}
-
src_install(){
- cd build/libs || die
- java-pkg_dojar *.jar
- java-pkg_dolauncher ${PN}
+ java-pkg_dojar TreeView.jar
+ java-pkg_dolauncher ${PN} TreeView.jar
+ cd ../helper-scripts-0.0.2 || die
+ perl_set_version
+ insinto "${VENDOR_LIB}"
+ doins *.pm
+ dobin *.pl
+ insinto /usr/share/"${PN}"/examples
+ doins blues.color
+ newdoc README README.helper-scripts
}