aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 19:39:36 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-30 19:02:35 +0000
commitd7637214cd6c37456262bc62ff07eab1b1dae6b3 (patch)
tree5a0f8e5909ffa789747d33e41b20d2ce9e6684ef /sci-biology/khmer/khmer-2.1.1.ebuild
parentsci-biology/screed: version bump 1.0.4 (diff)
downloadsci-d7637214cd6c37456262bc62ff07eab1b1dae6b3.tar.gz
sci-d7637214cd6c37456262bc62ff07eab1b1dae6b3.tar.bz2
sci-d7637214cd6c37456262bc62ff07eab1b1dae6b3.zip
sci-biology/khmer: version bump 2.1.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/sci/pull/1009 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-biology/khmer/khmer-2.1.1.ebuild')
-rw-r--r--sci-biology/khmer/khmer-2.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/khmer/khmer-2.1.1.ebuild b/sci-biology/khmer/khmer-2.1.1.ebuild
new file mode 100644
index 000000000..11c4231e8
--- /dev/null
+++ b/sci-biology/khmer/khmer-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="In-memory K-mer counting in DNA/RNA/protein sequences"
+HOMEPAGE="https://github.com/dib-lab/khmer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# ToDo: Fix this:
+# ModuleNotFoundError: No module named 'khmer._khmer'
+# even happens with --install option for enable_tests
+RESTRICT="test"
+
+RDEPEND="
+ sci-biology/screed[${PYTHON_USEDEP}]
+ dev-python/bz2file[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on pytest-runner
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}