aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-23 23:26:04 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-23 23:26:04 +0200
commit6317bbf43e4179c733694df8ba540f9cfc251fbf (patch)
treeb692e69f400018012658dc8f3e8cd9e37bbab907 /sci-biology/ncbi-tools++/files
parentsci-libs/fast5: remove blank line (diff)
downloadsci-6317bbf43e4179c733694df8ba540f9cfc251fbf.tar.gz
sci-6317bbf43e4179c733694df8ba540f9cfc251fbf.tar.bz2
sci-6317bbf43e4179c733694df8ba540f9cfc251fbf.zip
sci-biology/ncbi-tools++: do not add $(PCRE_LIBS) unless necessary (from Aaron Ucko)
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology/ncbi-tools++/files')
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-annotwriter-linking.patch12
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-blast_sample-linking.patch26
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-compartp-linking.patch34
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-hfilter-linking.patch13
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-igblast-linking.patch30
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-vecscreen-linking.patch14
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-apps-blast-linking.patch155
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-srcchk-linking.patch11
8 files changed, 97 insertions, 198 deletions
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-annotwriter-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-annotwriter-linking.patch
index 3f1379223..c9428084d 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-annotwriter-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-annotwriter-linking.patch
@@ -1,5 +1,7 @@
---- ncbi_cxx--18_0_0/src/app/annotwriter/Makefile.annotwriter.app.ori 2017-03-20 18:13:08.087145846 +0100
-+++ ncbi_cxx--18_0_0/src/app/annotwriter/Makefile.annotwriter.app 2017-03-20 18:14:10.988888851 +0100
+Index: c++.18.0.0/src/app/annotwriter/Makefile.annotwriter.app
+===================================================================
+--- c++.18.0.0/src/app/annotwriter/Makefile.annotwriter.app (revision 523253)
++++ c++.18.0.0/src/app/annotwriter/Makefile.annotwriter.app (working copy)
@@ -8,8 +8,8 @@
APP = annotwriter
@@ -9,7 +11,5 @@
+LIB = xobjwrite $(XFORMAT_LIBS) variation_utils $(OBJREAD_LIBS) xalnmgr \
+ xobjutil entrez2cli entrez2 tables xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
+
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-blast_sample-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-blast_sample-linking.patch
index cc0444d5c..7a158dc5c 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-blast_sample-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-blast_sample-linking.patch
@@ -1,28 +1,26 @@
---- ncbi_cxx--18_0_0/src/sample/app/blast/Makefile.blast_sample.app.ori 2017-03-27 03:01:00.032137965 +0200
-+++ ncbi_cxx--18_0_0/src/sample/app/blast/Makefile.blast_sample.app 2017-03-27 03:01:29.732137720 +0200
-@@ -12,9 +12,9 @@
+Index: c++.18.0.0/src/sample/app/blast/Makefile.blast_sample.app
+===================================================================
+--- c++.18.0.0/src/sample/app/blast/Makefile.blast_sample.app (revision 523253)
++++ c++.18.0.0/src/sample/app/blast/Makefile.blast_sample.app (working copy)
+@@ -12,7 +12,7 @@
# the lines reading "### BEGIN/END COPIED SETTINGS" in any way.
### BEGIN COPIED SETTINGS
-LIB_ = xobjsimple $(BLAST_LIBS) $(OBJMGR_LIBS)
+LIB_ = xobjsimple $(BLAST_LIBS) xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
LIB = $(LIB_:%=%$(STATIC))
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
- # These settings are necessary for optimized WorkShop builds, due to
- # BLAST's own use of them.
---- ncbi_cxx--18_0_0/src/sample/app/blast/Makefile.vsrun_sample.app.ori 2017-03-27 03:04:52.632136045 +0200
-+++ ncbi_cxx--18_0_0/src/sample/app/blast/Makefile.vsrun_sample.app 2017-03-27 03:05:26.012135769 +0200
-@@ -12,9 +12,9 @@
+Index: c++.18.0.0/src/sample/app/blast/Makefile.vsrun_sample.app
+===================================================================
+--- c++.18.0.0/src/sample/app/blast/Makefile.vsrun_sample.app (revision 523253)
++++ c++.18.0.0/src/sample/app/blast/Makefile.vsrun_sample.app (working copy)
+@@ -12,7 +12,7 @@
# the lines reading "### BEGIN/END COPIED SETTINGS" in any way.
### BEGIN COPIED SETTINGS
-LIB_ = xobjsimple $(BLAST_INPUT_LIBS) $(BLAST_LIBS) $(OBJMGR_LIBS)
+LIB_ = xobjsimple $(BLAST_INPUT_LIBS) $(BLAST_LIBS) xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
LIB = $(LIB_:%=%$(STATIC))
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
- # These settings are necessary for optimized WorkShop builds, due to
- # BLAST's own use of them.
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-compartp-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-compartp-linking.patch
index 0b4b76e4f..749c2e57f 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-compartp-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-compartp-linking.patch
@@ -1,31 +1,29 @@
---- ncbi_cxx--18_0_0/src/app/compart/Makefile.compart.app.ori 2017-03-23 14:49:24.915182566 +0100
-+++ ncbi_cxx--18_0_0/src/app/compart/Makefile.compart.app 2017-03-23 14:50:32.926896138 +0100
-@@ -5,11 +5,11 @@
+Index: c++.18.0.0/src/app/compart/Makefile.compart.app
+===================================================================
+--- c++.18.0.0/src/app/compart/Makefile.compart.app (revision 523253)
++++ c++.18.0.0/src/app/compart/Makefile.compart.app (working copy)
+@@ -5,8 +5,8 @@
APP = compart
SRC = compart
-LIB = xalgoalignsplign xalgoalignutil xalgoalignnw xqueryparse \
- $(BLAST_LIBS:%=%$(STATIC)) \
-+LIB = xalgoalignsplign xalgoalignutil xalgoalignnw xalgoseq taxon1 xqueryparse \
-+ $(BLAST_LIBS:%=%$(STATIC)) xregexp $(REGEXP_LIB) \
++LIB = xalgoalignsplign xalgoalignutil xalgoalignnw xalgoseq taxon1 \
++ $(BLAST_LIBS:%=%$(STATIC)) xqueryparse xregexp $(PCRE_LIB) \
$(OBJMGR_LIBS:%=%$(STATIC))
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(REGEXP_LIBS) $(ORIG_LIBS)
-
- CXXFLAGS = $(FAST_CXXFLAGS)
- LDFLAGS = $(FAST_LDFLAGS)
---- ncbi_cxx--18_0_0/src/app/compart/Makefile.compartp.app.ori 2017-03-23 18:05:44.135172346 +0100
-+++ ncbi_cxx--18_0_0/src/app/compart/Makefile.compartp.app 2017-03-23 18:09:00.990132154 +0100
-@@ -5,9 +5,9 @@
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
+Index: c++.18.0.0/src/app/compart/Makefile.compartp.app
+===================================================================
+--- c++.18.0.0/src/app/compart/Makefile.compartp.app (revision 523253)
++++ c++.18.0.0/src/app/compart/Makefile.compartp.app (working copy)
+@@ -5,7 +5,8 @@
APP = compartp
SRC = compartp
-LIB = prosplign xalgoalignutil $(BLAST_LIBS) xqueryparse $(OBJMGR_LIBS)
-+LIB = prosplign xalgoalignutil xalgoseq taxon1 $(BLAST_LIBS) xqueryparse xregexp $(REGEXP_LIB) $(OBJMGR_LIBS)
++LIB = prosplign xalgoalignutil xalgoseq taxon1 $(BLAST_LIBS) xqueryparse \
++ xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
--LIBS = $(CMPRS_LIBS) $(PCRE_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(PCRE_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(REGEXP_LIBS) $(ORIG_LIBS)
+ LIBS = $(CMPRS_LIBS) $(PCRE_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
- CXXFLAGS = $(FAST_CXXFLAGS)
- LDFLAGS = $(FAST_LDFLAGS)
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-hfilter-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-hfilter-linking.patch
index 77b1ba05e..63bbcc45a 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-hfilter-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-hfilter-linking.patch
@@ -1,6 +1,8 @@
---- ncbi_cxx--18_0_0/src/app/hfilter/Makefile.hfilter.app.ori 2017-03-23 19:47:10.204018194 +0100
-+++ ncbi_cxx--18_0_0/src/app/hfilter/Makefile.hfilter.app 2017-03-23 19:51:51.601108063 +0100
-@@ -5,9 +5,10 @@
+Index: c++.18.0.0/src/app/hfilter/Makefile.hfilter.app
+===================================================================
+--- c++.18.0.0/src/app/hfilter/Makefile.hfilter.app (revision 523253)
++++ c++.18.0.0/src/app/hfilter/Makefile.hfilter.app (working copy)
+@@ -5,7 +5,8 @@
APP = hfilter
SRC = hitfilter_app
@@ -8,8 +10,5 @@
+LIB = xalgoalignutil xalgoseq taxon1 $(BLAST_LIBS) \
+ xqueryparse xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
- CXXFLAGS = $(FAST_CXXFLAGS)
- LDFLAGS = $(FAST_LDFLAGS)
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-igblast-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-igblast-linking.patch
index 8610c7fd3..ffd3f897f 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-igblast-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-igblast-linking.patch
@@ -1,5 +1,7 @@
---- ncbi_cxx--18_0_0/src/app/igblast/Makefile.igblastn.app.ori 2017-03-23 20:30:35.667921836 +0100
-+++ ncbi_cxx--18_0_0/src/app/igblast/Makefile.igblastn.app 2017-03-23 20:32:04.553561820 +0100
+Index: c++.18.0.0/src/app/igblast/Makefile.igblastn.app
+===================================================================
+--- c++.18.0.0/src/app/igblast/Makefile.igblastn.app (revision 523253)
++++ c++.18.0.0/src/app/igblast/Makefile.igblastn.app (working copy)
@@ -2,7 +2,8 @@
APP = igblastn
@@ -10,17 +12,10 @@
LIB = blast_app_util igblast $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -10,7 +11,7 @@
- CXXFLAGS = $(FAST_CXXFLAGS:ppc=i386)
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
---- ncbi_cxx--18_0_0/src/app/igblast/Makefile.igblastp.app.ori 2017-03-23 20:33:03.215124531 +0100
-+++ ncbi_cxx--18_0_0/src/app/igblast/Makefile.igblastp.app 2017-03-23 20:34:22.817243181 +0100
+Index: c++.18.0.0/src/app/igblast/Makefile.igblastp.app
+===================================================================
+--- c++.18.0.0/src/app/igblast/Makefile.igblastp.app (revision 523253)
++++ c++.18.0.0/src/app/igblast/Makefile.igblastp.app (working copy)
@@ -2,7 +2,8 @@
APP = igblastp
@@ -31,12 +26,3 @@
LIB = blast_app_util igblast $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -10,7 +11,7 @@
- CXXFLAGS = $(FAST_CXXFLAGS:ppc=i386)
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-vecscreen-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-vecscreen-linking.patch
index 9f33392d3..898e3a70b 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-vecscreen-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-app-vecscreen-linking.patch
@@ -1,5 +1,7 @@
---- ncbi_cxx--18_0_0/src/app/vecscreen/Makefile.vecscreen.app.ori 2017-03-27 02:34:44.242150979 +0200
-+++ ncbi_cxx--18_0_0/src/app/vecscreen/Makefile.vecscreen.app 2017-03-27 02:36:22.752150165 +0200
+Index: c++.18.0.0/src/app/vecscreen/Makefile.vecscreen.app
+===================================================================
+--- c++.18.0.0/src/app/vecscreen/Makefile.vecscreen.app (revision 523253)
++++ c++.18.0.0/src/app/vecscreen/Makefile.vecscreen.app (working copy)
@@ -4,7 +4,7 @@
APP = vecscreen
@@ -9,11 +11,3 @@
LIB = $(LIB_:%=%$(STATIC))
# FIXME: do we need blast_app_util
#LIB = blast_app_util $(LIB_:%=%$(STATIC))
-@@ -15,6 +15,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-apps-blast-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-apps-blast-linking.patch
index 43104976e..e9dd1f710 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-apps-blast-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-apps-blast-linking.patch
@@ -1,5 +1,7 @@
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.blast_formatter.app.ori 2017-03-22 17:21:05.653409646 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.blast_formatter.app 2017-03-22 17:22:25.755581547 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.blast_formatter.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.blast_formatter.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.blast_formatter.app (working copy)
@@ -2,7 +2,7 @@
APP = blast_formatter
@@ -9,27 +11,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -11,6 +11,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLASTFORMAT $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.blastn.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.blastn.app 2017-03-22 19:58:28.925273217 +0100
-@@ -14,7 +14,7 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.blastp.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.blastp.app 2017-03-22 19:58:54.365962959 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.blastp.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.blastp.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.blastp.app (working copy)
@@ -4,7 +4,7 @@
APP = blastp
@@ -39,17 +24,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -13,7 +13,7 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.blastx.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.blastx.app 2017-03-22 19:59:11.066415737 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.blastx.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.blastx.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.blastx.app (working copy)
@@ -4,7 +4,7 @@
APP = blastx
@@ -59,17 +37,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -13,7 +13,7 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.deltablast.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.deltablast.app 2017-03-22 19:59:30.396939821 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.deltablast.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.deltablast.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.deltablast.app (working copy)
@@ -1,7 +1,7 @@
APP = deltablast
@@ -79,16 +50,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -10,6 +10,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.psiblast.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.psiblast.app 2017-03-22 19:59:51.837521114 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.psiblast.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.psiblast.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.psiblast.app (working copy)
@@ -2,7 +2,7 @@
APP = psiblast
@@ -98,16 +63,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -11,6 +11,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.rpsblast.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.rpsblast.app 2017-03-22 20:00:15.808170999 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.rpsblast.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.rpsblast.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.rpsblast.app (working copy)
@@ -2,7 +2,7 @@
APP = rpsblast
@@ -117,16 +76,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -11,6 +11,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.rpstblastn.app.ori 2017-03-22 19:57:18.063352028 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.rpstblastn.app 2017-03-22 20:00:34.328673121 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.rpstblastn.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.rpstblastn.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.rpstblastn.app (working copy)
@@ -2,7 +2,7 @@
APP = rpstblastn
@@ -136,16 +89,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -11,6 +11,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.seedtop.app.ori 2017-03-22 19:57:18.073352297 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.seedtop.app 2017-03-22 20:00:52.309160604 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.seedtop.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.seedtop.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.seedtop.app (working copy)
@@ -2,7 +2,7 @@
APP = seedtop
@@ -155,16 +102,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -11,6 +11,6 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.tblastn.app.ori 2017-03-22 19:57:18.073352297 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.tblastn.app 2017-03-22 20:01:09.669631276 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.tblastn.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.tblastn.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.tblastn.app (working copy)
@@ -4,7 +4,7 @@
APP = tblastn
@@ -174,17 +115,10 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -13,7 +13,7 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
---- ncbi_cxx--18_0_0/src/app/blast/Makefile.tblastx.app.ori 2017-03-22 19:57:18.073352297 +0100
-+++ ncbi_cxx--18_0_0/src/app/blast/Makefile.tblastx.app 2017-03-22 20:01:23.860016002 +0100
+Index: c++.18.0.0/src/app/blast/Makefile.tblastx.app
+===================================================================
+--- c++.18.0.0/src/app/blast/Makefile.tblastx.app (revision 523253)
++++ c++.18.0.0/src/app/blast/Makefile.tblastx.app (working copy)
@@ -4,7 +4,7 @@
APP = tblastx
@@ -194,12 +128,3 @@
LIB = blast_app_util $(LIB_:%=%$(STATIC))
# De-universalize Mac builds to work around a PPC toolchain limitation
-@@ -13,7 +13,7 @@
- LDFLAGS = $(FAST_LDFLAGS:ppc=i386)
-
- CPPFLAGS = -DNCBI_MODULE=BLAST $(ORIG_CPPFLAGS)
--LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(DL_LIBS) $(NETWORK_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
-
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-srcchk-linking.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-srcchk-linking.patch
index 2568662f5..49a4adb4e 100644
--- a/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-srcchk-linking.patch
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-18.0.0-fix-srcchk-linking.patch
@@ -1,5 +1,7 @@
---- ncbi_cxx--18_0_0/src/app/srcchk/Makefile.srcchk.app.ori 2017-03-24 04:08:42.723928634 +0100
-+++ ncbi_cxx--18_0_0/src/app/srcchk/Makefile.srcchk.app 2017-03-24 04:10:00.687004260 +0100
+Index: c++.18.0.0/src/app/srcchk/Makefile.srcchk.app
+===================================================================
+--- c++.18.0.0/src/app/srcchk/Makefile.srcchk.app (revision 523253)
++++ c++.18.0.0/src/app/srcchk/Makefile.srcchk.app (working copy)
@@ -8,8 +8,8 @@
APP = srcchk
@@ -9,8 +11,5 @@
+LIB = xobjwrite $(XFORMAT_LIBS) variation_utils $(OBJREAD_LIBS) xalnmgr \
+ xobjutil entrez2cli entrez2 tables xregexp $(PCRE_LIB) $(OBJMGR_LIBS)
--LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)
-+LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(PCRE_LIBS) $(ORIG_LIBS)
-
- REQUIRES = objects -Cygwin
+ LIBS = $(CMPRS_LIBS) $(NETWORK_LIBS) $(DL_LIBS) $(ORIG_LIBS)