aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2013-01-07 18:07:51 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2013-01-07 18:07:51 +0100
commitcd1e9304f788b93e10e6efe79580395d9cc04160 (patch)
tree4e6b5b029da0c77d9083e9db9b14c307a0b51a77 /sci-biology/ncbi-tools++/files
parentdev-lang/julia fix version in previous update (diff)
downloadsci-cd1e9304f788b93e10e6efe79580395d9cc04160.tar.gz
sci-cd1e9304f788b93e10e6efe79580395d9cc04160.tar.bz2
sci-cd1e9304f788b93e10e6efe79580395d9cc04160.zip
sci-biology/ncbi-tools++-9.0.0: although masked a not passing repoman checks this ebuild works for me, finally. All patches from upstream.
Diffstat (limited to 'sci-biology/ncbi-tools++/files')
-rw-r--r--sci-biology/ncbi-tools++/files/make_install.patch22
-rw-r--r--sci-biology/ncbi-tools++/files/report_project_settings_configure.ac.patch64
-rw-r--r--sci-biology/ncbi-tools++/files/report_project_settings_configure.patch66
-rw-r--r--sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.ac.patch54
-rw-r--r--sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.patch53
5 files changed, 259 insertions, 0 deletions
diff --git a/sci-biology/ncbi-tools++/files/make_install.patch b/sci-biology/ncbi-tools++/files/make_install.patch
new file mode 100644
index 000000000..081d99bea
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/make_install.patch
@@ -0,0 +1,22 @@
+The C++ Toolkit now includes a copy of the SRA Toolkit, which
+establishes an ncbi/ hierarchy under lib, which previously had no
+subdirectories. Please try the following patch to the top Makefile (and
+its progenitor, src/build-system/Makefile.in.top):
+
+Index: Makefile.in.top
+===================================================================
+--- Makefile.in.top (revision 358093)
++++ Makefile.in.top (working copy)
+@@ -39,7 +39,10 @@
+ -$(RMDIR) $(pincludedir)
+ $(INSTALL) -d $(bindir) $(libdir) $(pincludedir)
+ $(INSTALL) $(lbindir)/* $(bindir)
+- $(INSTALL) -m 644 $(llibdir)/* $(libdir)
++ $(INSTALL) -m 644 $(llibdir)/*.* $(libdir)
++ if test -d $(llibdir)/ncbi; then \
++ cp -pPR $(llibdir)/ncbi $(libdir)/; \
++ fi
+ -rm -f $(libdir)/lib*-static.a
+ cd $(libdir) && \
+ for x in *.a; do ln -s "$$x" "`basename \"$$x\" .a`-static.a"; done
+
diff --git a/sci-biology/ncbi-tools++/files/report_project_settings_configure.ac.patch b/sci-biology/ncbi-tools++/files/report_project_settings_configure.ac.patch
new file mode 100644
index 000000000..41240c330
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/report_project_settings_configure.ac.patch
@@ -0,0 +1,64 @@
+--- trunk/c++/src/build-system/configure.ac 2012/12/27 15:43:29 56694
++++ trunk/c++/src/build-system/configure.ac 2013/01/03 03:16:14 56754
+@@ -605,7 +605,8 @@
+ fi
+
+ case "$with_projects" in
+- "") if test -r projects; then
++ ""|yes)
++ if test -r projects; then
+ AC_MSG_NOTICE([using default projects file "projects".])
+ with_projects=projects
+ AC_SUBST(PROJECTS, "\$(top_srcdir)/projects")
+@@ -623,6 +624,16 @@
+ * ) AC_SUBST(PROJECTS, "\$(top_srcdir)/$with_projects") ;;
+ esac
+
++if test -n "$with_projects"; then
++ case "$with_projects" in
++ /* ) abs_projects=$with_projects ;;
++ yes) abs_projects=$srcdir/projects ;;
++ * ) abs_projects=$srcdir/$with_projects ;;
++ esac
++ test -r "$abs_projects" || \
++ AC_MSG_ERROR([unable to read requested projects file "$abs_projects".])
++fi
++
+ # Check for custom optimization flags before potentially going with defaults.
+ skip_fast_flags=no
+ if test -z "${DEF_FAST_FLAGS}${FAST_CXXFLAGS}"; then
+@@ -6379,7 +6390,7 @@
+ sep=", "
+ fi
+ if test -n "$reason" -a "$with_internal" = "yes"; then
+- if test -z "$with_projects" -o "$with_projects" = "no"; then
++ if test -z "$with_projects"; then
+ AC_MSG_ERROR([--with-internal: Cannot build INTERNAL projects: missing $reason])
+ else
+ AC_MSG_WARN([--with-internal: Cannot build all INTERNAL projects: missing $reason])
+@@ -6982,11 +6993,9 @@
+ else
+ cfm_flags='-remoteptb'
+ fi
+- case "$with_projects" in
+- yes ) cfm_flags="$cfm_flags -p projects" ;;
+- no | '' ) ;;
+- * ) cfm_flags="$cfm_flags -p $with_projects" ;;
+- esac
++ if test -n "$with_projects"; then
++ cfm_flags="$cfm_flags -p $with_projects"
++ fi
+ if test "$with_configure_dialog" = yes; then
+ cfm_flags="$cfm_flags -cfg"
+ fi
+@@ -7029,7 +7038,8 @@
+ esac
+
+ if test -n "$with_projects"; then
+- build_proj="To build selected projects: cd $builddir && make all_p"
++ build_proj="To build selected projects (as listed in \"$with_projects\"):
++ cd $builddir && make all_p"
+ fi
+
+ cat << EOCONF
+
diff --git a/sci-biology/ncbi-tools++/files/report_project_settings_configure.patch b/sci-biology/ncbi-tools++/files/report_project_settings_configure.patch
new file mode 100644
index 000000000..0c1b2d227
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/report_project_settings_configure.patch
@@ -0,0 +1,66 @@
+-- trunk/c++/src/build-system/configure 2012/12/27 15:43:29 56694
++++ trunk/c++/src/build-system/configure 2013/01/03 03:16:14 56754
+@@ -3125,7 +3125,8 @@
+ fi
+
+ case "$with_projects" in
+- "") if test -r projects; then
++ ""|yes)
++ if test -r projects; then
+ { echo "$as_me:$LINENO: using default projects file \"projects\"." >&5
+ echo "$as_me: using default projects file \"projects\"." >&6;}
+ with_projects=projects
+@@ -3151,6 +3152,18 @@
+ ;;
+ esac
+
++if test -n "$with_projects"; then
++ case "$with_projects" in
++ /* ) abs_projects=$with_projects ;;
++ yes) abs_projects=$srcdir/projects ;;
++ * ) abs_projects=$srcdir/$with_projects ;;
++ esac
++ test -r "$abs_projects" || \
++ { { echo "$as_me:$LINENO: error: unable to read requested projects file \"$abs_projects\"." >&5
++echo "$as_me: error: unable to read requested projects file \"$abs_projects\"." >&2;}
++ { (exit 1); exit 1; }; }
++fi
++
+ # Check for custom optimization flags before potentially going with defaults.
+ skip_fast_flags=no
+ if test -z "${DEF_FAST_FLAGS}${FAST_CXXFLAGS}"; then
+@@ -33825,7 +33838,7 @@
+ sep=", "
+ fi
+ if test -n "$reason" -a "$with_internal" = "yes"; then
+- if test -z "$with_projects" -o "$with_projects" = "no"; then
++ if test -z "$with_projects"; then
+ { { echo "$as_me:$LINENO: error: --with-internal: Cannot build INTERNAL projects: missing $reason" >&5
+ echo "$as_me: error: --with-internal: Cannot build INTERNAL projects: missing $reason" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -36062,11 +36075,9 @@
+ else
+ cfm_flags='-remoteptb'
+ fi
+- case "$with_projects" in
+- yes ) cfm_flags="$cfm_flags -p projects" ;;
+- no | '' ) ;;
+- * ) cfm_flags="$cfm_flags -p $with_projects" ;;
+- esac
++ if test -n "$with_projects"; then
++ cfm_flags="$cfm_flags -p $with_projects"
++ fi
+ if test "$with_configure_dialog" = yes; then
+ cfm_flags="$cfm_flags -cfg"
+ fi
+@@ -36110,7 +36121,8 @@
+ esac
+
+ if test -n "$with_projects"; then
+- build_proj="To build selected projects: cd $builddir && make all_p"
++ build_proj="To build selected projects (as listed in \"$with_projects\"):
++ cd $builddir && make all_p"
+ fi
+
+ cat << EOCONF
+
diff --git a/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.ac.patch b/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.ac.patch
new file mode 100644
index 000000000..89dae23ad
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.ac.patch
@@ -0,0 +1,54 @@
+--- trunk/c++/src/build-system/configure.ac 2012/12/21 15:12:14 56664
++++ trunk/c++/src/build-system/configure.ac 2012/12/27 15:43:29 56694
+@@ -623,6 +623,13 @@
+ * ) AC_SUBST(PROJECTS, "\$(top_srcdir)/$with_projects") ;;
+ esac
+
++# Check for custom optimization flags before potentially going with defaults.
++skip_fast_flags=no
++if test -z "${DEF_FAST_FLAGS}${FAST_CXXFLAGS}"; then
++ case " $CFLAGS $CXXFLAGS" in
++ *\ -O* | *\ -xO* ) skip_fast_flags=yes ;;
++ esac
++fi
+
+ #### Always define this
+ AC_DEFINE(NCBI_CXX_TOOLKIT, 1, [This is the NCBI C++ Toolkit.])
+@@ -1431,7 +1438,7 @@
+ wsrx="[[$wschars]]"
+
+ #### Flags to enable (potentially unsafe) extra optimization.
+-if test -z "$DEF_FAST_FLAGS" -o -z "$FAST_CXXFLAGS" ; then
++if test "$skip_fast_flags" = no -a -z "$DEF_FAST_FLAGS" ; then
+ case "$compiler:$compiler_version" in
+ GCC:2* | GCC:344 )
+ # GCC 2.9x sometimes experiences internal errors at high optimization;
+@@ -1502,8 +1509,6 @@
+ DEF_FAST_FLAGS="-O"
+ ;;
+ esac
+-else
+- DEF_FAST_FLAGS="-O"
+ fi
+
+ : ${FAST_CFLAGS="$DEF_FAST_FLAGS"}
+@@ -2608,9 +2613,15 @@
+ CXXFLAGS="$CXXFLAGS -O" ; fi
+ if echo " $LDFLAGS " | grep -v "$optrx" >/dev/null ; then
+ LDFLAGS="$LDFLAGS -O" ; fi
+- FAST_CFLAGS="$NOPT_CFLAGS $FAST_CFLAGS"
+- FAST_CXXFLAGS="$NOPT_CXXFLAGS $FAST_CXXFLAGS"
+- FAST_LDFLAGS="$NOPT_LDFLAGS $FAST_LDFLAGS"
++ if test "$skip_fast_flags" = yes ; then
++ FAST_CFLAGS="$CFLAGS"
++ FAST_CXXFLAGS="$CXXFLAGS"
++ FAST_LDFLAGS="$LDFLAGS"
++ else
++ FAST_CFLAGS="$NOPT_CFLAGS $FAST_CFLAGS"
++ FAST_CXXFLAGS="$NOPT_CXXFLAGS $FAST_CXXFLAGS"
++ FAST_LDFLAGS="$NOPT_LDFLAGS $FAST_LDFLAGS"
++ fi
+ fi
+ changequote([, ])dnl
+ fi
+
diff --git a/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.patch b/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.patch
new file mode 100644
index 000000000..669b31722
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/respect_CXXFLAGS_configure.patch
@@ -0,0 +1,53 @@
+--- trunk/c++/src/build-system/configure 2012/12/21 15:12:14 56664
++++ trunk/c++/src/build-system/configure 2012/12/27 15:43:29 56694
+@@ -3151,6 +3151,13 @@
+ ;;
+ esac
+
++# Check for custom optimization flags before potentially going with defaults.
++skip_fast_flags=no
++if test -z "${DEF_FAST_FLAGS}${FAST_CXXFLAGS}"; then
++ case " $CFLAGS $CXXFLAGS" in
++ *\ -O* | *\ -xO* ) skip_fast_flags=yes ;;
++ esac
++fi
+
+ #### Always define this
+
+@@ -5715,7 +5722,7 @@
+ wsrx="[$wschars]"
+
+ #### Flags to enable (potentially unsafe) extra optimization.
+-if test -z "$DEF_FAST_FLAGS" -o -z "$FAST_CXXFLAGS" ; then
++if test "$skip_fast_flags" = no -a -z "$DEF_FAST_FLAGS" ; then
+ case "$compiler:$compiler_version" in
+ GCC:2* | GCC:344 )
+ # GCC 2.9x sometimes experiences internal errors at high optimization;
+@@ -5786,8 +5793,6 @@
+ DEF_FAST_FLAGS="-O"
+ ;;
+ esac
+-else
+- DEF_FAST_FLAGS="-O"
+ fi
+
+ : ${FAST_CFLAGS="$DEF_FAST_FLAGS"}
+@@ -8936,9 +8941,15 @@
+ CXXFLAGS="$CXXFLAGS -O" ; fi
+ if echo " $LDFLAGS " | grep -v "$optrx" >/dev/null ; then
+ LDFLAGS="$LDFLAGS -O" ; fi
+- FAST_CFLAGS="$NOPT_CFLAGS $FAST_CFLAGS"
+- FAST_CXXFLAGS="$NOPT_CXXFLAGS $FAST_CXXFLAGS"
+- FAST_LDFLAGS="$NOPT_LDFLAGS $FAST_LDFLAGS"
++ if test "$skip_fast_flags" = yes ; then
++ FAST_CFLAGS="$CFLAGS"
++ FAST_CXXFLAGS="$CXXFLAGS"
++ FAST_LDFLAGS="$LDFLAGS"
++ else
++ FAST_CFLAGS="$NOPT_CFLAGS $FAST_CFLAGS"
++ FAST_CXXFLAGS="$NOPT_CXXFLAGS $FAST_CXXFLAGS"
++ FAST_LDFLAGS="$NOPT_LDFLAGS $FAST_LDFLAGS"
++ fi
+ fi
+ fi
+