aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-04-28 11:25:13 -0400
committerHorea Christian <chr@chymera.eu>2022-04-28 11:25:13 -0400
commit385a7b2400c1057978747c93eb8a6194911ccbf0 (patch)
treebae5fa34eecec94f0c326b05da0f38f0e08249eb /sci-biology/nilearn/nilearn-0.9.1.ebuild
parentdev-python/llvmlite: LLVM_MAX_SLOT bump (diff)
downloadsci-385a7b2400c1057978747c93eb8a6194911ccbf0.tar.gz
sci-385a7b2400c1057978747c93eb8a6194911ccbf0.tar.bz2
sci-385a7b2400c1057978747c93eb8a6194911ccbf0.zip
sci-biology/nilearn: version bump and working tests
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology/nilearn/nilearn-0.9.1.ebuild')
-rw-r--r--sci-biology/nilearn/nilearn-0.9.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-biology/nilearn/nilearn-0.9.1.ebuild b/sci-biology/nilearn/nilearn-0.9.1.ebuild
new file mode 100644
index 000000000..71fce4b3f
--- /dev/null
+++ b/sci-biology/nilearn/nilearn-0.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
+HOMEPAGE="http://nilearn.github.io/"
+SRC_URI="https://github.com/nilearn/nilearn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/joblib-0.15[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-3[${PYTHON_USEDEP}]
+ >=sci-libs/scikit-learn-0.22[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}/${P}-tests.patch" )
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ "examples/05_glm_second_level/plot_second_level_association_test.py"
+ "examples/05_glm_second_level/plot_second_level_one_sample_test.py"
+ "examples/05_glm_second_level/plot_second_level_two_sample_test.py"
+)
+EPYTEST_DESELECT=(
+ "nilearn/interfaces/fmriprep/tests/test_load_confounds.py::test_nilearn_standardize[False-True-zscore]"
+ "nilearn/interfaces/fmriprep/tests/test_load_confounds.py::test_nilearn_standardize[False-True-psc]"
+ "nilearn/interfaces/fmriprep/tests/test_load_confounds.py::test_nilearn_standardize[True-True-zscore]"
+ "nilearn/interfaces/fmriprep/tests/test_load_confounds.py::test_nilearn_standardize[True-True-psc]"
+)
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. epytest
+}