aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-09-23 15:16:23 +0200
committerJustin Lecher <jlec@gentoo.org>2016-09-23 14:16:23 +0100
commit96e2cb78a44557e310b7e0407de0e4c440a812e5 (patch)
tree8ef57f1353d27457442f4e3c0ba4df180ee4083a /sci-biology/nireg
parentsci-biology/nitime: new ebuild (#679) (diff)
downloadsci-96e2cb78a44557e310b7e0407de0e4c440a812e5.tar.gz
sci-96e2cb78a44557e310b7e0407de0e4c440a812e5.tar.bz2
sci-96e2cb78a44557e310b7e0407de0e4c440a812e5.zip
sci-biology/nireg:new ebuild (#680)
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology/nireg')
-rw-r--r--sci-biology/nireg/metadata.xml15
-rw-r--r--sci-biology/nireg/nireg-9999.ebuild33
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/nireg/metadata.xml b/sci-biology/nireg/metadata.xml
new file mode 100644
index 000000000..0885cf813
--- /dev/null
+++ b/sci-biology/nireg/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Nireg is a package for nytive-python image registration.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/nireg/nireg-9999.ebuild b/sci-biology/nireg/nireg-9999.ebuild
new file mode 100644
index 000000000..15cc644ca
--- /dev/null
+++ b/sci-biology/nireg/nireg-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Image registration package for Python."
+HOMEPAGE="http://nipy.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/nipy/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+KEYWORDS=""
+
+COMMONDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${COMMONDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND="${COMMONDEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ #nosetests -v || die
+ python -c "import nireg; nireg.test()" || die
+}