aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-02-13 22:50:14 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-02-13 22:50:14 +0100
commitdb6da9e797597d6c9ea43fce8adf4af218c013fc (patch)
tree620c8a26dcc3b26ec01e23c5caeb65088147e17e /sci-biology/primerD
parentfix Gentoo copyright header (diff)
downloadsci-db6da9e797597d6c9ea43fce8adf4af218c013fc.tar.gz
sci-db6da9e797597d6c9ea43fce8adf4af218c013fc.tar.bz2
sci-db6da9e797597d6c9ea43fce8adf4af218c013fc.zip
edit the bundled Makefile
Package-Manager: portage-2.2.15
Diffstat (limited to 'sci-biology/primerD')
-rw-r--r--sci-biology/primerD/ChangeLog5
-rw-r--r--sci-biology/primerD/primerD-1.0.0.ebuild13
2 files changed, 17 insertions, 1 deletions
diff --git a/sci-biology/primerD/ChangeLog b/sci-biology/primerD/ChangeLog
index 55298f3cb..f98ebf861 100644
--- a/sci-biology/primerD/ChangeLog
+++ b/sci-biology/primerD/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Feb 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ primerD-1.0.0.ebuild:
+ edit the bundled Makefile
+
10 Jan 2015; Justin Lecher <jlec@gentoo.org> primerD-1.0.0.ebuild:
Fix license
@@ -10,4 +14,3 @@
07 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+primerD-1.0.0.ebuild, +metadata.xml:
ebuild skeleton
-
diff --git a/sci-biology/primerD/primerD-1.0.0.ebuild b/sci-biology/primerD/primerD-1.0.0.ebuild
index 2dbabc88f..a77c03977 100644
--- a/sci-biology/primerD/primerD-1.0.0.ebuild
+++ b/sci-biology/primerD/primerD-1.0.0.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit toolchain-funcs
+
DESCRIPTION="Design degenerate primers"
HOMEPAGE="http://mblab.wustl.edu/software.html"
SRC_URI="http://mblab.wustl.edu/software/download/primerD.tar.gz -> primerD-1.0.tar.gz"
@@ -12,3 +14,14 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
IUSE=""
+
+S="${WORKDIR}"/primerD
+
+src_prepare(){
+ sed -e "s:CC=g++:CC=$(tc-getCXX):; s:-Wall -g:${CFLAGS}:" -i Makefile || die
+}
+
+src_install(){
+ dodoc README
+ dobin primerD
+}