aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2010-11-08 20:29:35 +0100
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2010-11-08 20:29:35 +0100
commite0d2de0457e71cb19d08cf8e8c78d28c2dbd190c (patch)
tree0f2053fa45f500af51f6542136f9cb3855d12c75 /sci-biology/quicktree/quicktree-1.1-r1.ebuild
parent[sci-biology/codonw] Respect CC,CFLAGS,LDFLAGS. Add missing die. Drop empty d... (diff)
downloadsci-e0d2de0457e71cb19d08cf8e8c78d28c2dbd190c.tar.gz
sci-e0d2de0457e71cb19d08cf8e8c78d28c2dbd190c.tar.bz2
sci-e0d2de0457e71cb19d08cf8e8c78d28c2dbd190c.zip
[sci-biology/quicktree] Respect CC,CFLAGS,LDFLAGS. Drop empty deps, add missing die. Fix SRC_URI wrt bug 344715. Thanks to Joel Berendzen <joelb@lanl.gov> for the report.
Diffstat (limited to 'sci-biology/quicktree/quicktree-1.1-r1.ebuild')
-rw-r--r--sci-biology/quicktree/quicktree-1.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/quicktree/quicktree-1.1-r1.ebuild b/sci-biology/quicktree/quicktree-1.1-r1.ebuild
new file mode 100644
index 000000000..99053dc6f
--- /dev/null
+++ b/sci-biology/quicktree/quicktree-1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/fasttree/fasttree-2.0.1.ebuild,v 1.1 2009/09/10 23:14:22 weaver Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Rapid reconstruction of phylogenies by the Neighbor-Joining method"
+HOMEPAGE="http://www.sanger.ac.uk/Software/analysis/quicktree/"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub4/resources/software/quicktree/quicktree.tar.gz -> quicktree-${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_prepare() {
+ sed -e "s/\-O2 \-Wall/${CFLAGS}/" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin bin/quicktree || die
+ dodoc README || die
+}