aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-30 19:17:50 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-30 19:17:50 +0200
commitdbff72983c149c6901adfa99351d1e0fa83e7bfe (patch)
tree35105dc8df4fd17bad967fb19e9c84c86f0f3f89 /sci-biology/reapr/reapr-1.0.18.ebuild
parentsci-biology/exomiser-bin: improve ebuild, fix LICENSE, a 19GB files should be... (diff)
downloadsci-dbff72983c149c6901adfa99351d1e0fa83e7bfe.tar.gz
sci-dbff72983c149c6901adfa99351d1e0fa83e7bfe.tar.bz2
sci-dbff72983c149c6901adfa99351d1e0fa83e7bfe.zip
sci-biology/reapr: new package with bundled samtools, bamtools, tabix (nowadays part of samtools) and other binaries; does not link probably due to a clash of symbols with my system-wide installed -lbamtools
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-biology/reapr/reapr-1.0.18.ebuild')
-rw-r--r--sci-biology/reapr/reapr-1.0.18.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/reapr/reapr-1.0.18.ebuild b/sci-biology/reapr/reapr-1.0.18.ebuild
new file mode 100644
index 000000000..312219abb
--- /dev/null
+++ b/sci-biology/reapr/reapr-1.0.18.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Verify and correct genome assembly scaffolds using paired-end reads"
+HOMEPAGE="http://www.sanger.ac.uk/science/tools/reapr"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/reapr/Reapr_${PV}.tar.gz
+ ftp://ftp.sanger.ac.uk/pub/resources/software/reapr/Reapr_1.0.18.manual.pdf"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="" # does not link against -lbamtools
+IUSE=""
+
+# tested smalt versions 0.6.4 to 0.7.0.1 only
+DEPEND="sci-biology/bamtools
+ =sci-biology/samtools-0.1.19-r2" # actually bundled is 0.1.18
+RDEPEND="${DEPEND}"
+# sci-biology/smalt
+# dev-perl/File-Basename
+# dev-perl/File-Copy
+# dev-perl/File-Spec
+# perl-core/Getopt-Long
+# dev-perl/List-Util
+# dev-lang/R"
+
+S="${WORKDIR}"/Reapr_"${PV}"
+
+src_prepare(){
+ sed -e 's#^CC = g++#CXX ?= g++#' -i src/Makefile || die
+ sed -e 's#$(CC)#$(CXX)#' -i src/Makefile || die
+ sed -e 's#-O3##' -i src/Makefile || die
+ sed -e 's#^CFLAGS =#CXXFLAGS += -I../third_party/bamtools/src -L../third_party/bamtools/src#' -i src/Makefile || die
+ #sed -e 's#-lbamtools#../third_party/bamtools/src/libbamtools.so#' -i src/Makefile || die
+ sed -e 's#-ltabix#../third_party/tabix/libtabix.a#' -i src/Makefile || die
+ sed -e 's#CFLAGS#CXXFLAGS#' -i src/Makefile || die
+}
+
+src_compile(){
+ cd third_party/tabix || die
+ emake # to yield tabix.o object
+ cd ../.. || die
+ cd src || die
+ emake # link directly tabix.o but elsewhere also ../third_party/tabix/libtabix.a
+}
+
+src_install(){
+ dodoc "${DISTDIR}"/Reapr_"${PV}".manual.pdf
+}
+
+pkg_postinst(){
+ einfo "There are test data at ftp://ftp.sanger.ac.uk/pub/resources/software/reapr/Reapr_${PV}.test_data.tar.gz"
+ einfo "You can view results with >=sci-biology/artemis*-15.0.0"
+}