aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 21:21:18 +0100
committerJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 22:57:41 +0100
commit2b0744a231b93f5e09b63375005fb6e522999c9a (patch)
tree0253a3f50b0ee618db1f6e6061d4b14fb06a0792 /sci-biology/rnaplex
parentsci-biology/mrfast: Port to EAPI 7 (diff)
downloadsci-2b0744a231b93f5e09b63375005fb6e522999c9a.tar.gz
sci-2b0744a231b93f5e09b63375005fb6e522999c9a.tar.bz2
sci-2b0744a231b93f5e09b63375005fb6e522999c9a.zip
sci-biology/rnaplex: Port to EAPI 7
Closes: https://bugs.gentoo.org/755770 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
Diffstat (limited to 'sci-biology/rnaplex')
-rw-r--r--sci-biology/rnaplex/files/rnaplex-0.2-inline.patch14
-rw-r--r--sci-biology/rnaplex/rnaplex-0.2.ebuild17
2 files changed, 26 insertions, 5 deletions
diff --git a/sci-biology/rnaplex/files/rnaplex-0.2-inline.patch b/sci-biology/rnaplex/files/rnaplex-0.2-inline.patch
new file mode 100644
index 000000000..30d05cd97
--- /dev/null
+++ b/sci-biology/rnaplex/files/rnaplex-0.2-inline.patch
@@ -0,0 +1,14 @@
+--- a/lib/fold.c
++++ b/lib/fold.c
+@@ -64,9 +64,9 @@ PRIVATE void backtrack(const char *sequence, int s);
+ PRIVATE int fill_arrays(const char *sequence);
+ /*@unused@*/
+ INLINE PRIVATE int oldLoopEnergy(int i, int j, int p, int q, int type, int type_2);
+-INLINE int LoopEnergy(int n1, int n2, int type, int type_2,
++int LoopEnergy(int n1, int n2, int type, int type_2,
+ int si1, int sj1, int sp1, int sq1);
+-INLINE int HairpinE(int size, int type, int si1, int sj1, const char *string);
++int HairpinE(int size, int type, int si1, int sj1, const char *string);
+
+ #define MAXSECTORS 500 /* dimension for a backtrack array */
+ #define LOCALITY 0. /* locality parameter for base-pairs */
diff --git a/sci-biology/rnaplex/rnaplex-0.2.ebuild b/sci-biology/rnaplex/rnaplex-0.2.ebuild
index 11de0007c..5892f4676 100644
--- a/sci-biology/rnaplex/rnaplex-0.2.ebuild
+++ b/sci-biology/rnaplex/rnaplex-0.2.ebuild
@@ -1,17 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-MY_P=RNAplex-${PV}
+inherit flag-o-matic
+MY_P=RNAplex-${PV}
DESCRIPTION="RNA-RNA interaction search"
HOMEPAGE="http://www.bioinf.uni-leipzig.de/Software/RNAplex/"
SRC_URI="http://www.bioinf.uni-leipzig.de/Software/RNAplex/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="~amd64 ~x86"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${P}-inline.patch )
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}